Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269328 - net-libs/opal-3.6.2 build fails with gcc 4.4.0: 'sprintf' was not declared in this scope
Summary: net-libs/opal-3.6.2 build fails with gcc 4.4.0: 'sprintf' was not declared in...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Mounir Lamouri (volkmar) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gcc-4.4
  Show dependency tree
 
Reported: 2009-05-10 21:43 UTC by Jose daLuz
Modified: 2009-07-09 09:13 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Output of paludis --info opal (opal_paludis_info.txt,24.11 KB, text/plain)
2009-05-10 21:44 UTC, Jose daLuz
Details
And here is the backported fix (opal-3.6.2-gcc44.diff,456 bytes, patch)
2009-07-07 20:05 UTC, Michał Górny
Details | Diff
and diff to ebuild (opal-3.6.2.ebuild.diff,433 bytes, patch)
2009-07-07 20:10 UTC, Michał Górny
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jose daLuz 2009-05-10 21:43:45 UTC
After upgrading gcc from 4.3.3-r2 to 4.4.0 and rebuilding world, opal
3.6.1 from the ikelos overlay no longer builds:

make[3]: Entering directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1/plugins/video/H.264'
x86_64-pc-linux-gnu-g++ -I../../../include  -I../common -I../../ -DLIB_DIR='"/usr/lib64"' -DVC_PLUGIN_DIR='"opal-3.6.1/codecs/video"' -DLICENCE_MPL -fPIC  -Os -march=native -O2 -pipe -ggdb -c ./shared/h264frame.cxx -o obj/h264frame.o
x86_64-pc-linux-gnu-g++ -I../../../include  -I../common -I../../ -DLIB_DIR='"/usr/lib64"' -DVC_PLUGIN_DIR='"opal-3.6.1/codecs/video"' -DLICENCE_MPL -fPIC  -Os -march=native -O2 -pipe -ggdb -c h264-x264.cxx -o obj/h264-x264.o
x86_64-pc-linux-gnu-g++ -I../../../include  -I../common -I../../ -DLIB_DIR='"/usr/lib64"' -DVC_PLUGIN_DIR='"opal-3.6.1/codecs/video"' -DLICENCE_MPL -fPIC  -Os -march=native -O2 -pipe -ggdb -c ../common/dyna.cxx -o obj/dyna.o
x86_64-pc-linux-gnu-g++ -I../../../include  -I../common -I../../ -DLIB_DIR='"/usr/lib64"' -DVC_PLUGIN_DIR='"opal-3.6.1/codecs/video"' -DLICENCE_MPL -fPIC  -Os -march=native -O2 -pipe -ggdb -c ../common/trace.cxx -o obj/trace.o
x86_64-pc-linux-gnu-g++ -I../../../include  -I../common -I../../ -DLIB_DIR='"/usr/lib64"' -DVC_PLUGIN_DIR='"opal-3.6.1/codecs/video"' -DLICENCE_MPL -fPIC  -Os -march=native -O2 -pipe -ggdb -c h264pipe_unix.cxx -o obj/h264pipe_unix.o
make[4]: Entering directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1/plugins/video/H.264/gpl'
x86_64-pc-linux-gnu-g++ -I../../../include -I..  -I../../common -I../../../ -fPIC  -Os -march=native -O2 -pipe -ggdb -c ../shared/h264frame.cxx -o obj/h264frame.o
x86_64-pc-linux-gnu-g++ -I../../../include -I..  -I../../common -I../../../ -fPIC  -Os -march=native -O2 -pipe -ggdb -c ../../common/trace.cxx -o obj/trace.o
x86_64-pc-linux-gnu-g++ -I../../../include -I..  -I../../common -I../../../ -fPIC  -Os -march=native -O2 -pipe -ggdb -c x264loader_unix.cxx -o obj/x264loader_unix.o
x86_64-pc-linux-gnu-g++ -I../../../include -I..  -I../../common -I../../../ -fPIC  -Os -march=native -O2 -pipe -ggdb -c h264helper_unix.cxx -o obj/h264helper_unix.o
x86_64-pc-linux-gnu-g++ -I../../../include -I..  -I../../common -I../../../ -fPIC  -Os -march=native -O2 -pipe -ggdb -c enc-ctx.cxx -o obj/enc-ctx.o
enc-ctx.cxx: In function 'void logCallbackX264(void*, int, const char*, __va_list_tag*)':
enc-ctx.cxx:54: error: 'sprintf' was not declared in this scope
enc-ctx.cxx:55: error: 'vsprintf' was not declared in this scope
make[4]: *** [obj/enc-ctx.o] Error 1
make[4]: *** Waiting for unfinished jobs....
make[4]: Leaving directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1/plugins/video/H.264/gpl'
make[3]: Leaving directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1/plugins/video/H.264'
make[3]: *** [h264_video_pwplugin.so] Error 2
make[2]: Leaving directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1/plugins'
make[2]: *** [all] Error 2
make[1]: *** [subdirs] Error 2
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory `/var/tmp/paludis/net-libs-opal-3.6.1/work/opal-3.6.1'
make: *** [opt] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in net-libs/opal-3.6.1

Portage 2.2_rc33 (default/linux/amd64/2008.0/desktop, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.29.3 x86_64)
=================================================================
System uname: Linux-2.6.29.3-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9650_@_3.00GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 09 May 2009 13:15:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.2
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.4
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r2
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j8"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/zugaina /usr/local/overlays/THE /usr/local/overlays/sunrise /usr/local/overlays/gnome /usr/local/overlays/desktop-effects /usr/local/overlays/vmware /usr/local/overlays/ikelos /usr/local/overlays/java-overlay /usr/local/overlays/berkano /usr/local/overlays/gcc-porting /usr/local/overlays/myoverlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 amr avahi bash-completion berkdb bluetooth branding bzip2 cairo cdda cdr cli cracklib crypt css cups dbus dri dts dvd dvdr dvdread eds emboss encode esd evo expat fam ffmpeg flac fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg lcms ldap libnotify mad midi mikmod mmx mono mp3 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp paludis pam pcre pdf perl pic png policykit ppds pppd pulseaudio python quicktime readline reflection ruby samba sdl session spell spl sqlite sse sse2 ssl startup-notification svg sysfs tcpd theora tiff tracker truetype unicode usb userlocales vcd vorbis x264 xcb xml xorg xulrunner xv xvid zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jose daLuz 2009-05-10 21:44:34 UTC
Created attachment 190878 [details]
Output of paludis --info opal
Comment 2 Jose daLuz 2009-05-10 23:57:46 UTC
This Fedora build log: http://koji.fedoraproject.org/koji/buildinfo?buildID=99604
indicates gcc 4.4 compilation was fixed:

* Tue Feb 10 2009 Peter Robinson <pbrobinson@gmail.com> - 3.5.2-7 - Add patches to fix gcc44 compilation, remove celt until issues are fixed upstream 

I don't know which patches are responsible but it's a place to start.
Comment 3 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-04 11:57:15 UTC
Same issue with =net-libs/opal-3.6.2 from main tree. Could you change 'Summary' to be less overlay-ish?
Comment 4 Mike Auty gentoo-dev 2009-07-04 12:01:04 UTC
Well, since this has now hit the main tree, I've removed the version from my overlay.  As there's been a report against the version in the main tree, I'm reassigning this...  5:)
Comment 5 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-06 13:55:07 UTC
Thank you for the gift Mike :)
It looks like opal-3.6.4 has some patches for gcc-4.4.0. I will wait until I bump opal to fix the bug.
Comment 6 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-07 13:21:31 UTC
(In reply to comment #5)
> It looks like opal-3.6.4 has some patches for gcc-4.4.0. I will wait until I
> bump opal to fix the bug.

Could you precise when it'll be? I think I can provide a patch for this version in a while if that would make any difference right now.
Comment 7 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-07 17:41:54 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > It looks like opal-3.6.4 has some patches for gcc-4.4.0. I will wait until I
> > bump opal to fix the bug.
> 
> Could you precise when it'll be? I think I can provide a patch for this version
> in a while if that would make any difference right now.
> 

opal-3.6.4, ptlib-2.6.4 and ekiga-3.2.5 are released so it could be in a few days. But as I'm really busy these days, it could also be in a few weeks.
So, if you want to provide gcc-4.4 patch for opal-3.6.2, it can worth the effort.

Actually, I think you can backport patches submitted to opal (search gcc in websvn) and test if they are working with opal-3.6.2.
In my opinion, as long as gcc-4.4 is masked, fixing gcc-4.4 bugs is not a priority.
Comment 8 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-07 20:05:25 UTC
Created attachment 197111 [details, diff]
And here is the backported fix
Comment 9 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-07 20:10:15 UTC
Created attachment 197112 [details, diff]
and diff to ebuild
Comment 10 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-07 21:17:12 UTC
If I recall correctly, there are 2 or 3 patches for gcc-4.4. One for theora for example.
Can you check/confirm that ?
Comment 11 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-07 22:54:15 UTC
Only searching for 'gcc' keyword, I found four patches but only this one was essential. Others were there only to remove warnings, so I decided to not waste time on them.

With this patch, opal compiles fine. There's problem with ekiga though but it also seems easy to fix. I'll take a look at it in next 16h, I think.
Comment 12 Jose daLuz 2009-07-07 23:12:06 UTC
I can confirm opal-3.6.2 from Portage builds with this patch.

Now to reopen bug 269329 and see if ekiga 3.2.4 will build.
Comment 13 Jose daLuz 2009-07-07 23:20:15 UTC
(In reply to comment #11)
> With this patch, opal compiles fine. There's problem with ekiga though but it
> also seems easy to fix. I'll take a look at it in next 16h, I think.
> 
Please see if it's the same problem I ran into in bug 269329.
Comment 14 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2009-07-07 23:22:18 UTC
(In reply to comment #13)
> (In reply to comment #11)
> > With this patch, opal compiles fine. There's problem with ekiga though but it
> > also seems easy to fix. I'll take a look at it in next 16h, I think.
> > 
> Please see if it's the same problem I ran into in bug 269329.

Yes, that's the one.
Comment 15 Mounir Lamouri (volkmar) (RETIRED) gentoo-dev 2009-07-09 09:13:33 UTC
Patch in the tree.
Thanks Michal :)