Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269250 - www-plugins/nspluginwrapper-1.0.0 fails to emerge with gcc 4.4.0
Summary: www-plugins/nspluginwrapper-1.0.0 fails to emerge with gcc 4.4.0
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal with 1 vote (vote)
Assignee: Patrick McLean
Depends on:
Blocks: gcc-4.4
  Show dependency tree
Reported: 2009-05-10 13:28 UTC by Morgan Wesström
Modified: 2010-06-19 21:25 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---

fix gcc 4.4.0 build error(use systemlibs). (nspluginwrappes-systemlibs.diff,3.01 KB, patch)
2009-06-26 12:34 UTC, hubertstar
Details | Diff
gcc 4.4.0 build fix for 1.3.0 (nspluginwrappes-1.3.0-systemlibs.diff,3.05 KB, patch)
2009-06-26 13:05 UTC, hubertstar
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Morgan Wesström 2009-05-10 13:28:15 UTC
Compilation ends with this output:

gcc -std=c99 -m32 -o npviewer.bin npviewer-npw-viewer.o npviewer-npw-rpc.o npviewer-rpc.o npviewer-debug.o npviewer-utils.o npviewer-npruntime.o npviewer-cxxabi-compat.o -m32 -Llsb-build-i386 -lgtk-x11-2.0 -lgdk-x11-2.0 -lgobject-2.0 -ldl -lglib-2.0 -lX11 -lXt -ldl -lpthread -lgthread-2.0 -Wl,--export-dynamic -Wl,--version-script,/tmp/portage/www-plugins/nspluginwrapper-1.0.0/work/nspluginwrapper-1.0.0/src/ -lsupc++
gcc -std=c99 -m32 -shared -o libxpcom-libxpcom.o libxpcom-debug.o -m32 -Llsb-build-i386 -Wl,--soname,
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0/32/libsupc++.a(cp-demangle.o): In function `d_print_comp':
(.text+0x37e6): undefined reference to `__sprintf_chk'
collect2: ld returned 1 exit status
make: *** [npviewer.bin] Error 1
rm lsb-build-i386/libXext.o lsb-build-i386/libgcc_s.o lsb-build-i386/libc_main.o lsb-build-i386/libpthread.o lsb-build-i386/libdl.o lsb-build-i386/libgobject-2.0.o lsb-build-i386/libgdk-x11-2.0.o lsb-build-i386/libgtk-x11-2.0.o lsb-build-i386/libgthread-2.0.o lsb-build-i386/libX11.o lsb-build-i386/libXt.o lsb-build-i386/libglib-2.0.o lsb-build-i386/libc_nonshared.o

I've also tried to compile 1.2.2 but it fails with similar messages. Both versions compile fine if I switch back to gcc 4.3.3.

Reproducible: Always

Steps to Reproduce:
1. switch to gcc 4.4.0
2. emerge -1 nspluginwrapper

Actual Results:  
Fails to compile complaining about "undefined reference to `__sprintf_chk'"

Expected Results:  
Should compile and install without errors.

# emerge --info
Portage 2.2_rc33 (default/linux/amd64/2008.0, gcc-4.4.0, glibc-2.9_p20081201-r2, 2.6.28-gentoo-r5-test x86_64)
System uname: Linux-2.6.28-gentoo-r5-test-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4600+-with-glibc2.2.5
Timestamp of tree: Sun, 10 May 2009 00:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.2-r1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-march=native -O2 -pipe -mfpmath=sse -ftree-vectorize"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -pipe -mfpmath=sse -ftree-vectorize"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="3dnow 3dnowext X X509 a52 aac accessibility acl acpi alsa amd64 automount bash-completion berkdb branding bzip2 cairo cdda cddb cdio cdparanoia cdr cleartype cli consolekit cracklib crypt cups dbus device-mapper dga disk-partition djvu dri dts dv dvb dvd dvdr eds encode esd fat ffmpeg flac fortran gdbm geoip gif gimp glib glitz gnome gpm gstreamer gtk hal hddtemp iconv idn imlib isdnlog java java6 jpeg lame lcms libnotify live lm_sensors lzma lzo mad matroska md5sum midi mjpeg mmx mmxext mp2 mp3 mpeg mplayer mudflap multilib musepack nautilus ncurses network nfs nls nptl nptlonly nsplugin ntfs nvidia ogg openal opengl openmp optimisememory pam pcre pdf perl png pppd python quicktime rar readline reflection reiserfs rle rtc rtsp sdl session smp source spell spl sqlite srt sse sse2 sse3 ssh ssl suid svg sysfs tcl tcpd tga threads tiff tk truetype twolame unicode usb v4l v4l2 vcd vdpau vorbis wxwindows x264 xml xorg xulrunner xv xvid xvmc yv12 zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="tda1004x" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia v4l"
Comment 1 Ryan Hill (RETIRED) gentoo-dev 2009-05-16 00:45:50 UTC
also 1.2.2
Comment 2 Patrick McLean gentoo-dev 2009-06-09 00:05:17 UTC
My knowledge of toolchain internals is somewhat limited.. I am not sure how to fix this. CC'ing toolchain to see if they have any suggestions.
Comment 3 Oschtan 2009-06-09 18:25:07 UTC
gcc -std=c99 -o test-rpc-concurrent-server test-rpc-concurrent-server.o test-rpc-common-server.o debug-server.o rpc-server.o -lglib-2.0   -lpthread
ln -sf lsb-build-i386/
gcc -std=c99 -m32 -o npviewer.bin npviewer-npw-viewer.o npviewer-npw-common.o npviewer-npw-malloc.o npviewer-npw-rpc.o npviewer-rpc.o npviewer-debug.o npviewer-utils.o npviewer-npruntime.o npviewer-cxxabi-compat.o -m32 -Llsb-build-i386 -lgtk-x11-2.0 -lgdk-x11-2.0 -lgobject-2.0 -ldl -lglib-2.0 -lX11 -lXt -ldl -lpthread -lgthread-2.0 -Wl,--export-dynamic -Wl,--version-script,/var/tmp/portage/www-plugins/nspluginwrapper-1.2.2/work/nspluginwrapper-1.2.2/src/ -lsupc++
gcc -std=c99 -m32 -shared -o libxpcom-libxpcom.o libxpcom-debug.o -m32 -Llsb-build-i386 -Wl,-soname,
gcc -std=c99 -m32 -shared -o libnoxshm-libnoxshm.o -m32 -Llsb-build-i386 -Wl,-soname,
gcc -std=c99 -Wl,-O1 -o npplayer npplayer-npw-player.o npplayer-debug.o npplayer-rpc.o npplayer-utils.o npplayer-glibcurl.o npplayer-gtk2xtbin.o -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0   -lcurl   -L/usr/lib64 -lX11 -lXt -lgthread-2.0 -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.4.0/32/libsupc++.a(cp-demangle.o): In function `d_print_comp':
(.text+0x38c6): undefined reference to `__sprintf_chk'
collect2: ld returned 1 exit status
make: *** [npviewer.bin] Error 1
make: *** Waiting for unfinished jobs....
npplayer-npw-player.o: In function `on_stream_open_cb':
npw-player.c:(.text+0x1d01): warning: the use of `tmpnam' is dangerous, better use `mkstemp'
rm test-rpc-types-server.o lsb-build-i386/libXext.o lsb-build-i386/libgdk-x11-2.0.o lsb-build-i386/libgcc_s.o test-rpc-nested-2-client.o lsb-build-i386/libc_main.o test-rpc-concurrent-client.o lsb-build-i386/libpthread.o lsb-build-i386/libdl.o lsb-build-i386/libgobject-2.0.o test-rpc-common-server.o test-rpc-common-client.o test-rpc-nested-2-server.o rpc-client.o test-rpc-types-client.o test-rpc-concurrent-server.o lsb-build-i386/libgthread-2.0.o lsb-build-i386/libX11.o debug-client.o lsb-build-i386/libgtk-x11-2.0.o rpc-server.o lsb-build-i386/libXt.o lsb-build-i386/libglib-2.0.o test-rpc-nested-1-server.o debug-server.o lsb-build-i386/libc_nonshared.o test-rpc-nested-1-client.o
 * ERROR: www-plugins/nspluginwrapper-1.2.2 failed.
Also. 1.3.0
Comment 4 hubertstar 2009-06-18 07:38:58 UTC
I can confirm it.

same error here.

anyone can fix this error?
Comment 5 hubertstar 2009-06-26 12:34:58 UTC
Created attachment 195813 [details, diff]
fix gcc 4.4.0 build error(use systemlibs).

fix gcc 4.4.0 build error.

apply this patch and build.

after emerge it, you can navigate to this URL to test acrobat pdf reader:
Comment 6 hubertstar 2009-06-26 13:05:52 UTC
Created attachment 195814 [details, diff]
gcc 4.4.0 build fix for 1.3.0

this is 1.3.0 patch.
Comment 7 Oschtan 2009-06-26 14:33:47 UTC
It's work. 1.2.2 and 1.3.0. Thanks)
Comment 8 Patrick McLean gentoo-dev 2009-07-20 20:27:20 UTC
www-plugins/nspluginwrapper-1.2.2-r1 now in tree with gcc44 patch, will not put 1.3.0 as it's considered unstable.
Comment 9 Matt 2010-06-18 20:19:18 UTC
why is every other distribution using or being able to use nspluginwrapper 1.3.0 and Gentoo is still using 1.2.2 (which now might be less well working with flash 10.1) and regarding 1.3.0 as unstable ?

anyone has tried whether 1.3.0 fixes the problem observed with 1.2.2 and adobe-flash 10.1 ?
Comment 10 SpanKY gentoo-dev 2010-06-19 21:25:41 UTC
this bug is closed and is not about version bumping.  file a new bug and/or post your question to a mailing list/forum.