Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269117 - sys-apps/hal does not include dm-raid devices in database
Summary: sys-apps/hal does not include dm-raid devices in database
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Freedesktop bugs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-09 12:08 UTC by bugzilla-gentoo
Modified: 2009-07-30 18:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla-gentoo 2009-05-09 12:08:53 UTC
When starting the hal daemon, my dm-raid devices are not added to the database. Hence I cannot use gnome-mount to mount them. Here is a snippet of the
hald debug output when starting up:

13:43:09.984 [I] blockdev.c:874: block_add: sysfs_path=/sys/block/dm-1 dev=/dev/mapper/nvidia_cjedaafj is_part=0, parent=0x00000000
13:43:09.984 [I] blockdev.c:915: Looking in /sys/block/dm-1/slaves for Device Mapper
13:43:09.984 [I] blockdev.c:926:  /sys/block/dm-1/slaves/. -> /sys/block/dm-1/slaves
13:43:09.984 [I] blockdev.c:958: Couldn't find slave volume in devices
13:43:09.985 [I] blockdev.c:926:  /sys/block/dm-1/slaves/.. -> /sys/block/dm-1
13:43:09.985 [I] blockdev.c:958: Couldn't find slave volume in devices
13:43:09.985 [I] blockdev.c:926:  /sys/block/dm-1/slaves/sda -> /sys/block/sda
13:43:09.985 [I] blockdev.c:958: Couldn't find slave volume in devices
13:43:09.985 [I] blockdev.c:926:  /sys/block/dm-1/slaves/sdb -> /sys/block/sdb
13:43:09.985 [I] blockdev.c:958: Couldn't find slave volume in devices
13:43:09.985 [I] blockdev.c:964: Done looking in /sys/block/dm-1/slaves
13:43:09.985 [I] blockdev.c:970: Ignoring hotplug event - no parent
13:43:09.985 [W] blockdev.c:1473: Not adding device object

Any nvidia_cjedaafj* partitions are not added either.

The dm-raid device nvidia_cjedaafj is created from /dev/sda and /dev/sdb. As an example the output of adding /dev/sda:

13:57:14.751 [I] osspec.c:966: hal_util_find_known_parent: '/sys/block/sda'->'/sys/devices/pci0000:00/0000:00:07.0/host0/target0:0:0/0:0:0:0'
13:57:14.751 [I] blockdev.c:874: block_add: sysfs_path=/sys/block/sda dev=/dev/sda is_part=0, parent=0x006a04e0
13:57:14.752 [I] blockdev.c:1248: parent_bus is scsi
13:57:14.752 [I] blockdev.c:502: Probing storage device /dev/sda
13:57:14.754 [D] hald_dbus.c:3294: udi=/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A
13:57:14.755 [I] hald_dbus.c:3320: AddonIsReady on udi '/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A'
13:57:14.755 [D] hald_dbus.c:3294: udi=/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A
13:57:14.755 [E] device.c:1705: In hal_device_inc_num_ready_addons for udi=/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A but all addons are already ready!
13:57:14.755 [I] hald_dbus.c:3320: AddonIsReady on udi '/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A'
[1336]: 13:57:14.755 [D] addon-storage.c:748: **************************************************
[1336]: 13:57:14.755 [D] addon-storage.c:749: Doing addon-storage for /dev/hdc (bus ide) (drive_type cdrom) (udi /org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A)
[1336]: 13:57:14.755 [D] addon-storage.c:750: **************************************************
13:57:14.756 [D] hald_dbus.c:3223: udi=/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A
13:57:14.756 [I] hald_dbus.c:3248: Local connection 0x6745e0 to handle interface 'org.freedesktop.Hal.Device.Storage.Removable' on udi '/org/freedesktop/Hal/devices/storage_model__NEC_DVD_RW_ND_4550A'
woohoo
[1337]: 13:57:14.758 [D] probe-storage.c:155: Doing probe-storage for /dev/sda (bus scsi) (drive_type disk) (udi=/org/freedesktop/Hal/devices/temp/117) (--only-check-for-fs==0)
[1337]: 13:57:14.758 [D] probe-storage.c:407: Checking for file system on /dev/sda
[1337]: 13:57:14.758 [D] probe-storage.c:413: Doing open ("/dev/sda", O_RDONLY)
[1337]: 13:57:14.758 [D] probe-storage.c:421: Returned from open(2)
[1337]: 13:57:14.758 [D] probe-storage.c:437: look for existing partitions for sda
[1337]: 13:57:14.758 [D] probe-storage.c:447: partition sda1 found, skip probing for filesystem
[1337]: 13:57:14.758 [I] partutil.c:446: No MSDOS_MAGIC found
[1337]: 13:57:14.758 [I] partutil.c:873: MSDOS partition table detected
13:57:14.759 [I] hald_dbus.c:1366: storage.removable.media_available -> True
13:57:14.759 [I] hald_dbus.c:1350: storage.removable.media_size -> 1000204886016
13:57:14.759 [I] hald_dbus.c:1334: storage.partitioning_scheme -> mbr
13:57:14.760 [I] blockdev.c:387: entering; exit_type=0, return_code=0
13:57:14.763 [I] blockdev.c:141: Add callouts completed udi=/org/freedesktop/Hal/devices/storage_serial_SATA_WDC_WD10EADS_00_WD_WCAU45177909
13:57:14.763 [D] device_store.c:516: adding 0x6c5ce0 to (linux.sysfs_path,/sys/block/sda)

Reproducible: Always

Steps to Reproduce:

Actual Results:  
$ lshal | grep nvidia_cjedaafj
[no output]
$

Expected Results:  
The dm-raid devices nvidia_cjedaafj* should be added to the hal database.

I have sys-fs/udev-124-r2 and sys-apps/hal-0.5.11-r8 installed.
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-05-09 23:54:34 UTC
stupid question but do you have dmraid tools installed ? (you can check by installed gparted with USE="dmraid")
Comment 2 bugzilla-gentoo 2009-05-10 01:07:06 UTC
I do have dmraid installed. Nevertheless I installed (unstable) gparted with USE flag dmraid and gparted recognizes my raid devices properly. Unfortunately hald still does not recognize them.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-05-10 09:25:41 UTC
btw, does your issue look like bug #262981 ?
Comment 4 bugzilla-gentoo 2009-05-10 15:22:12 UTC
It might be related, however I use the stable hal version and nevertheless it does not work:

[ebuild   R   ] sys-apps/hal-0.5.11-r8  USE="X acpi crypt -apm -debug -dell -disk-partition -doc -laptop (-selinux)" 0 kB
Comment 5 bugzilla-gentoo 2009-05-14 19:37:46 UTC
Bump. Should I report upstream?
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-07-28 22:58:10 UTC
looks like upstream won't do any effort to add this feature. Did it ever worked ? If it did, you should point that fact to upstream.
Comment 7 bugzilla-gentoo 2009-07-29 18:15:21 UTC
(In reply to comment #6)
> looks like upstream won't do any effort to add this feature. Did it ever worked
> ? If it did, you should point that fact to upstream.

Nope they won't. See here:

http://lists.freedesktop.org/archives/hal/2009-June/013432.html

Hal seems to be in the process of being deprecated and thus no more features are added. It seems to be replaced by DeviceKit and libudev.

http://lists.freedesktop.org/archives/hal/2008-May/011560.html
http://lists.freedesktop.org/archives/devkit-devel/2009-April/000140.html

But nevertheless good news: As Kay Sievers points it out in his reply to my upstream posting:

> Current work focuses on the device-mapper
> udev integration regarding this problem

And no it never worked afaik.
Comment 8 Rémi Cardona gentoo-dev 2009-07-29 18:41:44 UTC
Indeed, HAL will just get bug fixes from now on. Now is probably the best time to get in touch with DeviceKit-disk upstream to make sure that it will properly support dm-raid devices.

Closing. Thanks
Comment 9 bugzilla-gentoo 2009-07-30 18:46:25 UTC
(In reply to comment #8)
> Indeed, HAL will just get bug fixes from now on. Now is probably the best time
> to get in touch with DeviceKit-disk upstream to make sure that it will properly
> support dm-raid devices.

For convenience in case somebody reads this:
http://lists.freedesktop.org/archives/devkit-devel/2009-July/000391.html

This issue seems to be almost sorted out in DeviceKit-disks.