Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 269017 - app-emulation/kvm-85-r1 hangs on shutdown of windows xp or windows 2000 guests
Summary: app-emulation/kvm-85-r1 hangs on shutdown of windows xp or windows 2000 guests
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo QEMU Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-08 10:02 UTC by David Williams
Modified: 2010-06-10 19:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Williams 2009-05-08 10:02:17 UTC
When I shut down a windows guest windows goes through it's shutdown procedure the window goes blank but doesn't close. If I forget to press Ctrl+alt during shutdown I can't get the mouse back. A Windows restart works fine within the virtual machine so I don't think it's a purely Windows problem, especially as the same thinng happens in 2000 and XP.

Assuming I remember to get the mouse back I still can't close the window normally although it will minimize. I can only get rid of with 

killall -s KILL kvm

the normal SIGTERM doesn't work.

Reproducible: Always




I have tried a 2.6.28 kernel, 2.6.29-gentoo-r1 and currently 2.6.29-gentoo-r2. I am using the kernel kvm modules as I couldn't get the included modules to work.

emerge --info follows
Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r3 i686)
=================================================================
System uname: Linux-2.6.29-gentoo-r3-i686-AMD_Athlon-tm-_64_Processor_3200+-with-glibc2.0
Timestamp of tree: Thu, 07 May 2009 15:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=k8 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe "
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en_GB en en_US"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gcc-porting /usr/local/portage"
SYNC="rsync://rsync.uk.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa amr berkdb bzip2 cairo cli cracklib crypt cups dbus dri dv dvd dvdr fam fat ffmpeg flac foomaticdb fortran gdbm gif glibc-omitfp gpm gstreamer gtk hal iconv isdnlog java jpeg kvm ldap libnotify matroska midi mmx mng mp3 mp4 mudflap ncurses nls nptl nptlonly nsplugin ntfs ogg ogm opengl openmp pam pch pcre perl png ppds pppd python quicktime readline reflection reiserfs sdl session sound spl sse sse2 ssl startup-notification sysfs tcpd theora unicode usb vorbis wavpack win32codecs x264 x86 xml xorg xvid zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_GB en en_US" USERLAND="GNU" VIDEO_CARDS="vesa fbdev radeon radeonhd"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-10 23:54:48 UTC
You can also use ctrl-c in the window that started kvm, if you have it.  I've seen this too; I believe the issue is that windows isn't using a shutdown method supported by kvm.   My research seems to indicate that it's because windows doesn't think it's running on an ACPI capable computer.  This is usually due to having installed windows with ACPI disabled (which was necessary for a while to work around an installer bug).  You can try to enable ACPI by following this:
http://support.microsoft.com/kb/810903
but reports are that it doesn't work, and that a re-install is necessary on an ACPI enabled kvm.

I'll try my win2k install when I get a chance, to see if I can fix it here.
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-05-11 00:09:51 UTC
Okay, for my win2k install, it was sufficient to open control center, open Power settings, and on APM, click the Advanced Power Management.  That made shutdown actually power off the VM.
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2009-09-21 15:02:23 UTC
I can't maintain kvm anymore.
Comment 4 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2010-06-10 19:57:55 UTC
The old kvm ebuilds have been dropped from the tree quite sometime ago.
If anyone can duplicate this issue on the latest qemu-kvm ebuilds, please open a new bug.