Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 268805 - dev-python/jinja2[doc], dev-python/sphinx: Circular dependencies
Summary: dev-python/jinja2[doc], dev-python/sphinx: Circular dependencies
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High minor with 1 vote (vote)
Assignee: Python Gentoo Team
URL:
Whiteboard:
Keywords:
: 278168 285937 286311 294121 297605 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-06 11:37 UTC by tonich
Modified: 2009-12-27 19:19 UTC (History)
10 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tonich 2009-05-06 11:37:34 UTC
dev-python/jinja2-2.1.1  with USE="doc" depends on dev-python/sphinx
=dev-python/sphinx-0.6.1 depends on dev-python/jinja2

Reproducible: Always

Steps to Reproduce:
1. emerge -C jinja2 dev-python/sphinx
2. USE="doc" emerge dev-python/sphinx
3.

Actual Results:  
Calculating dependencies... done!


[nomerge      ] dev-python/sphinx-0.6.1  USE="doc -test" 
[ebuild  N    ]  dev-python/jinja2-2.1.1  USE="doc examples i18n -test" 
[ebuild  N    ]   dev-python/sphinx-0.6.1  USE="doc -test" 

 * Error: circular dependencies:

('ebuild', '/', 'dev-python/sphinx-0.6.1', 'merge') depends on
  ('ebuild', '/', 'dev-python/jinja2-2.1.1', 'merge') (buildtime)
('ebuild', '/', 'dev-python/jinja2-2.1.1', 'merge') depends on
  ('ebuild', '/', 'dev-python/sphinx-0.6.1', 'merge') (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



to avoid this problem jinja2 will be splitted into two packages: jinja2 and jinja2-doc
Comment 1 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-07-18 16:42:36 UTC
*** Bug 278168 has been marked as a duplicate of this bug. ***
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-14 20:43:11 UTC
Portage will hopefully somewhen support resolution of circular dependencies.
Comment 3 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-22 16:25:27 UTC
*** Bug 285937 has been marked as a duplicate of this bug. ***
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-25 19:45:41 UTC
*** Bug 286311 has been marked as a duplicate of this bug. ***
Comment 5 Shawn Rutledge 2009-09-26 20:00:59 UTC
It's apparently not acceptable to do without these packages anymore, so therefore this bug must be fixed.  I tried 

rm -rf /usr/portage/dev-python/sphinx

[mini][12:58:13 PM] emerge -avuND system
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-python/sphinx-0.6".
(dependency required by "dev-python/pycairo-1.8.8" [ebuild])
(dependency required by "dev-python/pygtk-2.14.1-r1" [installed])
(dependency required by "gnome-extra/libgsf-1.14.11" [installed])
(dependency required by "gnome-base/librsvg-2.22.3" [installed])
(dependency required by "app-editors/emacs-23.1" [installed])
(dependency required by "dev-util/gtk-doc-1.11" [ebuild])
(dependency required by "dev-libs/glib-2.20.5" [ebuild])
(dependency required by "gnome-base/libglade-2.6.4" [installed])
Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-26 20:08:05 UTC
USE="doc" shouldn't be enabled globally as it is known to cause many circular dependencies (not only between jinja2 and sphinx).

Users might run:
USE="-doc" emerge -1 jinja2 sphinx
emerge -1 jinja2 sphinx
Comment 7 Shawn Rutledge 2009-09-26 21:36:52 UTC
You are right that USE=-doc works.
Comment 8 tonich 2009-09-29 05:41:41 UTC
>Users might run:
>USE="-doc" emerge -1 jinja2 sphinx
>emerge -1 jinja2 sphinx

This is ugly workaround, not solution...
Comment 9 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-29 16:49:18 UTC
(In reply to comment #8)

There is no solution which could be made in ebuilds.

*** This bug has been marked as a duplicate of bug 175808 ***
Comment 10 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-11-23 01:54:02 UTC
*** Bug 294121 has been marked as a duplicate of this bug. ***
Comment 11 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-12-27 19:19:32 UTC
*** Bug 297605 has been marked as a duplicate of this bug. ***