Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 268466 - =media-sound/listen-0.6.2: Version bump request
Summary: =media-sound/listen-0.6.2: Version bump request
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Sound Team
URL: http://www.listen-project.org/
Whiteboard:
Keywords: EBUILD
Depends on:
Blocks: 252276
  Show dependency tree
 
Reported: 2009-05-03 16:22 UTC by Frederic LIETART
Modified: 2009-07-18 06:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
listen-0.6.1.ebuild (listen-0.6.1.ebuild,2.13 KB, text/plain)
2009-05-10 08:26 UTC, Samuli Suominen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic LIETART 2009-05-03 16:22:33 UTC
* Browse and listen Shoucast Webradio
    * Download and listen Podcast
    * Show Lyrics (through many plugins like lyriki, leolyrics,... )
    * See Wikipedia informations about artists or albums
    * Browse shared library with DAAP
    * Listen Last.fm Station
    * Looking for Events about your favourite artists.
    * Record any stream played in Listen
    * Tune sound, with an equalizer 10 Bands
    * Diffuse your playlist with an Icecast Agent (Need an icecast server)
    * Visualizer (all gstreamer visualizer plugins are supported)
    * Browse and listen Jamendo Music Store
    * A Crossfade/Gapless playback engine
    * Automatically update your Gajim or Pidgin status
    * Show album cover and track progression in Avant-Window-Navigator
    * Burn audio cd with Brasero
    * Sync your iPod 

Reproducible: Always
Comment 1 Samuli Suominen gentoo-dev 2009-05-10 08:26:27 UTC
Created attachment 190813 [details]
listen-0.6.1.ebuild

I started working on this.. but for now I gave up, the build system is pretty horrible. Please test, and comment on what should be changed.
Comment 2 Matti Bickel (RETIRED) gentoo-dev 2009-05-31 10:20:48 UTC
0.6.2 has been out for a while. I've tested the thing a bit, but i'm not satisfied.

There could be musicbrainz support, if only there was a python-musicbrainz2 (http://musicbrainz.org/doc/python-musicbrainz2) ebuild in tree. There's one over at bug #12607

ssouminen: any reason you keep that rewrite of /usr/bin/listen? It's broken. Pure
python /usr/lib/listen/listen "$@" works for me.

Otherwise i agree with you - that build system is freaky. The app keeps bombing at retrieving amazon cover art, and does not show lyrics. But that we can't fix.
Comment 3 Samuli Suominen gentoo-dev 2009-07-17 09:07:32 UTC
0.6.2 in portage, 0.5* removed.
Comment 4 Alexandru Cepoi 2009-07-17 21:40:40 UTC
Shouldn't this depend on pyxdg?
It isn't pulled as a dep, but listen won't start without it..
Comment 5 Samuli Suominen gentoo-dev 2009-07-18 06:43:30 UTC
(In reply to comment #4)
> Shouldn't this depend on pyxdg?
> It isn't pulled as a dep, but listen won't start without it..
> 

Good catch. Added now, sync in a hour or so