Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267963 - emerge fail on touch after sys-apps/coreutils-7.1 upgrade
Summary: emerge fail on touch after sys-apps/coreutils-7.1 upgrade
Status: RESOLVED DUPLICATE of bug 224483
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-30 09:34 UTC by Peter Hultqvist
Modified: 2009-04-30 10:46 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Hultqvist 2009-04-30 09:34:58 UTC
After upgrading to coreutils 7.1 emerge fail on every package I try to install with:
  touch: setting times of `/var/tmp/portage/sys-apps/coreutils-6.10-r2/.unpacked': Bad address

Trying to use touch gives:
  $ touch a
  touch: setting times of `a': Bad address


Reproducible: Didn't try

Steps to Reproduce:
Since portage now can't install anything I'm unable to up/downgrade anything.
Actual Results:  
Portage fail with the same type of error on every emerge attempt


Portage 2.1.6.11 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.18-92.1.13.el5.028stab059.6 i686)
=================================================================
System uname: Linux-2.6.18-92.1.13.el5.028stab059.6-i686-Intel-R-_Xeon-R-_CPU_E5405_@_2.00GHz-with-glibc2.0
Timestamp of tree: Thu, 30 Apr 2009 09:00:01 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-O2 -mtune=i686 -O2 -march=i686 -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /sbin/rc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mtune=i686 -O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_exclude"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl bcmath bzip2 cgi cjk cli cracklib crypt curl curlwrappers djvu dri exif fastcgi gd gdbm geoip gnutls graphviz iconv idn imap ipfilter ipv6 isdnlog jbig jce jpeg jpeg2k lowmem mhash midi mmx mudflap mysql ncurses nptl nptlonly openexr openmp pam pcre perl php png posix postfix pppd python readline reflection sasl session sni spl sqlite ssl svg sysfs sysvipc tcpd threads tidy tiff truetype unicode vhosts wmf x86 xml xmlreader xmlrpc xmlwriter xorg xsl zip zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias  auth_basic auth_digest  authn_alias authn_anon authn_dbm authn_default authn_file     authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user     autoindex cache dav dav_fs dav_lock deflate dir disk_cache    env expires ext_filter file_cache filter headers include info         log_config logio mem_cache mime mime_magic negotiation rewrite        setenvif speling status unique_id userdir usertrack vhost_alias               " APACHE2_MPMS="worker" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Jeroen Roovers gentoo-dev 2009-04-30 10:39:56 UTC
Looks like it's time you built yourself a new kernel...
Comment 2 Jeroen Roovers gentoo-dev 2009-04-30 10:46:40 UTC
Sorry, that was unfair.
Comment 3 Jeroen Roovers gentoo-dev 2009-04-30 10:46:50 UTC

*** This bug has been marked as a duplicate of bug 224483 ***