Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267916 - app-text/xmlto-0.0.18 - ?
Summary: app-text/xmlto-0.0.18 - ?
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo SGML herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-29 21:16 UTC by g-user
Modified: 2009-05-01 14:08 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Default /etc/xml/catalog (catalog,236 bytes, text/plain)
2009-04-29 22:03 UTC, Finn Wilke
Details
emerge -av app-text/xmlto old log (log1.txt,6.42 KB, text/plain)
2009-04-30 11:40 UTC, g-user
Details
emerge --info (log2.txt,9.18 KB, text/plain)
2009-04-30 11:41 UTC, g-user
Details
log3 emerge -av app-text/xmlto (log3.txt,6.40 KB, text/plain)
2009-04-30 11:49 UTC, g-user
Details
cat /var/tmp/portage/app-text/xmlto-0.0.18/temp/build.log (log4.txt,4.92 KB, text/plain)
2009-04-30 11:51 UTC, g-user
Details

Note You need to log in before you can comment on or make changes to this bug.
Description g-user 2009-04-29 21:16:21 UTC
app-text/xmlto-0.0.18 problem

Reproducible: Always

Steps to Reproduce:
i have amd64 and small problems.
I try install this one

localhost ~ # emerge -av x11-wm/awesome
These are the packages that would be merged, in order:
Calculating dependencies... done!
[ebuild  N    ] app-text/xmlto-0.0.18  0 kB   <<<<-------there is problem
[ebuild  N    ] x11-wm/awesome-2.3.4  USE="gtk -doc" 0 kB
Total: 2 packages (2 new), Size of downloads: 0 kB
Would you like to merge these packages? [Yes/No] n

my logs
1. emerge -av app-text/xmlto 
http://pastebin.com/m32df2263 
2. emerge --info
http://pastebin.com/m73065b
Comment 1 Finn Wilke 2009-04-29 22:03:38 UTC
Created attachment 189907 [details]
Default /etc/xml/catalog

Seems like your /etc/xml/catalog got cleared somehow.
Can you try to put the default catalog file that I attached to /etc/xml and run 'emerge -av app-text/xmlto'?
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2009-04-30 10:56:06 UTC
Please reopen this bug report after you have gathered the necessary information *right here*. External sources of information such as pastebins are not acceptable. Our bugzilla offers facilities to post information in comments and to upload file attachments. I suggest you use them.
Comment 3 g-user 2009-04-30 11:40:49 UTC
Created attachment 189949 [details]
emerge -av app-text/xmlto old log
Comment 4 g-user 2009-04-30 11:41:17 UTC
Created attachment 189953 [details]
emerge --info
Comment 5 g-user 2009-04-30 11:49:15 UTC
Created attachment 189957 [details]
log3  emerge -av app-text/xmlto
Comment 6 g-user 2009-04-30 11:51:57 UTC
Created attachment 189958 [details]
cat /var/tmp/portage/app-text/xmlto-0.0.18/temp/build.log
Comment 7 g-user 2009-04-30 11:54:28 UTC
> Seems like your /etc/xml/catalog got cleared somehow.
yes is true. Thanks! 

localhost ~ # cat /etc/xml/catalog
show me clear file

>Can you try to put the default catalog file that I attached to /etc/xml and >run 'emerge -av app-text/xmlto'?

i put it, now it's looks like this (i make it like you attach):
localhost ~ # cat /etc/xml/catalog
<?xml version="1.0"?>
<!DOCTYPE catalog PUBLIC "-//OASIS//DTD Entity Resolution XML Catalog V1.0//EN" "http://www.oasis-open.org/committees/entity/release/1.0/catalog.dtd">
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog"/>

But when i try emerge -av app-text/xmlto they give me error again. ;-(
Please look at log3 and log4

>ps. External sources of information such as pastebins are not
>acceptable

Sorry. I fix it - already post all logs.
Comment 8 Finn Wilke 2009-04-30 23:45:03 UTC
Is this a duplicate of http://bugs.gentoo.org/show_bug.cgi?id=99851 ?
Comment 9 g-user 2009-05-01 13:58:26 UTC
> Is this a duplicate
Maybe. Anyway after this:  
emerge -av app-text/docbook-xsl-stylesheets
all seem's ok, and solve my problem. 
emerge -av app-text/xmlto
installed fine

By my option this one look's like broken dependencies for app-text/xmlto ebuild. 
Thanks for help.