Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267596 - ffmpeg; add nonfree and optimizations USE flags
Summary: ffmpeg; add nonfree and optimizations USE flags
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-26 20:42 UTC by Mikael Lammentausta
Modified: 2009-07-10 18:45 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
patch for new use flags (ffmpeg-nonfree-optimizations.patch,998 bytes, patch)
2009-04-26 20:43 UTC, Mikael Lammentausta
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Lammentausta 2009-04-26 20:42:24 UTC
The ffmpeg configure script accepts --enable-nonfree and --enable-optimizations which are not turned on by default.

I have noticed that the optimization flag makes a *huge* performance increase in some cases.

I'll submit a patch for ffmpeg-0.5-r1 which creates USE flags for these options.

Are there any reasons why they are not already included in the ebuilds?

Reproducible: Always
Comment 1 Mikael Lammentausta 2009-04-26 20:43:05 UTC
Created attachment 189559 [details, diff]
patch for new use flags
Comment 2 Alexis Ballier gentoo-dev 2009-05-08 09:56:42 UTC
(In reply to comment #0)
> any reasons why they are not already included in the ebuilds?

'optimizations' seems to be enabled by default; why do you get a "huge" difference?

'nonfree' is enabled as needed, e.g., when amr is enabled and recently faac.
Comment 3 Samuli Suominen (RETIRED) gentoo-dev 2009-07-09 14:50:49 UTC
indeed,

optimizations             yes

which is output of current ./configure

i don't see any reason to keep this bug open (except placebo feeling by enabling USE optimizations maybe? :-))
Comment 4 Mikael Lammentausta 2009-07-10 18:45:22 UTC
Right. For version 0.5 --enable-optimizations and --enable-nonfree make no difference. I think this was different with some 0.4.x pre-release versions.