Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267513 - app-office/akonadi-server-1.1.1 crash
Summary: app-office/akonadi-server-1.1.1 crash
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-26 09:24 UTC by renato gallo
Modified: 2010-12-29 20:40 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
akonadi debug crash log (akonadidebug.txt,14.17 KB, text/plain)
2009-04-26 09:25 UTC, renato gallo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description renato gallo 2009-04-26 09:24:06 UTC
crash debug attached


Reproducible: Always

Steps to Reproduce:
1. start akonadiconsole


Actual Results:  
it crashes

Expected Results:  
it runs

emerge --info
Portage 2.2_rc30 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29.1 x86_64)
=================================================================                                
System uname: Linux-2.6.29.1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q6600_@_2.40GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 25 Apr 2009 21:15:01 +0000                                               
distcc 3.1 x86_64-pc-linux-gnu [disabled]                                                        
ccache version 2.4 [disabled]                                                                    
app-shells/bash:     4.0_p17-r1                                                                  
dev-java/java-config: 1.3.7-r1, 2.1.7                                                            
dev-lang/python:     2.6.2                                                                       
dev-python/pycrypto: 2.0.1-r8                                                                    
dev-util/ccache:     2.4-r8                                                                      
dev-util/cmake:      2.6.3-r1                                                                    
sys-apps/baselayout: 2.0.0                                                                       
sys-apps/openrc:     0.4.3-r2                                                                    
sys-apps/sandbox:    1.9                                                                         
sys-devel/autoconf:  2.13, 2.63-r1                                                               
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                   
sys-devel/binutils:  2.19.1-r1                                                                   
sys-devel/gcc-config: 1.4.1                                                                      
sys-devel/libtool:   2.2.6a                                                                      
virtual/os-headers:  2.6.28-r1                                                                   
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                   
CBUILD="x86_64-pc-linux-gnu"                                                                     
CFLAGS="-march=nocona -O2 -pipe"                                                                 
CHOST="x86_64-pc-linux-gnu"                                                                      
CONFIG_PROTECT="/etc /opt/openjms/config /usr/share/config"                                      
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"                  
CXXFLAGS="-march=nocona -O2 -pipe"                                                                                                              
DISTDIR="/usr/portage/distfiles"                                                                                                                
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"                    
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"                                           
LANG="it_IT.UTF-8"                                                                                                                              
LDFLAGS="-Wl,-O1"                                                                                                                               
LINGUAS="it en"                                                                                                                                 
MAKEOPTS="-j5"                                                                                                                                  
PKGDIR="/usr/portage/packages"                                                                                                                  
PORTAGE_CONFIGROOT="/"                                                                                                                          
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                  
PORTAGE_TMPDIR="/var/tmp"                                                                                                                       
PORTDIR="/usr/portage"                                                                                                                          
PORTDIR_OVERLAY="/usr/local/portage/layman/kde-testing /usr/local/portage/layman/wschlich-testing /usr/local/portage/layman/sunrise /usr/local/portage/layman/mozilla"                                                                                                                          
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"                                                                                           
USE="2dnow 3dnowext 7zip X Xaw3d a52 aac aalib accessibility acl acpi ada addbookmarks akode akonadi alias alsa amd64 amr amrb apache2 applet aqua_theme archive ares artworkextra athena autoipd automount autoreplace avahi bash-completion beagle belagle berkdb bidi bittorrent bl bluetooth bonjour bookmarks branding bzip2 cairo calendar caps captury carbone_theme cdda cddb cdio cdparanoia cdr chm cisco clamavfontconfig cli compiz connection-sharing connectionstatus consolekit contactnotes cpudetection cracklib crypt cscope ctype cups cupsddk curl dbus debug designer-plugin device-mapper dga dhcpcd digitalradio directfb disk-partition diskio djvu dmx dnd doc dri dts dv dvb dvd dvdr dvi editor eds elf emacs emacx enca encode eolconv epiphany equalizer esd exif expat extensible fam fasttrack fax fbcon fbcondecor festival ffmpeg filepicker filter firefox flac fltk fontforge foomaticdb fortran freetts freewnn ftp fuse gadu galago gcj gd gdbm gedit ggi gif gimp glib glitz gnokii gnome gnome-keyring gnomecd gnutella gnutls google-gadgets gpg gphoto2 gpm gps graphwiz groupwise grub gsf gsm gstreamer gtk gtkhtml guile gz gzip-el hal hdf hdri hesiod hfs highlight history hotplug howl-compat httpd hybrid-auth iceweasel iconv idn ieee1394 imagemagick imap imlib innodb inotify inquisitio ioctl ipod iproute2 ipv6 irc irda irmc isdnlog jack jadetex jai java java5 javamail javascript jbig jce jingle jmf jms jmx joystick jpeg jpeg2k kde4 kdrive kerberos kipi kolab ladspa lame lapack laptop latex lcms ldap legacyssl libcaca libffi libnotify libsamplerate libssh2 lirc live lm_sensors logitech-mouse lua lzma lzo mad mbrola md5sum mdnsresponder-compat meanwhile mfd-rewrites midi mjpeg mmap mmx mng mono motif mozdevelop mp2 mp3 mpeg msn mudflap mule multilib musepack mxdatetime mysql mysqli mythtv nas nat nautilus ncurses neXt nemesi netmeeting network networkingnetworkmanager new-login nls nntp nowlistening npp nptl nptlonly nsplugin nss oci8-instant-client odbc odk offensive ogg old-daemons openal openexr openft opengl openmp openntpd opensslcrypt openstreetmap oracle oscar otr pam parse-clocks passwordsave pch pcre pda pdf perl phonon php pink pkcs11 plasma plotutils plugins png pnm pop portage postgres povray ppds pppd pulseaudio python python-bindings q32 q8 qa qt3 qt3support qt4 quicktime radio rar raster rdesktop readline redeyes redland reflection remote resolvconf rpm rrdcgi rss rtc ruby ruby-bindings samba sametime sasl savedconfig scanner schedule script scripting sdl seamonkey semantic-desktop sendmail sesame2 session skey slang slp smartcard smp sms smux sndfile snmp sockets socks5 solver sound soundex speechd speex spell spl sql sqlite srt sse sse2 ssl ssse3 startup-notification statistics stemmer suid svg swat swig sysfs syslog szip t1lib taglib tcl tcltk tcpd teletext test test-programs tetex texteffect tftp tga theora threads thumbnail tidy tiff tk toolkit-scroll-bars tools tracker translator truetype tseng tunepimp unicode usb utils v4l v4l2 vcd vim-pager vim-syntax vim-with-x visibility vnc vorbis wavpack wddx webinterface webkit webpresence wifi winpopup wireless wlm wmf x264 xanim xattr xcb xcomposite xemacs xext xface xforms xft xim xine xinerama xinetd xml xml2 xmp xorg xpm xscreensaver xulrunner xv xvid xvmc yahoo zeroconf zlib zoran zsh-completion zvbi" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="event" CAMERAS="adc65 agfa_cl20 aox barbie canon casio_qv clicksmart310 digigr8 digita dimagev dimera3500 directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica konica_qm150 largan lg_gsm mars mustek panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 pccam300 pccam600 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ptp2 ricoh ricoh_g3 samsung sierra sipix_blink sipix_blink2 sipix_web2 smal sonix sony_dscf1 sony_dscf55 soundvision spca50x sq905 stv0674 stv0680 sx330z template toshiba_pdrm11" DVB_CARDS="tda1004x" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse acecad aiptek digitaledge elographics fpit hyperpen jamstudio joystick magellan mutouch palmax spaceorb summa synaptics tek4957 ur98 vmmouse void wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncursestext" LINGUAS="it en" LIRC_DEVICES="pctv" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 renato gallo 2009-04-26 09:25:41 UTC
Created attachment 189472 [details]
akonadi debug crash log

attached akonadi debug crash log
Comment 2 renato gallo 2009-04-26 09:26:41 UTC
I would particularly turn your attention on this line of the crash log

[akonadiserver] akonadiserver: libmysql.c:4301: setup_one_fetch_function: Asserzione `param->buffer_length != 0' fallita.
Comment 3 renato gallo 2009-04-26 16:23:15 UTC
was this complete enough or you need more datas ?

(In reply to comment #2)
> I would particularly turn your attention on this line of the crash log
> 
> [akonadiserver] akonadiserver: libmysql.c:4301: setup_one_fetch_function:
> Asserzione `param->buffer_length != 0' fallita.
> 

Comment 4 renato gallo 2009-04-26 16:38:30 UTC
"[
0: akonadiserver(_Z11akBacktracev+0x39) [0x40b353]
1: akonadiserver [0x40b877]
2: /lib/libc.so.6 [0x7f0e30705270]
3: /lib/libc.so.6(gsignal+0x35) [0x7f0e307051e5]
4: /lib/libc.so.6(abort+0x183) [0x7f0e30706703]
5: /lib/libc.so.6(__assert_fail+0xe9) [0x7f0e306fe229]
6: /usr/lib/libmysqlclient_r.so.15(set_stmt_errmsg+0) [0x7f0e2a54b1db]
7: /usr/lib/libmysqlclient_r.so.15(mysql_stmt_bind_result+0x151) [0x7f0e2a54c50d]
8: /usr/lib64/qt4/plugins/sqldrivers/libqsqlmysql.so [0x7f0e2a8b94ae]
9: /usr/lib64/qt4/plugins/sqldrivers/libqsqlmysql.so [0x7f0e2a8b8a4e]
10: /usr/lib64/qt4/libQtSql.so.4(_ZN9QSqlQuery4execERK7QString+0x126) [0x7f0e323f69a8]
11: /usr/lib64/libakonadiprivate.so.1(_ZN13DbInitializer10checkTableERK11QDomElement+0x2ec6) [0x7f0e329e05fc]
12: /usr/lib64/libakonadiprivate.so.1(_ZN13DbInitializer3runEv+0x51b) [0x7f0e329e3cd9]
13: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi9DataStore4initEv+0x57) 
overlay ver crashes too

[0x7f0e329d5237]
14: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x57f) [0x7f0e329676bd]
15: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x35) [0x7f0e32968473]
16: akonadiserver(main+0x2dd) [0x4067c4]
17: /lib/libc.so.6(__libc_start_main+0xe6) [0x7f0e306f15c6]
18: akonadiserver [0x406419]
]
Comment 5 Leo Franchi 2009-04-26 16:49:31 UTC
I can confirm, using all the  kde-live packages. same crash. 
Comment 6 renato gallo 2009-06-22 00:11:13 UTC
any news on this ?
Comment 7 renato gallo 2009-06-26 09:25:24 UTC
(In reply to comment #5)
> I can confirm, using all the  kde-live packages. same crash. 
> 

news ?
Comment 8 boris64 2009-08-05 15:48:11 UTC
I'm having the exact same problem on kde-4.3 with
akondi-server-1.2, mysql-5.0.83 and qt-sql-4.5.2

Any news on this? Without working akonadi lot of
stuff from kde is kind of useless.
Comment 9 renato gallo 2009-08-06 08:09:57 UTC
I am waiting for answers like you

(In reply to comment #8)
> I'm having the exact same problem on kde-4.3 with
> akondi-server-1.2, mysql-5.0.83 and qt-sql-4.5.2
> 
> Any news on this? Without working akonadi lot of
> stuff from kde is kind of useless.
> 

Comment 10 Fredrik Klasson 2009-08-06 12:12:03 UTC
Could this possibly be related to this[1] old (feb. 2008) bug in MySQL? (I'm just guessing based on the error message.)
That bug appears to have been closed because it wasn't reproducable anymore.

[1] http://bugs.mysql.com/bug.php?id=25251


my 'versions':
 AMD64
 KDE 4.3
 akonadi-4.3.0
 akonadi-server-1.2.0
 mysql-5.0.76-r1
 qt-sql-4.5.1

I'm seeing the same bt as Comment #4 (different addresses though)
Comment 11 Dennis Schridde 2009-08-07 12:43:25 UTC
bug of fame in the Akonadi Userbase FAQ: http://userbase.kde.org/Akonadi#The_so-called_.22Gentoo-Assert.22
Comment 12 Dennis Schridde 2009-08-07 12:50:05 UTC
Can confirm the issue with dev-db/mysql-5.0.76-r1 and dev-db/mysql-5.0.83, both times using x11-libs/qt-sql-4.5.2.

Log from 5.0.76-r1:
[akonadiserver] Database "akonadi" opened using driver "QMYSQL"
[akonadiserver] DbInitializer::run()
[akonadiserver] checking table  "SchemaVersionTable"
[akonadiserver] checking table  "ResourceTable"
[akonadiserver] checking table  "CollectionTable"
[akonadiserver] akonadiserver: libmysql.c:4301: setup_one_fetch_function: Assertion `param->buffer_length != 0' failed.
[akonadiserver] "[
[akonadiserver] 0: akonadiserver(_Z11akBacktracev+0x39) [0x40ab29]
[akonadiserver] 1: akonadiserver [0x40b05a]
[akonadiserver] 2: /lib/libc.so.6 [0x7fb5b2acc460]
[akonadiserver] 3: /lib/libc.so.6(gsignal+0x35) [0x7fb5b2acc3d5]
[akonadiserver] 4: /lib/libc.so.6(abort+0x183) [0x7fb5b2acdfe3]
[akonadiserver] 5: /lib/libc.so.6(__assert_fail+0xe9) [0x7fb5b2ac5429]
[akonadiserver] 6: /usr/lib/libmysqlclient_r.so.15 [0x7fb5b060652c]
[akonadiserver] 7: /usr/lib/libmysqlclient_r.so.15(mysql_stmt_bind_result+0x14c) [0x7fb5b0607b1c]
[akonadiserver] 8: /usr/lib64/qt4/plugins/sqldrivers/libqsqlmysql.so [0x7fb5b0979427]
[akonadiserver] 9: /usr/lib64/qt4/plugins/sqldrivers/libqsqlmysql.so [0x7fb5b0978329]
[akonadiserver] 10: /usr/lib64/qt4/libQtSql.so.4(_ZN9QSqlQuery4execERK7QString+0x126) [0x7fb5b25804d6]
[akonadiserver] 11: /usr/lib64/libakonadiprivate.so.1(_ZN13DbInitializer10checkTableERK11QDomElement+0x3001) [0x7fb5b40dffa1]
[akonadiserver] 12: /usr/lib64/libakonadiprivate.so.1(_ZN13DbInitializer3runEv+0x514) [0x7fb5b40e3cd4]
[akonadiserver] 13: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi9DataStore4initEv+0x6b) [0x7fb5b40d12cb]
[akonadiserver] 14: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServerC1EP7QObject+0x585) [0x7fb5b405fb15]
[akonadiserver] 15: /usr/lib64/libakonadiprivate.so.1(_ZN7Akonadi13AkonadiServer8instanceEv+0x4a) [0x7fb5b406091a]
[akonadiserver] 16: akonadiserver(main+0x3a2) [0x405df2]
[akonadiserver] 17: /lib/libc.so.6(__libc_start_main+0xe6) [0x7fb5b2ab79f6]
[akonadiserver] 18: akonadiserver [0x405959]
[akonadiserver] ]
[akonadiserver] "
ProcessControl: Application 'akonadiserver' returned with exit code 255 (Unknown error)
"akonadiserver" crashed too often and will not be restarted!
Comment 13 Dennis Schridde 2009-08-07 13:09:09 UTC
The issue might vanish when compiling dev-db/mysql with USE=-debug. (But since other errors appear in that case, I can not be sure.)
Comment 14 Fredrik Klasson 2009-08-07 16:06:08 UTC
@ Comment  #13 :
I tried re-emerging mysql with USE=-debug and ran "akonadictl start". It seems to be running ok now, it didn't crash. Got some error about some resource not being migrated (but most of them appears to have been).
Though, I'm suspecting that -debug simply let's the error slip though (not doing abny code for the assert macro). That or maybe that assertion shouldn't be there at all (but then other distros should've hit the bug too :/)?
Btw, the ebuild warns about -fPIC, I tried "CFLAGS="-O2" CXXFLAGS="-O2" USE=-debug emerge mysql" but the fPIC warning remained so I just re-emerged with "USE=-debug emerge mysql" (thus with optimizations).
Comment 15 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-08-07 20:47:48 UTC
USE=debug on mysql enables a LOT of assertion hard checks (with exit on failure). Why are you using it?
Comment 16 Dennis Schridde 2009-08-07 21:54:30 UTC
(In reply to comment #15)
> USE=debug on mysql enables a LOT of assertion hard checks (with exit on
> failure). Why are you using it?
I was debugging vanishing records in the Akonadi database.
Comment 17 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2009-08-08 02:12:15 UTC
Assuming akonadi isn't using MySQL's embedded mode, you'd be better off using the querylogs than USE=debug.

I'll put larger warnings around USE=debug for MySQL, but you shouldn't be using it in this case.

Removing mysql team now.
Comment 18 Dennis Schridde 2009-08-08 09:19:53 UTC
The Akonadi database strongly misbehaves (the abovementioned vanishing records). Binary logs show succeeding insertion of huge numbers where there should be strings, and huge numbers where there should be small numbers. The reason seems to be indeed Gentoo's MySQL (-patches?), as it does not happen on other distributions or when using SQLite as backend.
Comment 19 renato gallo 2009-08-08 16:41:40 UTC
had the same problem on slackware

(In reply to comment #18)
> The Akonadi database strongly misbehaves (the abovementioned vanishing
> records). Binary logs show succeeding insertion of huge numbers where there
> should be strings, and huge numbers where there should be small numbers. The
> reason seems to be indeed Gentoo's MySQL (-patches?), as it does not happen on
> other distributions or when using SQLite as backend.
> 

Comment 20 renato gallo 2009-08-08 16:56:34 UTC
also on other distros 
http://chakra-project.org/bbs/viewtopic.php?id=229
(In reply to comment #18)
> The Akonadi database strongly misbehaves (the abovementioned vanishing
> records). Binary logs show succeeding insertion of huge numbers where there
> should be strings, and huge numbers where there should be small numbers. The
> reason seems to be indeed Gentoo's MySQL (-patches?), as it does not happen on
> other distributions or when using SQLite as backend.
> 

Comment 21 Andreas K. Hüttel gentoo-dev 2010-04-02 18:56:08 UTC
any news on this?
what happens with 1.2.1 or 1.3.1 ???
Comment 22 Tobias Leupold 2010-04-06 11:13:29 UTC
Still the same with

app-office/akonadi-server-1.3.1
kde-base/akonadi-4.4.2
x11-libs/qt-sql-4.6.2
dev-db/mysql-5.0.90-r2

Removing the debug use flag from mysql still fixes it.
Comment 23 Paul Campbell 2010-07-05 21:31:28 UTC
still there at kde 4.4 - and probably a lot more relevant since it seems that akonadi is now required for kde4.4 (at least if you want to read your email)
Comment 24 Dan Johnson 2010-08-18 13:47:23 UTC
As per http://userbase.kde.org/Akonadi_4.4/Troubleshooting#The_so-called_.22Gentoo-Assert.22 have you tried rebuilding x11-libs/qt-sql since you last rebuild mysql. Seems there can be protocol mismatches between the client and server if you don't.
Comment 25 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-12-29 20:40:16 UTC
No news for many months, let's suppose it is fixed. Reopen if it persists