Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267398 - should x11-base/xorg-server-1.5.3-r5 have dri2proto as dependancy?
Summary: should x11-base/xorg-server-1.5.3-r5 have dri2proto as dependancy?
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-25 07:33 UTC by Étienne Buira
Modified: 2009-04-28 10:08 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Étienne Buira 2009-04-25 07:33:16 UTC
Emerging x11-base/xorg-server-1.5.3-r5 leads me to an error whilst configuring build.
The weird thing is that I emerged it (update) some days ago. But I think I did an emerge --depclean since.

An extract of the output:
checking for a useful monotonic clock ...... yes
checking for XLIB... yes
checking for GL... configure: error: Package requirements (glproto >= 1.4.9 gl >= 7.1.0) were not met:

Package dri2proto was not found in the pkg-config search path.
Perhaps you should add the directory containing `dri2proto.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dri2proto', required by 'gl', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GL_CFLAGS
and GL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/x11-base/xorg-server-1.5.3-r5/work/xorg-server-1.5.3/config.log
 * 
 * ERROR: x11-base/xorg-server-1.5.3-r5 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3252:  Called x-modular_src_compile
 *             environment, line 4060:  Called x-modular_src_configure
 *             environment, line 4069:  Called econf '--prefix=/usr' '--datadir=/usr/share' '--disable-ipv6' '--disable-dmx' '--disable-kdrive' '--disable-tslib' '--disable-xcalibrate' '--enable-xvfb' '--enable-xnest' '--enable-xtrap' '--enable-record' '--enable-xfree86-utils' '--enable-install-libxf86config' '--enable-dri' '--enable-glx' '--enable-xorg' '--enable-glx-tls' '--enable-xorgcfg' '--disable-config-dbus' '--disable-config-hal' '--disable-dri2' '--sysconfdir=/etc/X11' '--localstatedir=/var' '--enable-install-setuid' '--with-fontdir=/usr/share/fonts' '--with-xkb-output=/var/lib/xkb' '--disable-xsdl'


Reproducible: Always

Steps to Reproduce:
1. Unmerge x11-proto/dri2proto
2. emerge xorg-server (use flag change in my case, -ipv6)

Actual Results:  
Fails when configuring build

Expected Results:  
Configure and build out of the box

A quick and dirty workaround is to emerge -av1 dri2proto, but dri2proto should be added to build deps or the configure script should be changed.
Comment 1 Nick Fortino 2009-04-25 07:47:46 UTC
Could you post the output of emerge -pv xorg-server, as well as emerge --info? Once this gets re-assigned to the maintainer, that will be needed.

I'm guessing you have USE="minimal" set, as otherwise dri2proto should be pulled in by the media-libs/mesa dependency.
Comment 2 Étienne Buira 2009-04-25 08:06:08 UTC
(In reply to comment #1)
> Could you post the output of emerge -pv xorg-server, as well as emerge --info?
> Once this gets re-assigned to the maintainer, that will be needed.
> 
> I'm guessing you have USE="minimal" set, as otherwise dri2proto should be
> pulled in by the media-libs/mesa dependency.
> 

emerge -pv xorg-server:
# emerge -pv xorg-server

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-base/xorg-server-1.5.3-r5  USE="nptl sdl xorg (-3dfx) -debug -dmx -hal -ipv6 -kdrive -minimal -tslib" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -tslib -ur98 -virtualbox -vmmouse -void -wacom" VIDEO_CARDS="nv -apm -ark -ast -chips -cirrus -dummy -epson -fbdev -fglrx (-geode) -glint -i128 (-i740) (-impact) (-imstt) -intel -mach64 -mga -neomagic (-newport) -nvidia -r128 -radeon -radeonhd -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l (-vermilion) -vesa -via -virtualbox -vmware -voodoo (-xgi)" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB


emerge --info:
# emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.18-xen-r12 x86_64)
=================================================================
System uname: Linux-2.6.18-xen-r12-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9300_@_2.50GHz-with-glibc2.2.5
Timestamp of tree: Fri, 24 Apr 2009 16:45:03 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.4-r2
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.heanet.ie/pub/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://mirror.cambrium.nl/pub/os/linux/gentoo/"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apache2 berkdb bzip2 cli cracklib crypt cups doc dri fortran gdbm gtk hvm iconv imlib isdnlog jadetex jpeg live midi mikmod mmx mozdevelop mudflap multilib mysql mysqli ncurses nls nptl nptlonly openmp pam pcre perl png pppd python readline reflection sdl session spl sse sse2 ssl sysfs tcpd threads unicode usb vorbis xorg xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

About mesa, I have media-libs/mesa-7.3-r1 and x11-apps/mesa-progs-7.3 installed. But no 'minimal' useflag at all
Comment 3 Nick Fortino 2009-04-25 08:18:47 UTC
Well in that case, when you do an emerge --depclean, do you use --with-bdeps=n?

This would explain how you have mesa and not dri2proto. The likely solution will be to add dri2proto to the !minimal? block of xorg-server.
Comment 4 Étienne Buira 2009-04-25 08:28:35 UTC
(In reply to comment #3)
> Well in that case, when you do an emerge --depclean, do you use --with-bdeps=n?
> 
> This would explain how you have mesa and not dri2proto. The likely solution
> will be to add dri2proto to the !minimal? block of xorg-server.
> 

Good catch! Sorry, I forgot I used --with-bdeps option (because otherwise, --depclean didn't want to work, I can't remember why).

I think it's time to file this bug as invalid. Sorry about this.
Comment 5 Nick Fortino 2009-04-25 08:34:03 UTC
In my opinion, you should re-open this bug (I can't do it for you). While your case is definitely a fringe case, --with-bdeps=n is not invalid usage. 
It's not valid for xorg-server to depend on build dependencies of a runtime dependency to be installed (which is what is happening here), so the bug should at least be looked at by a dev.
Comment 6 Étienne Buira 2009-04-25 08:52:52 UTC
(In reply to comment #5)
> In my opinion, you should re-open this bug (I can't do it for you). While your
> case is definitely a fringe case, --with-bdeps=n is not invalid usage. 
> It's not valid for xorg-server to depend on build dependencies of a runtime
> dependency to be installed (which is what is happening here), so the bug should
> at least be looked at by a dev.

OK, you're right, bug reopenned.
Comment 7 Rémi Cardona gentoo-dev 2009-04-28 10:08:27 UTC
Thing is, we have no sensible way to specify this sort of dependency in ebuilds...

xorg-server 1.5 clearly doesn't use dri2proto at all, so adding the dep would be wrong (in a moral sense).

But dri2proto isn't a run-time dep of mesa either...

In the end, I'm just tempted to close this CANTFIX because xorg 1.6 will depend on dri2proto directly, closing the issue :)

Thanks