Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267188 - x11-drivers/ati-drivers: X crashes when closing the lid (ACPI problem?)
Summary: x11-drivers/ati-drivers: X crashes when closing the lid (ACPI problem?)
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Luca Barbato
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-23 11:23 UTC by Stefan Kamphausen
Modified: 2009-09-01 13:15 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
My current xorg.conf (xorg.conf,5.06 KB, text/plain)
2009-04-25 21:46 UTC, Stefan Kamphausen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Kamphausen 2009-04-23 11:23:08 UTC
Last week I emerged the new xorg 1.5 with hal.  The same world-built also shipped a new ati-driver.  For this to compile I needed to upgrade my kernel from linux-2.6.24-gentoo-r8 to current stable linux-2.6.27-gentoo-r10.  Following the xorg-1.5 upgrade guide (especially the evdev and hal things were important to me) I finally emerged world and rebooted.

Now, every time I close the lid of my laptop and re-open it the X-display becomes scrambled and I can create a few input events (i.e. move the mouse, hit some keys) before the machines freezes completely.  

* Sometimes an SSH session still lives
* Sometimes it is dead for a minute or something and then comes back.  Then I can see the X process consuming 100% CPU.  This process can not be killed.  Not even with kill -9
* The problem seems to be connected to ACPI because I can produce a similar behaviour when I call aticonfig --set-powerstate=1 and =3 (or vice versa?).  I came up with this because I found that the ACPI event is handled by /etc/acpi/ati-powermode.sh where I found that command.
* I've seen CPU-Locks in /var/log/messages, but not every time.
* Some really scary looking things in /var/log/messages where:

Apr 20 15:23:03 minerva [fglrx] ASIC hang happened
Apr 20 15:23:03 minerva Pid: 13387, comm: X Tainted: P          2.6.27-gentoo-r7 #3
Apr 20 15:23:03 minerva [<f9844990>] KCL_DEBUG_OsDump+0x8/0xa [fglrx]
Apr 20 15:23:03 minerva [<f9853ed9>] firegl_hardwareHangRecovery+0x19/0x30 [fglrx]
Apr 20 15:23:03 minerva [<f98d5f8b>] ? _ZN4Asic9WaitUntil15ResetASICIfHungEv+0xb/0x20 [fglrx]
Apr 20 15:23:03 minerva [<f98d5f27>] _ZN4Asic9WaitUntil15WaitForCompleteEv+0x97/0xf0 [fglrx]
Apr 20 15:23:03 minerva [<f98dafec>] _ZN6AsicR616ASICIdleInternalEN4Asic15idle_WaitMethodE+0xcc/0x1f0 [fglrx]
Apr 20 15:23:03 minerva [<f98b2136>] ? QSSubmitList+0x56/0x170 [fglrx]
Apr 20 15:23:03 minerva [<f98d46cc>] _ZN4Asic7PM4idleENS_15idle_WaitMethodE+0x4c/0x80 [fglrx]
Apr 20 15:23:03 minerva [<f98cd7f5>] _ZN15QS_PRIVATE_CORE7PM4idleEN4Asic15idle_WaitMethodE+0x35/0x70 [fglrx]
Apr 20 15:23:03 minerva [<f98ba9a1>] _ZN10QS_PRIVATE11synchronizeEv+0x31/0x40 [fglrx]
Apr 20 15:23:03 minerva [<f98b2267>] QSSynchronize+0x17/0x20 [fglrx]
Apr 20 15:23:03 minerva [<f98bb669>] _Z14uQSSynchronizej+0x19/0x20 [fglrx]
Apr 20 15:23:03 minerva [<f98c3dbb>] _Z8uCWDDEQCjjjPvjS_+0x3db/0x1260 [fglrx]
Apr 20 15:23:03 minerva [<f98b1754>] CMMQS_uCWDDEQC+0x34/0x40 [fglrx]
Apr 20 15:23:03 minerva [<f9873142>] firegl_cmmqs_CWDDE_32+0x402/0x640 [fglrx]
Apr 20 15:23:03 minerva [<c023c62a>] copy_from_user+0x2c/0x4f
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f
Apr 20 15:23:03 minerva [<f987188d>] firegl_cmmqs_CWDDE32+0x8d/0x140 [fglrx]
Apr 20 15:23:03 minerva [<c0126b1d>] capable+0x13/0x2c
Apr 20 15:23:03 minerva [<f9871800>] firegl_cmmqs_CWDDE32+0x0/0x140 [fglrx]
Apr 20 15:23:03 minerva [<f984ecc7>] firegl_ioctl+0x227/0x1200 [fglrx]
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f
Apr 20 15:23:03 minerva [<c0117ef6>] pick_next_task_fair+0x9c/0xa6
Apr 20 15:23:03 minerva [<f9843204>] ip_firegl_ioctl+0xd/0xf [fglrx]
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f
Apr 20 15:23:03 minerva [<c017f74e>] vfs_ioctl+0x4e/0x67
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f
Apr 20 15:23:03 minerva [<c017f99e>] do_vfs_ioctl+0x237/0x245
Apr 20 15:23:03 minerva [<c017f9ec>] sys_ioctl+0x40/0x5c
Apr 20 15:23:03 minerva [<c01037d9>] sysenter_do_call+0x12/0x21
Apr 20 15:23:03 minerva [<c01c64a6>] print_block+0xd0/0x43f

or

Apr 21 17:19:44 minerva acpid: completed event "button/lid LID 00000080 00000006"
Apr 21 17:22:53 minerva BUG: soft lockup - CPU#1 stuck for 61s! [X:16477]
Apr 21 17:22:53 minerva Modules linked in: fglrx(P) ipv6 snd_pcm_oss snd_mixer_oss snd_seq_oss snd_seq_midi_event snd_seq snd_se
Apr 21 17:22:53 minerva 
Apr 21 17:22:53 minerva Pid: 16477, comm: X Tainted: P          (2.6.27-gentoo-r10 #1)
Apr 21 17:22:53 minerva EIP: 0060:[<f9a6f4fe>] EFLAGS: 00203246 CPU: 1
Apr 21 17:22:53 minerva EIP is at _ZN4Asic16WaitForBitsClear19ConditionSuccessfulEv+0x1e/0x70 [fglrx]
Apr 21 17:22:53 minerva EAX: 90010140 EBX: f56d9d18 ECX: 00000000 EDX: f94c0e40
Apr 21 17:22:53 minerva ESI: 0009bbc3 EDI: f56d9d18 EBP: f56d9cc0 ESP: f56d9ca8
Apr 21 17:22:53 minerva DS: 007b ES: 007b FS: 00d8 GS: 0033 SS: 0068
Apr 21 17:22:53 minerva CR0: 80050033 CR2: b7f466b5 CR3: 3576b000 CR4: 000006d0
Apr 21 17:22:53 minerva cron[17206]: (root) CMD (test -x /usr/sbin/run-crons && /usr/sbin/run-crons )
Apr 21 17:22:53 minerva DR0: 00000000 DR1: 00000000 DR2: 00000000 DR3: 00000000
Apr 21 17:22:53 minerva DR6: ffff0ff0 DR7: 00000400
Apr 21 17:22:53 minerva [<f9a6e7b8>] _ZN4Asic9WaitUntil15WaitForCompleteEv+0x38/0xf0 [fglrx]
Apr 21 17:22:53 minerva [<f9a73a2c>] _ZN6AsicR616ASICIdleInternalEN4Asic15idle_WaitMethodE+0xcc/0x1f0 [fglrx]
Apr 21 17:22:53 minerva [<f9a49a76>] ? QSSubmitList+0x56/0x170 [fglrx]
Apr 21 17:22:53 minerva [<f9a6cf0c>] _ZN4Asic7PM4idleENS_15idle_WaitMethodE+0x4c/0x80 [fglrx]
Apr 21 17:22:53 minerva [<f9a65fb5>] _ZN15QS_PRIVATE_CORE7PM4idleEN4Asic15idle_WaitMethodE+0x35/0x70 [fglrx]
Apr 21 17:22:53 minerva [<f9a525c1>] _ZN10QS_PRIVATE11synchronizeEv+0x31/0x40 [fglrx]
Apr 21 17:22:53 minerva [<f9a49ba7>] QSSynchronize+0x17/0x20 [fglrx]
Apr 21 17:22:53 minerva [<f9a53309>] _Z14uQSSynchronizej+0x19/0x20 [fglrx]
Apr 21 17:22:53 minerva [<f9a5c5eb>] _Z8uCWDDEQCjjjPvjS_+0x3db/0x1260 [fglrx]
Apr 21 17:22:53 minerva [<f9a49094>] CMMQS_uCWDDEQC+0x34/0x40 [fglrx]
Apr 21 17:22:53 minerva [<f9a043e6>] firegl_cmmqs_CWDDE_32+0x3d6/0x4b0 [fglrx]
Apr 21 17:22:53 minerva [<c023d54a>] copy_from_user+0x2c/0x4f
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva [<f9a0298a>] firegl_cmmqs_CWDDE32+0x8a/0x140 [fglrx]
Apr 21 17:22:53 minerva [<c0126e45>] capable+0x13/0x2c
Apr 21 17:22:53 minerva [<f9a02900>] firegl_cmmqs_CWDDE32+0x0/0x140 [fglrx]
Apr 21 17:22:53 minerva [<f99df34d>] firegl_ioctl+0x22d/0x11d0 [fglrx]
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva [<f99d4254>] ip_firegl_ioctl+0xd/0xf [fglrx]
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva [<c01804de>] vfs_ioctl+0x4e/0x67
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva [<c018072e>] do_vfs_ioctl+0x237/0x245
Apr 21 17:22:53 minerva [<c018077c>] sys_ioctl+0x40/0x5c
Apr 21 17:22:53 minerva [<c01037e9>] sysenter_do_call+0x12/0x21
Apr 21 17:22:53 minerva [<c01c64a6>] reiserfs_hashname+0x29/0x2b
Apr 21 17:22:53 minerva =======================

What did I try in the meantime?

* Remerge all of x11-drivers, x11-proto, x11-base
* Remerge KDM which is my display driver
* Tried some older ati-drivers which did not work anymore
* Booted into the old kernel (no help)
* Emerged ati-drivers without acpi-USE-flag (seemed to help, I will do that again and see how long the system stays stable)
* Read hundreds of posts and bugs (mainly from Gentoo but also Ubuntu and X)
* Read several howtos and trouble shooting guides (Gentoo wiki, unofficial ATI wiki)
* Compiled the kernel over and over again with different configurations

Unfortunately I need the external monitor quite often, so fglrx seems to be a must for me, since I never really got it working with the open source drivers.

Any help on how get a wonderful stable notebook again (as it had been for months before that) is highly appreciated.

Best Regards,
Stefan

Reproducible: Always

Steps to Reproduce:
1. /etc/init.d/xdm start
2. Login as normal user
3. Close lid
4. Reopen lid (sometimes it only crashes if I wait a few seconds before opening the lid)

Actual Results:  
Crash as described in Description field above.

Expected Results:  
Continue to run.

Lenovo/IBM ThinkPad T60

lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility X1400
02:00.0 Ethernet controller: Intel Corporation 82573L Gigabit Ethernet Controller
03:00.0 Network controller: Atheros Communications Inc. AR5418 802.11abgn Wireless PCI Express Adapter (rev 01)
15:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller


emerge --info
emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r10 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r10-i686-Intel-R-_Core-TM-2_CPU_T5600_@_1.83GHz-with-glibc2.0
Timestamp of tree: Thu, 23 Apr 2009 09:00:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl acpi alsa arts bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups curl dbus dmi dri dvd dvdr dvdread eds emacs emboss encode esd evo fam firefox flac fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde kipi kpathsea laptop ldap mad midi mikmod mmx mp3 mpeg mudflap ncurses networkmanager nls nptl nptlonly ogg opengl openmp osd pam pcre pdf perl pmu png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification suexec svg sysfs tcpd theora tiff truetype unicode usb vorbis win32codecs x86 xinerama xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="fglrx vesa fbdev radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-25 14:32:55 UTC
Please attach your xorg.conf file.
Comment 2 Stefan Kamphausen 2009-04-25 21:46:15 UTC
Created attachment 189431 [details]
My current xorg.conf

Thanks for taking care.  I attached my current xorg.conf.  I tried without any xorg.conf at all, earlier I still had the input devices active and I tried the settings mentioned when emerging ati-drivers.  I not 100% sure, though, that I tried everything.

Regards,
Stefan
Comment 3 Stefan Kamphausen 2009-04-28 19:34:06 UTC
Update:  In the meantime I recompiled all of kde-base (no change) and removed the kde configuration ($HOME/.kde/ and $HOME/.kderc) (also no change).  I tried this because there is no problem when only kdm is running.  Just when I log in can I crash the machine.

Damn, I need this computer up and running.  I hope this is not my way to Ubuntu (though, I've seen similar posts with Ubuntu, so it may make no difference?).

Regards,
Stefan
Comment 4 Stefan Kamphausen 2009-04-29 09:17:40 UTC
More experiments:

* modprobe -r ath9k
  Unfortunately I suffer from Atheros AR5418-sickness.  Used an SVN-trunk madwifi for ages with little problems, the current ath9k keeps disconnecting all the time (about every minute or so).  Since there was also a PCI-problem announced in syslog I thought I'd try without that module.  No change.

* Recompiled x11-libs, x11-apps, app-laptop, sys-power

  No change.

Any more ideas, what I could try?  Should I attach my kernel config?

I'm about to remerge world (521 packages currently so it'll take some time).

Regards,
Stefan
Comment 5 Stefan Kamphausen 2009-04-30 09:58:09 UTC
A new observation: if I open and close the lid once or sometimes twice, I will get the scrambled screen.  Doing some input then like hitting a key or moving the mouse or pressing a mouse button will lead to the freezing of the machine within seconds.

Opening and closing the lid some more times will get me back to a normal display,which I can't crash, again.  It _is_ kind of a work-around.

Other then that: I now load the acpi-cpufreq module and removed ath-modules completely from the kernel.  Without success.  

I can't help but feeling that I miss something simple and maybe obvious.

Regards,
Stefan
Comment 6 Stefan Kamphausen 2009-05-04 16:21:27 UTC
The problem only occurs when the laptop is powered.  When running on batteries I can't seem to provoke the error.
Comment 7 Stefan Kamphausen 2009-05-05 08:27:10 UTC
Since this seems to be a monologue, I'm at the end of what little wisdom I may have, and I need this computer in two days urgently, I will install that other Linux distribution today.  Unfortunately we'll loose a test-case that way.

Hopefully I'll find the time to get back to Gentoo later.  (Still running Gentoo on the desktop, though, so I'm not lost :-)

Cheers,
Stefan
Comment 8 Stefan Kamphausen 2009-05-06 07:04:16 UTC
Just for the record: FGLRX in Jaunty with my radeon Mobility X1400 fails miserably (no X at all, that card was dropped by ATI as it seems) and I now use the open source drivers.  Using the external monitor requires X restart, though.

... so that is my punishment ;-)

Cheers,
Stefan
Comment 9 Tomáš Chvátal (RETIRED) gentoo-dev 2009-09-01 13:15:56 UTC
Well i would recommend to switch onto xf86-video-ati. Sadly there is no hope in old ati-drivers releases, that is why i masked them too.

The bug since it is binary blob is cantfix, sorry.