Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 267031 - dev-lang/gforth-0.7.0: stabilisation request
Summary: dev-lang/gforth-0.7.0: stabilisation request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: gcc-4.3-stable
  Show dependency tree
 
Reported: 2009-04-21 21:59 UTC by Peter Fox
Modified: 2009-05-02 17:04 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log for gforth-0.6.2 showing build failure with gcc-4.3.2-r3 (build.log,8.30 KB, text/plain)
2009-04-21 22:03 UTC, Peter Fox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Fox 2009-04-21 21:59:48 UTC
Currently stable gforth-0.6.2 doesn't build with stable gcc-4.3.2-r3. gforth-0.7.0 does here.

Reproducible: Always

Steps to Reproduce:
1. emerge =gforth-0.6.0
2. build fails
3.
Comment 1 Peter Fox 2009-04-21 22:03:03 UTC
Created attachment 189101 [details]
Build log for gforth-0.6.2 showing build failure with gcc-4.3.2-r3
Comment 2 Peter Fox 2009-04-21 22:07:37 UTC
emerge --info:

Portage 2.2_rc28 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r5 i686)
=================================================================
System uname: Linux-2.6.28-gentoo-r5-i686-AMD_Sempron-tm-_Processor_2800+-with-glibc2.0
Timestamp of tree: Sat, 18 Apr 2009 21:30:17 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -pipe -ggdb"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=athlon-xp -O2 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://cool/ http://distfiles.gentoo.org"
LANG="en_GB"
LDFLAGS="-Wl,-O1"
LINGUAS="en en_GB es de fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/openchrome /usr/portage/local/layman/armagetron /usr/portage/local/layman/sunrise /usr/portage/local/layman/pro-audio /home/gentoo/portage /home/gentoo/overlays/gentoo-science-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X aalib acl acpi aiglx alsa apache2 audiofile berkdb bzip2 cairo cdr cli cracklib crypt cups curl dbus dlloader doc dri dvdr eds encode exif ffmpeg firefox flac fortran gd gdbm gif gimp gimpprint gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml hal iconv imagemagick imlib isdnlog jack java jbig jpeg jpeg2k lcms lynxkeymap mad mbox midi mikmod mmx mng mono mozilla mp3 mpeg mudflap ncurses nls nptl nptlonly ogg oggvorbis opengl openmp pam pcre pdf perl png pppd python qemu-fast quicktime readline reflection samba sdl session softmmu speex spell spl sqlite sse sse2 ssl svg sysfs tcpd tetex theora tiff truetype unicode usb vorbis win32codecs wmf x86 xine xml xml2 xorg xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en en_GB es de fr" USERLAND="GNU" VIDEO_CARDS="openchrome vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-23 20:34:05 UTC
(In reply to comment #0)
> Currently stable gforth-0.6.2 doesn't build with stable gcc-4.3.2-r3.
> gforth-0.7.0 does here.

Yeah, this has already been reported in bug #250834 but it seems like this package had been forgotten at the big gcc-4.3 stabilization round :)

CCing dirtyepic as he took the other bug as well...
Comment 4 Ryan Hill (RETIRED) gentoo-dev 2009-04-27 23:00:59 UTC
archs, go nuts.
Comment 5 Markus Meier gentoo-dev 2009-04-29 19:50:16 UTC
amd64/x86 stable
Comment 6 nixnut (RETIRED) gentoo-dev 2009-05-02 17:04:41 UTC
ppc stable. closing since we're last