Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266858 - gnome-base/gdm-2.20.10: many parser and validity errors
Summary: gnome-base/gdm-2.20.10: many parser and validity errors
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 274532 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-20 14:26 UTC by Robert Crawford
Modified: 2009-06-18 16:51 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Crawford 2009-04-20 14:26:09 UTC
Now I have another gdm-2.20.10 completely different error on another kde-svn installation partition (on the same box), but this install is 32bit- the other is amd64. SNIPPED about 100 similar lines previous to: 
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error : Content error in the external subset
<!ATTLIST setinfo
    ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: validity error : All markup of the conditional section is not in the same entity
<!ATTLIST setinfo
    ^
http://www.oasis-open.org/docbook/xml/4.1.2/dbhierx.mod:243: parser error : Content error in the external subset
<!ATTLIST setinfo
       ^
unable to parse fr/gdm.xml
make[2]: *** [gdm-fr.omf] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-base/gdm-2.20.10/work/gdm-2.20.10/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-base/gdm-2.20.10/work/gdm-2.20.10'
make: *** [all] Error 2
 *
 * ERROR: gnome-base/gdm-2.20.10 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2895:  Called gnome2_src_compile
 *             environment, line 2113:  Called die
 * The specific snippet of code:
 *       emake || die "compile failure"
 *  The die message:
 *   compile failure
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-04-20 14:43:07 UTC
you most likely have a corrupted docbook catalog. I'll come back later with instruction for how to fix it.
Comment 2 Robert Crawford 2009-04-21 09:11:46 UTC
(In reply to comment #1)
> you most likely have a corrupted docbook catalog. I'll come back later with
> instruction for how to fix it.
> 

Gilles,
I forgot to mention, this, and the other gdm bug I filed ( http://bugs.gentoo.org/show_bug.cgi?id=266857 ) ocurred on systems running kde-svn from the kde-testing overlay. However, don't know if this makes any difference, but I just successfully installed gdm-2.20.10 on another identical Gentoo 32 bit ~x86 system running kde-4.2.2 from portage.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-04-22 22:35:33 UTC
Ok, I didn't find where I left my nice comments about this kind of problems so let's try again.

First, please backup /etc/xml/catalog somewhere, then reinstall app-text/docbook-xml-dtd:4.1.2 (I assume it already is otherwise please say so but still continue with these instructions), make a diff between the backup and the new /etc/xml/catalog and attach it here.

Then you should be able to build gdm.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-04-27 20:18:24 UTC
please get back to us
Comment 5 Robert Crawford 2009-04-27 23:15:02 UTC
(In reply to comment #4)
> please get back to us
> 
Sorry-  I replied to 266857, and mentioned this one, too (both were filed concurrently), and assumed since it was the same person dealing with both of them that when they read my reply on 266857 they would also assume both problems were apparently resolved by rebuilding libpng. The corrupted docbook problem filed here disappeared without me doing anything else except just the rebuild of libpng. 
Comment 6 Gilles Dartiguelongue gentoo-dev 2009-05-31 08:56:39 UTC
reopening per comment #5
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-05-31 08:57:16 UTC
and closing, thanks for getting back to us.
Comment 8 Ignitus 2009-06-04 00:52:35 UTC
(In reply to comment #7)
> and closing, thanks for getting back to us.
> 

Just for record keeping. I ran in to this same issue not to long ago.  I just fixed it and I will post the diff in a few hours when I get a graphical browser running on the machine so its easier to copy and paste the diff for you.

I am more curious how the file became corrupt
Comment 9 Ignitus 2009-06-05 00:18:10 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > and closing, thanks for getting back to us.
> > 
> 
> Just for record keeping. I ran in to this same issue not to long ago.  I just
> fixed it and I will post the diff in a few hours when I get a graphical browser
> running on the machine so its easier to copy and paste the diff for you.
> 
> I am more curious how the file became corrupt
> 


 diff /etc/xml/catalog  ~/catalog.bak                                            
3a4,5                                                                                                          
>   <public publicId="-//OMF//DTD Scrollkeeper OMF Variant V1.0//EN" uri="/usr/share/xml/scrollkeeper/dtds/scro
llkeeper-omf.dtd"/>                                                                                            
>   <system systemId="http://scrollkeeper.sourceforge.net/dtds/scrollkeeper-omf-1.0/scrollkeeper-omf.dtd" uri="
/usr/share/xml/scrollkeeper/dtds/scrollkeeper-omf.dtd"/>                                                       
10a13
>   <system systemId="http://glade.gnome.org/glade-2.0.dtd" uri="/usr/share/xml/libglade/glade-2.0.dtd"/>

Couldn't get this up sooner
Comment 10 Gilles Dartiguelongue gentoo-dev 2009-06-17 21:40:55 UTC
hum that's not exactly what I would have expected to find as a diff since I have those two lines and it still builds fine. Maybe the problem is somewhere else. Nevermind we've got other reports with users have similar problem. Truth will eventually emerge :)
Comment 11 Gilles Dartiguelongue gentoo-dev 2009-06-18 06:20:26 UTC
*** Bug 274532 has been marked as a duplicate of this bug. ***
Comment 12 John D Maunder 2009-06-18 16:51:35 UTC
(In reply to comment #11)
> *** Bug 274532 has been marked as a duplicate of this bug. ***
> Thanks for the fix. Reemerged docbook and gdm emerged fine after that. Did a diff between old and new catalog and there were no differences between the files. Diff output was null. Do you require anymore info??????

Thanks for yuor help