Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266646 - app-portage/portage-utils: qpkg doesn't find package with -rX to merge
Summary: app-portage/portage-utils: qpkg doesn't find package with -rX to merge
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage Utils Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-18 13:43 UTC by Jorge Manuel B. S. Vicetto
Modified: 2011-02-21 07:34 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
portage-utils-atom-revision.patch (portage-utils-atom-revision.patch,1.89 KB, patch)
2009-07-28 15:18 UTC, Tiago Cunha (RETIRED)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2009-04-18 13:43:32 UTC
qpkg fails to match any package with a revision (-rX) and thus won't build a binary package for it.

atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qlist -Iv dev-db/mysql
dev-db/mysql-5.0.76-r1
dev-db/mysql-init-scripts-1.2
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qpkg dev-db/mysql
 * 1 package could not be matched :/
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qlist -Iv amarok
media-sound/amarok-2.0.2-r1
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qpkg amarok
 * 1 package could not be matched :/
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qlist -Iv webapp-config
app-admin/webapp-config-1.50.16-r3
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qpkg webapp-config
 * 1 package could not be matched :/

It does work for packages without revisions:

atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qlist -Iv sys-apps/portage
sys-apps/portage-2.2_rc30
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qpkg portage
 - sys-apps/portage-2.2_rc30: 822 kB
 * Packages can be found in /home/atlantis/binpkgs
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qlist -Iv portage-utils
app-portage/portage-utils-0.2
atlantis@lap64 /home/gentoo-cvs/gentoo-projects/portage-utils $ qpkg portage-utils
 - app-portage/portage-utils-0.2: 113 kB
 * Packages can be found in /home/atlantis/binpkgs
Comment 1 Tiago Cunha (RETIRED) gentoo-dev 2009-07-28 15:18:05 UTC
Created attachment 199450 [details, diff]
portage-utils-atom-revision.patch

Apparently, the problem is that portage-utils was using atom->P, instead of atom->PVR. I've changed things a bit in atom_explode.c:atom_explode to not append -r0 to PVR, and thus matching portage's behaviour (although, it still contains PN), and use it instead in qpkg.c:qpkg_make.

The patch should apply against HEAD.
Hope it's the correct approach, though.
Comment 2 SpanKY gentoo-dev 2011-02-21 07:34:33 UTC
should work with portage-utils-0.4