Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 266310 - sys-apps/util-linux: cfdisk cannot 'seek' disk
Summary: sys-apps/util-linux: cfdisk cannot 'seek' disk
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL: http://groups.google.com/group/linux....
Whiteboard:
Keywords: Inclusion
Depends on:
Blocks:
 
Reported: 2009-04-15 22:06 UTC by Roel Brook
Modified: 2010-03-07 04:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Strace ouput of cfdisk up until the error message (strace2,8.30 KB, text/plain)
2009-04-15 22:07 UTC, Roel Brook
Details
The patch proposed by Thorsten Gunkel on Debian's bugzilla (patch.txt,252 bytes, patch)
2009-04-15 22:08 UTC, Roel Brook
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Roel Brook 2009-04-15 22:06:08 UTC
I'm getting the following error when running cfdisk /dev/mapper/isw_dagchgecca_Data:
                     FATAL ERROR: Cannot seek on disk drive
                          Press any key to exit cfdisk

The error is also described in Debian's bugzilla (see URL), which suggest this is a problem with opening large disks.

cfdisk on a other (smaller) dmraid array on the same controller works fine.

Reproducible: Always

Steps to Reproduce:




I have 2 arrays defined on the controller; a RAID1 of 33.8GB and a RAID0 of 1932.7 GB. The controller is a soft / fake ICH9R BIOS raid controller. The problem is only present when opening the RAID0 array.

fdisk -l on the array DOES work, but when creating a new partition it tells me there are "no free sectors", while there is ~30GB unallocated on the disk.

The patch in the URL might be the solution.
Comment 1 Roel Brook 2009-04-15 22:07:16 UTC
Created attachment 188505 [details]
Strace ouput of cfdisk up until the error message

The line:

lseek(3, 18446743624680418304, SEEK_SET) = -1 EINVAL (Invalid argument)

is probably the cause of the error.
Comment 2 Roel Brook 2009-04-15 22:08:55 UTC
Created attachment 188506 [details, diff]
The patch proposed by Thorsten Gunkel on Debian's bugzilla
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-18 16:12:38 UTC
Please post your "emerge --info" and the output of

  cfdisk -v
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-22 21:42:19 UTC
Reopen this bug when you provide the requested information.
Comment 5 Roel Brook 2009-04-25 17:58:27 UTC
Sorry for the late reply:

Medusa ~ # emerge --info
Portage 2.1.6.11 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-zen1 x86_64)
=================================================================
System uname: Linux-2.6.29-zen1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 25 Apr 2009 17:20:01 +0000
app-shells/bash:     4.0_p17-r1
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2, 2.6.1-r1
dev-util/cmake:      2.6.3-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.9
sys-devel/autoconf:  2.13, 2.63-r1
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -msse4.1 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/eselect/postgresql /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.muntinternet.net/pub/gentoo/ http://gentoo.tiscali.nl/ http://de-mirror.org/distro/gentoo/ http://mirror.muntinternet.net/pub/gentoo/ ftp://gentoo.tiscali.nl/pub/mirror/gentoo/"
LANG="nl_NL.UTF-8"
LC_ALL="nl_NL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="nl en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/zen-overlay /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac aalib acl alsa amd64 apache2 bash-completion branding bzip2 cli cracklib crypt cups curl dbus device-mapper directfb divx dri emerald exif fat ffmpeg flac fortran fuse gdbm glitz gnome gphoto2 gpm gtk hal iconv id3tag imagemagick ipod isdnlog java jfs jpeg kqemu libcaca lzo matroska midi mktemp mmx mmxext mp3 mudflap multilib mysql ncurses nls nptl nptlonly nsplugin ntfs offensive opengl openmp pam pcre perl php png postgres pppd python rar readline realmedia reflection reiser4 reiserfs session skins spl sqlite sse sse2 ssl ssse3 sysfs tcpd theora threads tiff tk unicode v4l v4l2 vcd vcdx vim-syntax vorbis wmp wub32codecs x264 xattr xcomposite xfce xfs xorg xscreensaver xulrunner xvid zeroconf zlib" ALSA_CARDS="snd_hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="nl en" USERLAND="GNU" VIDEO_CARDS="nvidia nv"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Medusa ~ # cfdisk -v
cfdisk (util-linux-ng 2.14.2)
Copyright (C) 1994-2002 Kevin E. Martin & aeb
Comment 6 SpanKY gentoo-dev 2009-05-05 22:02:41 UTC
should be fixed with util-linux 2.15
Comment 7 Roel Brook 2009-05-07 22:22:28 UTC
Yep. that did the trick with cfdisk. fdisk still gives me the error there are no free sectors available, but this is solved for cfdisk.
Comment 8 Marko Weber Bürgermeister 2010-03-02 00:21:50 UTC
(In reply to comment #7)
> Yep. that did the trick with cfdisk. fdisk still gives me the error there are
> no free sectors available, but this is solved for cfdisk.
> 

Still having this Bug here on 1.5 TB Disks

root@rescue ~ # cfdisk -v
cfdisk (util-linux-ng 2.13.1.1)
Copyright (C) 1994-2002 Kevin E. Martin & aeb

Comment 9 SpanKY gentoo-dev 2010-03-07 04:55:22 UTC
try using a version that is actually in the tree now