Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265861 - x11-drivers/xf86-input-synaptics-1.0.0: ALPS touchpad doesn't work
Summary: x11-drivers/xf86-input-synaptics-1.0.0: ALPS touchpad doesn't work
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Tony Vroon
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-12 14:16 UTC by Michael
Modified: 2009-04-14 17:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
lshal (h,115.72 KB, text/plain)
2009-04-12 14:18 UTC, Michael
Details
Xorg.log (Xorg.0.log,21.12 KB, text/plain)
2009-04-12 14:19 UTC, Michael
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael 2009-04-12 14:16:48 UTC
ALPS touchpad doesn't work on Acer EMachines E510 with gentoo-sources-2.6.29-r1, xorg-server-1.5.3-r5 [hal], xf86-input-synaptics-1.0.0. By the term "doesn't work" I mean it doesn't work at all, neither mouse move nor click etc.

Reproducible: Always

Steps to Reproduce:
1. Install xorg-server-1.5
Actual Results:  
Touchpad doesn't work (usb mouse works ok)

Expected Results:  
Touchpad works

emerge --info
Portage 2.2_rc30 (default/linux/x86/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29-gentoo-r1 i686)                                                                             
=================================================================                        
System uname: Linux-2.6.29-gentoo-r1-i686-Genuine_Intel-R-_CPU_T1400_@_1.73GHz-with-glibc2.0                                                                                      
Timestamp of tree: Sun, 12 Apr 2009 07:30:02 +0000                                       
distcc 3.1 i686-pc-linux-gnu [disabled]                                                  
app-shells/bash:     4.0_p10                                                             
dev-java/java-config: 2.1.7                                                              
dev-lang/python:     2.5.4-r2                                                            
dev-util/cmake:      2.6.2-r1                                                            
sys-apps/baselayout: 2.0.0                                                               
sys-apps/openrc:     0.4.3-r1                                                            
sys-apps/sandbox:    1.6                                                                 
sys-devel/autoconf:  2.13, 2.63-r1                                                       
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                           
sys-devel/binutils:  2.19.1-r1                                                           
sys-devel/gcc-config: 1.4.1                                                              
sys-devel/libtool:   2.2.6a                                                              
virtual/os-headers:  2.6.28-r1                                                           
ACCEPT_KEYWORDS="x86 ~x86"                                                               
CBUILD="i686-pc-linux-gnu"                                                               
CFLAGS="-O2 -march=i686 -pipe -mssse3"                                                   
CHOST="i686-pc-linux-gnu"                                                                
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config /var/bind /var/lib/hsqldb"                                                                        
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"                                                                   
CXXFLAGS="-O2 -march=i686 -pipe -mssse3"                                                 
DISTDIR="/mnt/nfshome/distfiles"                                                         
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.mirrors.tds.net/gentoo "
LANG="ru_UA.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru uk"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/php-testing /usr/local/portage"
SYNC="rsync://home/gentoo-portage"
USE="3dnow X aac acl acpi alsa bash-completion berkdb bzip2 cairo cdr cli cracklib cryptcss ctype cups curl curlwrappers cxx dbus dbx djvu dri dvd dvdr dvdread encode expat fbcon ffmpeg firefox flac fontconfig fortran ftp gd gdbm gif gimp gpm gtk hal hddtemp htmlhandbook iconv icq imagemagick imap ipv6 isdnlog java javascript jpeg kde kdeprefix kdm laptop libwww lm_sensors mhash midi mime mmx mp3 mpeg mplayer mudflap mysql ncurses nls nptlnptlonly ogg openal opengl openmp pam pcmcia pcre pdf perl plasma png posix pppd python qt4 quicktime rdesktop readline recode reflection rss samba session slang smp sockets spell spl sqlite sse sse2 ssl sysfs syslog taglib tcpd threads tiff truetype unicode usb vcdvim-syntax vnc vorbis wifi win32codecs wxwindows x86 xattr xcb xcomposite xine xml xmlrpc xorg xscreensaver xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev mouse keyboard synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru uk" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Michael 2009-04-12 14:18:47 UTC
Created attachment 188088 [details]
lshal
Comment 2 Michael 2009-04-12 14:19:50 UTC
Created attachment 188089 [details]
Xorg.log
Comment 3 Rafał Mużyło 2009-04-12 15:35:47 UTC
Be more verbose about what doesn't work.
Did you test it with xinput ?
Comment 4 Michael 2009-04-12 15:47:01 UTC
(In reply to comment #3)
> Be more verbose about what doesn't work.
> Did you test it with xinput ?
> 

Just tested the touchpad with xinput. It doesn't send any events (motion, button press, button release or any other)
Comment 5 Michael 2009-04-13 11:02:47 UTC
I do some additional testing. I've recompiled the kernel with psmouse as a module. If I unload psmouse, then touch the touchpad and load the module again, the touchpad works for a moment after the first touch. I mean I can do a simple move or a click and then the touchpad stops working. So I suppose it's a kernel bug rather than synaptics itself.
Comment 6 Michael 2009-04-14 16:49:06 UTC
I found some related errors in dmesg:

[  379.547466] input: PS/2 Mouse as /devices/platform/i8042/serio1/input/input21         
[  379.595308] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio1/input/input22                                                                                    
[  380.817992] psmouse.c: GlidePoint at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.                                                                        
[  381.341211] psmouse.c: resync failed, issuing reconnect request
Comment 7 Tony Vroon gentoo-dev 2009-04-14 17:05:55 UTC
I'm sorry, this is the kernel losing synchronisation. The kernel driver appears to have attached to a device that does not speak the expected protocol (perhaps because it is behind an unrecognised PS/2 multiplexer or because it claims to be a Synaptics-compatible touchpad but isn't).
There is nothing that a driver can do about this in userspace.