Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265776 - >=dev-libs/libpcre-7.8-r1 does not build static libpcre.la (breaks dolphin)
Summary: >=dev-libs/libpcre-7.8-r1 does not build static libpcre.la (breaks dolphin)
Status: VERIFIED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
: 266244 308623 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-11 16:08 UTC by Markus Strobl
Modified: 2010-03-09 10:21 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Markus Strobl 2009-04-11 16:08:56 UTC
Since libpcre-7.8-r1 it no longer builds the static libpcre.la. This breaks dev-libs/redland. 

Now this wouldn't be a big deal except that kde-misc/dolphin requires soprano built with redland, and I really like dolphin. :)

 

Reproducible: Always




As a workaround I used libpcre-7.8 and everything (redland, soprano, dolphin) builds
Comment 1 Rafał Mużyło 2009-04-11 16:14:40 UTC
libpcre.la is/was not a static lib.
grep for it in other la files in /usr/lib
to see which packages you may want to reemerge
(or simply sed it out out of them)
Comment 2 Markus Strobl 2009-04-11 16:31:56 UTC
Well, when I check the files that are provided by libpcre-7.8 I get:

markus@markuspc ~ $ equery f libpcre | grep libpcre.la
/usr/lib64/libpcre.la

If I do the same on libpcre-7.8-r1 or newer there is no libpcre.la. Also, when building libpcre-7.8 there is a summary displayed that says "build static libs: yes". In 7.8-r1 and never that same printout says "build static libs: no".

I'm not sure what you mean when you say "grep for it in usr/lib"? Redland explicitly links against libpcre.la and fails when it can't find the file.

Am I missing something? (Wouldn't be the first time :)

 
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-11 16:35:27 UTC
The .la files were removed by intention:

*libpcre-7.8-r1 (09 Apr 2009)

  09 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> -libpcre-7.7-r1.ebuild,
  +libpcre-7.8-r1.ebuild, +libpcre-7.9_rc2.ebuild:
  Bump. No longer include .la and .a files. Revision bump for 7.8 with the
  same changes. Move libpcre.so* to /lib for grep - bug 1638 and bug 53627.
Comment 4 Markus Strobl 2009-04-11 16:43:46 UTC
I understand libpcre.la was removed intentionally, but it doesn't change the fact that another package depends on it. Please provide a solution before closing the bug as currently it is not possible to emerge dolphin which is the recommended KDE filemanager. 

Note: If you feel that this is a bug in the redland package then I guess this bug can be closed and I'll open a new bug on redland. Or maybe this is a bug in dolphin (does it really require the currently hard-coded redland backend dependency)?

Basically, what I'm saying is please don't close a bug without giving a solution or at least a way forward.  
Comment 5 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-11 16:52:55 UTC
Redland builds fine for me. Have you tried:
revdep-rebuild -i -- -a
revdep-rebuild can be found in gentoolkit.
Comment 6 Markus Strobl 2009-04-11 17:22:54 UTC
AHA! Thanks, Peter. Revdep-rebuild found that dev-libs/rasqal needed a rebuild after libpcre was updated. Looks like Redland uses rasqal so once rasqal had been rebuilt, redland built also. 

Man bugar och tackar!  
Comment 7 Markus Strobl 2009-04-11 17:23:14 UTC
Closing.
Comment 8 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-15 21:07:08 UTC
*** Bug 266244 has been marked as a duplicate of this bug. ***
Comment 9 Samuli Suominen (RETIRED) gentoo-dev 2010-03-09 10:21:36 UTC
*** Bug 308623 has been marked as a duplicate of this bug. ***