Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265560 - app-editors/vim-7.2.108 drops all classical syntax highlighting
Summary: app-editors/vim-7.2.108 drops all classical syntax highlighting
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: Vim Maintainers
Depends on:
Reported: 2009-04-09 15:06 UTC by Tamas Haraszti
Modified: 2009-04-13 18:53 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

the equery files app-editors/vim-core response (emerge-vim-info,20.30 KB, text/plain)
2009-04-11 06:31 UTC, Tamas Haraszti
emerge --info about my system (emergeinfo,8.06 KB, text/plain)
2009-04-11 06:37 UTC, Tamas Haraszti

Note You need to log in before you can comment on or make changes to this bug.
Description Tamas Haraszti 2009-04-09 15:06:57 UTC
When installed the newest vim, all syntax highlighting went away. 

A bit confusing, that the /usr/share/vim contains two folders, vim72 and vimfiles, from which the vimfiles/syntax is the one used.
I do not know the developmental issues, but picking all the syntax files from the vim-7.2 tar source (downloading the source from, runtime/syntax solved the issue. 

The /usr/share/vim/vim72/doc folder is also missing together with the help.txt.
Which package should be emerged to fix this? At the moment I copied the runtime doc folder over this, which fixed the system for me.
Comment 1 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-04-10 16:54:48 UTC
It sounds to me like something really bad happened when your system installed app-editors/vim-core.  I suspect if you reinstall it, this problem will be solved.

Though honestly, I can't imagine how the install could "succeed" and leave you with such a broken system.  Would you mind posting your 'emerge --info' as well as what version of app-editors/vim-core you have installed?

Also useful would be the output of 'equery files app-editors/vim-core', but please attach that, don't just post it as a reply, thanks :)


More information about the 2 folders:

There are two folders in /usr/share/vim for a reason.  The 'vim72' one is for the stock vim files (installed by app-editors/vim-core), and 'vimfiles' is the location where 3rd-party plugins put their stuff.  Vim searches both at runtime, and this is by design of the vim authors - The default runtime search path list is:

"$HOME/.vim, $VIM/vimfiles, $VIMRUNTIME, $VIM/vimfiles/after, $HOME/.vim/after"

Where the default for $VIM is '/usr/share/vim' and $VIMRUNTIME is '/usr/share/vim/vim72'.

Once you have your help.txt back, try ":help rtp" and you'll see this text:

The defaults for most systems are setup to search five locations:
        1. In your home directory, for your personal preferences.
        2. In a system-wide Vim directory, for preferences from the system
        3. In $VIMRUNTIME, for files distributed with Vim.
        4. In the "after" directory in the system-wide Vim directory.  This is
           for the system administrator to overrule or add to the distributed
           defaults (rarely needed)
        5. In the "after" directory in your home directory.  This is for
           personal preferences to overrule or add to the distributed defaults
           or system-wide settings (rarely needed).
Comment 2 Tamas Haraszti 2009-04-11 06:31:09 UTC
Created attachment 187953 [details]
the equery files app-editors/vim-core response

Here is the equery response as requested. There is no vim.c or help.txt in this one.
Comment 3 Tamas Haraszti 2009-04-11 06:37:46 UTC
Created attachment 187955 [details]
emerge --info about my system

This is the emerge --info about my system
Comment 4 Tamas Haraszti 2009-04-11 06:39:36 UTC
Thanks for the reply.

Attached are the requested information files. 
The system is a gentoo, where a month ago I upgraded to gcc-4.3.3. The ~x86 keyword is enabled.

The vim is:
app-editors/vim-core-7.2.108  USE="acl livecd nls -bash-completion"
Comment 5 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-04-13 16:11:01 UTC
(In reply to comment #4)
> The vim is:
> app-editors/vim-core-7.2.108  USE="acl livecd nls -bash-completion"

AHA!  You should change this to -livecd and all your problems will be solved.

You should probably investigate where this USE flag is is set on your system -> If it's set in /etc/make.conf, this may hurt your more places than just vim.

The 'livecd' flag is only for those people building livecds.  From 'euse -i livecd':

livecd - !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used during livecd building

They need to trim things down to save space, and do other weird things.  Specifically in the case of vim-core, this deletes the entire 'doc' directory and large sections of the syntax files.
Comment 6 Tamas Haraszti 2009-04-13 18:53:30 UTC
Thanks Jim, the livecd flag was set in my make.conf. I set it to '-livecd', and reemerged vim-core. It is fine now. Silly error. 

Thanks again, problem solved.