Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265411 - Hibernate to disk causes xorg and later complete system freeze (only with KDE4)
Summary: Hibernate to disk causes xorg and later complete system freeze (only with KDE4)
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-08 08:46 UTC by x.para
Modified: 2009-12-30 12:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Kernel Config (.config,68.40 KB, text/plain)
2009-04-13 19:16 UTC, x.para
Details

Note You need to log in before you can comment on or make changes to this bug.
Description x.para 2009-04-08 08:46:03 UTC
Typing hibernate into console in KDE 4.2 causes KDE to freeze, also xorg server
stop responding after few moments.

This is only related to KDE 4.2. On same machine on different slot there is KDE
3.5 installed and this issue is not observed there at all.

Running gentoo-sources-2.6.26-r4, and nvidia drivers 180.44.

Reproducible: Sometimes

Steps to Reproduce:
1.Login to KDE4
2.Open at least 4 applications (konqueror, konsole, kopete, firefox)
3.type "hibernate to konsole"

Actual Results:  
System stops to respond, xorg is stopped, input devices stop to work, keyboard is dead

Expected Results:  
System goes to hibernate state like a charm

Hibernate-ram works fine, no issues observed
Comment 1 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-10 22:54:18 UTC
Probably be wise to see:
*emerge --info
*kernel .config

Binary drivers are woefully known for "issues" - have you tried any others?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-13 18:40:03 UTC
Reopen this bug when you provide the requested information.
Comment 3 x.para 2009-04-13 19:12:23 UTC
emerge --info

Portage 2.1.6.7 (default/linux/x86/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r7-i686-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-glibc2.0
Timestamp of tree: Thu, 09 Apr 2009 18:30:17 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.3.5
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo"
LANG="cs_CZ"
LC_ALL="cs_CZ"
LDFLAGS="-Wl,-O1"
LINGUAS="cs en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/berkano /usr/portage/local/layman/kde-testing"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa berkdb bzip2 cdr cli cracklib crypt cups dbus dri dvb dvd fortran gdbm gif gpm hal iconv ipv6 isdnlog jpeg kde kdehiddenvisibility kdeprefix logitech-mouse midi mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl pppd python qt3 qt4 readline reflection session spell spl ssl sysfs tcpd unicode v4l2 vdpau x264 x86 xcomposite xinerama xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="cs en" LIRC_DEVICES="serial sir" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

#####
#####
#####


Comment 4 x.para 2009-04-13 19:16:07 UTC
Created attachment 188260 [details]
Kernel Config

Kernel Config
Comment 5 Jeroen Roovers (RETIRED) gentoo-dev 2009-04-14 15:17:27 UTC
Hmm, `emerge --info' disagrees on the kernel you are running (2.6.26-r4 vs. 2.6.27-gentoo-r7).
Comment 6 x.para 2009-04-14 17:37:51 UTC
It was my typo mistake in previous bug. I really run 2.6.27-gentoo-r7

uname -a
Linux stable 2.6.27-gentoo-r7 #26 PREEMPT Sun Apr 5 10:08:41 CEST 2009 i686 Inte
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2009-12-01 15:52:40 UTC
This aint kde-bug at all. Wranglers plz wrangle.
Comment 8 Wormo (RETIRED) gentoo-dev 2009-12-02 06:49:08 UTC
When you try hibernating and it fails, does it leave progress messages in /var/log/hibernate.log ? If so, that would be a good thing to post -- especially with an example of hibernating that worked from KDE3 vs not working from KDE4.