Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265406 - x11-wm/fluxbox-1.1.1 displays themes differently at startup compared to 'reconfigure'
Summary: x11-wm/fluxbox-1.1.1 displays themes differently at startup compared to 'reco...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Jim Ramsay (lack) (RETIRED)
URL:
Whiteboard:
Keywords:
: 277141 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-08 07:40 UTC by Michał Kiedrowicz
Modified: 2009-07-09 16:59 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Screenshot with inproperly displayed decorations (2009.04.08-09:35:12.png,1.90 MB, image/png)
2009-04-08 07:41 UTC, Michał Kiedrowicz
Details
Screenshot after refreshing configuration (2009.04.08-09:35:17.png,1.90 MB, image/png)
2009-04-08 07:42 UTC, Michał Kiedrowicz
Details
My theme used in screenshots (theme.cfg,4.02 KB, text/plain)
2009-04-08 07:42 UTC, Michał Kiedrowicz
Details
My ~/.fluxbox/init (init,3.24 KB, text/plain)
2009-04-12 01:47 UTC, Michał Kiedrowicz
Details
My theme with pixmaps (black.theme.tar.bz2,1.36 KB, application/octet-stream)
2009-04-12 01:50 UTC, Michał Kiedrowicz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Kiedrowicz 2009-04-08 07:40:25 UTC
Hi,

fluxbox-1.1.1 has problems displaying decorations immediately after startup. After refreshing configuration (from root menu), this problem disapears. On fluxvox-1.0.0-r2 everything is correct.

Two screenshots follow: one with invalid decorations and after refreshing configuration.


Reproducible: Always
Comment 1 Michał Kiedrowicz 2009-04-08 07:41:24 UTC
Created attachment 187663 [details]
Screenshot with inproperly displayed decorations
Comment 2 Michał Kiedrowicz 2009-04-08 07:42:03 UTC
Created attachment 187664 [details]
Screenshot after refreshing configuration
Comment 3 Michał Kiedrowicz 2009-04-08 07:42:53 UTC
Created attachment 187666 [details]
My theme used in screenshots
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-08 20:06:02 UTC
Please post your "emerge --info".
Comment 5 Michał Kiedrowicz 2009-04-08 20:17:14 UTC
Portage 2.2_rc12 (default/linux/amd64/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_CPU_6300_@_1.86GHz-with-glibc2.2.5
Timestamp of tree: Wed, 01 Apr 2009 19:20:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe -ggdb"
DISTDIR="/usr/portage.distfiles"
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS=" 	http://gentoo.prz.rzeszow.pl 	ftp://gentoo.po.opole.pl 	ftp://pandemonium.tiscali.de/pub/gentoo/ 	ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="pl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac alsa amd64 bash-completion berkdb bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread encode flac gd gdbm gif gnutls gpm gstreamer gtk hal iconv java jpeg kdeenablefinal kdehiddenvisibility lcms lm_sensors logrotate mad midi mmx mp3 mpeg mudflap multilib musepack ncurses nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcre pdf perl png python quicktime readline sasl sdl session slang spell spl sse sse2 ssl svg sysfs tcpd threads truetype unicode vim-syntax vorbis xcomposite xml xorg xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="pl" USERLAND="GNU" VIDEO_CARDS="intel i810 i830 i915 vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


I'm also experiencing the same problem on my completely stable amd64 at work, but I'm not able to post emerge --info of that system now.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-10 22:52:25 UTC
assigning to maintainer
Comment 7 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-04-12 00:02:21 UTC
Can you please also attach your ~/.fluxbox/init

Are you using true transparency with xcompmgr, or pseudo-transparency?
Comment 8 Michał Kiedrowicz 2009-04-12 01:47:09 UTC
Created attachment 188041 [details]
My ~/.fluxbox/init
Comment 9 Michał Kiedrowicz 2009-04-12 01:48:44 UTC
(In reply to comment #7)
> Are you using true transparency with xcompmgr, or pseudo-transparency?
> 

Only pseudo-transparency, but I have "Composite" enabled in /etc/X11/xorg.conf

Comment 10 Michał Kiedrowicz 2009-04-12 01:50:21 UTC
Created attachment 188044 [details]
My theme with pixmaps
Comment 11 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-04-13 13:30:45 UTC
While it does look to me like there's some sort of bug in the way fluxbox does things the first time with a style (and technically there are other bugs of this sort), they usually only occur when there are minor problems in the style.

For example, I noticed that your .xpm files are 20x20 in size, but you have set window.title.height to 22.  Take a close look at your "before" and "after" screenshots.  You can see that in the "before" there are 2 pixels of space to the right and bottom of each of your buttons.  In the "after", fluxbox has scaled your images up to be 22x22, at some loss of quality, but it covers the weird purple holes that appear.

I suspect that if you either increase the size of your .xpm files to 22x22, or reduce your window hight to 20, your problems will go away.

Give this a shot and let me know if it works around the problem.

Though this should still be reported to upstream as well, since I believe it is indeed a bug -> It should be consistent one way or the other.
Comment 12 Michał Kiedrowicz 2009-04-13 14:11:56 UTC
(In reply to comment #11)
> I suspect that if you either increase the size of your .xpm files to 22x22, or
> reduce your window hight to 20, your problems will go away.
> 
> Give this a shot and let me know if it works around the problem.
> 
> Though this should still be reported to upstream as well, since I believe it is
> indeed a bug -> It should be consistent one way or the other.
> 

Yes, you were right, reducing window titlebar height to 20 caused tilebar to be displayed correctly.

And yes, I agree that still it is a bug that should be fixed :)
Comment 13 Kazankov Alexander 2009-04-15 13:52:25 UTC
For me the similar situation, but only for me is more than icon than window.title. I think that it is regress in functions of start/restart of session. How to be told in the description of the given problem:

> After refreshing configuration (from root menu), this problem disapears. 

but if to restart fluxbox (from root menu) the problem comes back.
Comment 14 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-04-15 14:16:58 UTC
(In reply to comment #13)
> For me the similar situation, but only for me is more than icon than
> window.title.

If you see the same types of visual artifacts, it is probably because of a mis-match between your theme's value for 'window.title.height' and your window button graphic size.

But yes, regarding the rest of your comment, there is certainly a difference between how fluxbox treats themes at startup (or restart) and reconfigure.

This difference is a bug that needs to be fixed.  But you can work around it by ensuring that your theme has the same value for window.title.height and the size of the window button graphics.
Comment 15 Jim Ramsay (lack) (RETIRED) gentoo-dev 2009-07-09 16:59:52 UTC
*** Bug 277141 has been marked as a duplicate of this bug. ***