Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265376 - Stabilize sys-apps/sandbox-1.6-r2
Summary: Stabilize sys-apps/sandbox-1.6-r2
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Sandbox Maintainers
URL:
Whiteboard:
Keywords: STABLEREQ
: 266625 (view as bug list)
Depends on:
Blocks: 265107
  Show dependency tree
 
Reported: 2009-04-07 19:50 UTC by SpanKY
Modified: 2009-04-26 19:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
testsuite.log (testsuite.log,115.90 KB, text/plain)
2009-04-08 14:24 UTC, Dustin Polke
Details
sys-apps/sanbox tests log (testsuite.log,123.50 KB, text/plain)
2009-04-18 01:43 UTC, Jerome Potts
Details
testsuite.log (testsuite.log,1.27 KB, text/plain)
2009-04-18 14:21 UTC, Raúl Porcel (RETIRED)
Details
tests/testsuite.log (testsuite.log,124.04 KB, text/plain)
2009-04-18 17:00 UTC, Jerome Potts
Details

Note You need to log in before you can comment on or make changes to this bug.
Description SpanKY gentoo-dev 2009-04-07 19:50:20 UTC
the 1.6-r# are "new", but they only contain specific fixes to 1.6 ... otherwise, the 1.6 version should be OK to stabilize as it has no known regressions to stable (but certainly plenty of fixes)
Comment 1 Dustin Polke 2009-04-08 14:24:19 UTC
Created attachment 187695 [details]
testsuite.log

make[2]: Entering directory `/var/tmp/portage/sys-apps/sandbox-1.6-r2/work/build-sparc64/tests'
/bin/sh '../../sandbox-1.6/tests/testsuite'
## ----------------------- ##
## sandbox 1.6 test suite. ##
## ----------------------- ##
  1: access/1                                        ok
  2: chmod/1                                         ok
  3: chown/1                                         ok
  4: fchmodat/1                                      ok
  5: fchownat/1                                      ok
  6: fchownat/2                                      ok
  7: lchown/1                                        ok
  8: libsigsegv                                      FAILED (libsigsegv.at:3)
  9: mkdir/1                                         skipped (mkdir.at:1)
 10: mkdir/2                                         ok
 11: mkdir/3                                         skipped (mkdir.at:3)
 12: open/1                                          ok
 13: sb_printf                                       ok
 14: script/1                                        skipped (script.at:1)
 15: script/2                                        skipped (script.at:2)
 16: script/3                                        skipped (script.at:3)
 17: script/4                                        skipped (script.at:4)
 18: script/5                                        skipped (script.at:5)
 19: script/6                                        skipped (script.at:6)

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: 11 tests were run,
1 failed unexpectedly.
8 tests were skipped.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##
Comment 2 Dustin Polke 2009-04-08 14:49:42 UTC
(In reply to comment #1)

For completeness, this is on sparc multilib profile with additional FEATURES="-userpriv"

Portage 2.1.6.7 (default/linux/sparc/experimental/multilib/server, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 sparc64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-sparc64-sun4u-with-glibc2.0
Timestamp of tree: Wed, 08 Apr 2009 08:20:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.7.9-r1, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-O2 -mcpu=ultrasparc -pipe -ggdb"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=ultrasparc -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms splitdebug strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/             ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/                ftp://gd.tuwien.ac.at/opsys/linux/gentoo/             ftp://pandemonium.tiscali.de/pub/gentoo/                 ftp://gentoo.inode.at/source/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS=""
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/modified /usr/portage/local/own"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="acl admin apache2 bash-completion berkdb bzip2 cli courier coverpage cracklib crypt cups dri fortran gd gdbm gpm iconv iproute2 isdnlog javascript jpeg kerberos ldap logrotate midi mime mudflap multilib ncurses nls nptl nptlonly openmp pam pcre perl php png posix pppd python readline reflection sasl session snmp sparc spl ssl suhosin sysfs syslog tcpd threads tiff truetype unicode userlocales xml xorg zlib" ALSA_CARDS="cs4231" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias asis auth_digest authn_anon authn_dbm authz_host        autoindex cache cern_meta charset_lite dav dav_fs deflate dir disk_cache        env expires ext_filter file_cache filter headers include info log_config       logio mem_cache mime mime_magic negotiation proxy proxy_connect         proxy_ftp proxy_http rewrite setenvif speling status unique_id userdir         usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="mach64"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS_FLAGS
Comment 3 Markus Meier gentoo-dev 2009-04-08 17:21:47 UTC
(In reply to comment #1)

this only happens when upgrading from the old sandbox, it passes w/o problems when remerging the 1.6-r2 version.
Comment 4 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-08 20:58:57 UTC
Indeed, tests success after remerge but after installing I get:

bluebird@opher ~ $ sandbox echo hello
(sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function rc_ls_dir(), line 108:
(sandbox)        strerror() = 'Permission denied'
(sandbox)        Failed to opendir() '/etc/sandbox.d'!
(sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function rc_ls_dir(), line 108:
(sandbox)        strerror() = 'Permission denied'
(sandbox)        Failed to opendir() '/etc/sandbox.d'!
(sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function rc_ls_dir(), line 108:
(sandbox)        strerror() = 'Permission denied'
(sandbox)        Failed to opendir() '/etc/sandbox.d'!
(sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function rc_ls_dir(), line 108:
(sandbox)        strerror() = 'Permission denied'
(sandbox)        Failed to opendir() '/etc/sandbox.d'!
hello

which is also trigger when running repoman. Permission of /etc/sandbox.d is 700 root:root

This also happens with 1.5, 1.6-r0, 1.7 and 1.8 so maybe it's just me? here's emerge-info:

Portage 2.1.6.7 (default/linux/sparc/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 sparc64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-sparc64-sun4u-with-glibc2.0
Timestamp of tree: Wed, 08 Apr 2009 18:00:02 +0000
app-shells/bash:     3.2_p39
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.6-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.8
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="sparc"
CBUILD="sparc-unknown-linux-gnu"
CFLAGS="-mcpu=ultrasparc3 -mtune=ultrasparc3 -O2 -frename-registers -pipe"
CHOST="sparc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-mcpu=ultrasparc3 -mtune=ultrasparc3 -O2 -frename-registers -pipe"
DISTDIR="/tmp/distfiles"
FEATURES="collision-protect distlocks metadata-transfer parallel-fetch sandbox strict test unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de en"
MAKEOPTS="-j17"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://anubis.lan.local.porno-bullen.de/gentoo-portage"
USE="64bit 7zip X a52 aac aalib ace agg alsa artworkextra ass audacious audiofile blender-game bluetooth bzip2 c++ caps clock-screen command-args cups curl custom-cflags cvs cxx dbus devhelp dga disk-partition divx doc dri dts dv dvd dvdread eds encode evo exif fastcgi fat festival ffmpeg flac fortran ftp fuse gd gif gimp gimpprint glade gmedia gnome gnome-print gnomecanvas gpm grammar gstreamer gtk hal heterogeneous hpn ieee1394 imap ipv6 ithreads javascript jpeg jpeg2k key-screen libsexy libvisual lyrics lzo mad mbrola memcache midi mikmod mjpeg mng mouse mp2 mp3 mpeg mpeg2 mplayer musepack musicbrainz nautilus ncurses network network-cron networking nls nptl nptlonly nsplugin objc offensive ogg openal opengl openmp opera optimize-cflags pam parallel pcre pdf png pnm ppds qt3support quicktime raw realmedia regex rtsp ruby samba sasl sdl sdl-image search-screen shout slang smartcard smp sms sound soundex source sourceview sparc speex spell sqlite3 ssl stream subversion svg symlink taglib tagwriting theora threads tiff timidity tools truetype tta unicode urandom usb userlocales utils vcd vidix vim vim-syntax vim-with-x vis visualization vorbis webdav-neon wma wmf wmp wordexp x264 xanim xcb xfce xine xinerama xmlrpc xorg xulrunner xv xvid zlib" ALSA_CARDS="CS4231" ALSA_PCM_PLUGINS="adpcm alaw copy dshare dsnoop extplug file hooks ladspa lfloat linear meter mulaw multi null rate route share shm asym dmix empty iec958 ioplug plug softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="ati mach64 fbdev mga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Dustin Polke 2009-04-08 21:43:34 UTC
(In reply to comment #4)
> Indeed, tests success after remerge
I can confirm this. Everything went smooth now. Maybe a notice in the ebuild is apropriate to inform users who upgrade sandbox?

> but after installing I get:
> 
> bluebird@opher ~ $ sandbox echo hello
> (sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function
> rc_ls_dir(), line 108:
> (sandbox)        strerror() = 'Permission denied'
> (sandbox)        Failed to opendir() '/etc/sandbox.d'!
> (sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function
> rc_ls_dir(), line 108:
> (sandbox)        strerror() = 'Permission denied'
> (sandbox)        Failed to opendir() '/etc/sandbox.d'!
> (sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function
> rc_ls_dir(), line 108:
> (sandbox)        strerror() = 'Permission denied'
> (sandbox)        Failed to opendir() '/etc/sandbox.d'!
> (sandbox) error: in ../../sandbox-1.6/libsbutil/src/file.c, function
> rc_ls_dir(), line 108:
> (sandbox)        strerror() = 'Permission denied'
> (sandbox)        Failed to opendir() '/etc/sandbox.d'!
> hello
> 
> which is also trigger when running repoman. Permission of /etc/sandbox.d is 700
> root:root
> 
> This also happens with 1.5, 1.6-r0, 1.7 and 1.8 so maybe it's just me? here's
No, happens on my box as well, but the correct permission of /etc/sandbox.d permission seems to be 755. With that there are no complaints anymore and sandbox seems to work correctly.
Comment 6 SpanKY gentoo-dev 2009-04-08 22:14:45 UTC
sounds like a bug on your system ... the ebuild does not set sandbox.d with 0700 permissions

$ ls -l /var/tmp/portage/sys-apps/sandbox-1.6-r2/image/etc/
total 12
drwxr-xr-x 2 root root 4096 2009-04-08 18:06 env.d
-rw-r--r-- 1 root root 2441 2009-04-08 18:06 sandbox.conf
drwxr-xr-x 2 root root 4096 2009-04-08 18:06 sandbox.d
Comment 7 SpanKY gentoo-dev 2009-04-09 00:23:16 UTC
if someone can figure out where/how the perms were set like that, we can add appropriate checks to the ebuild
Comment 8 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-09 20:03:24 UTC
(In reply to comment #7)
> if someone can figure out where/how the perms were set like that, we can add
> appropriate checks to the ebuild
> 

=dev-libs/openssl-0.9.8k (older versions probably too, but I didn't check) installs /etc/sandbox.d/10openssl and it creates /etc/sandbox.d with 0700 root:root because sandbox-1.2.18.1-r2 didn't include a sandbox.d config dir.

Steps to reproduce:
export ROOT=/tmp/testroot
emerge =sys-apps/sandbox-1.2.18.1-r2
emerge =dev-libs/openssl-0.9.8k
emerge =sys-apps/sandbox-1.6-r2
Comment 10 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-09 21:12:50 UTC
> http://sources.gentoo.org/sys-apps/sandbox/sandbox-1.6-r2.ebuild?r1=1.1&r2=1.2
> http://sources.gentoo.org/sys-apps/sandbox/sandbox-1.9.ebuild?r1=1.1&r2=1.2

Thanks, but shouldn't that read $ROOT instead of $D and chmod instead of chown? :) 

Comment 11 SpanKY gentoo-dev 2009-04-09 21:28:13 UTC
yes, thanks
Comment 12 Friedrich Oslage (RETIRED) gentoo-dev 2009-04-09 21:34:46 UTC
looks fine now :)

sparc stable
Comment 13 Tobias Klausmann gentoo-dev 2009-04-12 10:57:51 UTC
Stable on alpha.
Comment 14 Brent Baude (RETIRED) gentoo-dev 2009-04-12 18:10:12 UTC
ppc64 stable
Comment 15 Jeroen Roovers (RETIRED) gentoo-dev 2009-04-13 14:59:31 UTC
Stable for HPPA.
Comment 16 Markus Meier gentoo-dev 2009-04-15 19:40:41 UTC
amd64/x86 stable
Comment 17 Jerome Potts 2009-04-18 01:43:28 UTC
Created attachment 188757 [details]
sys-apps/sanbox tests log

I'm also failing some of the tests, my problem is visible in the attached tests/testsuite.log

I am upgrading from version 1.2.17

I am using "paludis" instead of "emerge".
Comment 18 Raúl Porcel (RETIRED) gentoo-dev 2009-04-18 14:17:06 UTC
arm/m68k/s390/sh stable
Comment 19 Raúl Porcel (RETIRED) gentoo-dev 2009-04-18 14:21:18 UTC
Created attachment 188793 [details]
testsuite.log

Fails on ia64:

 16: script/3                                        ok
 17: script/4                                        ok
 18: script/5                                        FAILED (script.at:5)
 19: script/6                                        ok
Comment 20 Jerome Potts 2009-04-18 17:00:51 UTC
Created attachment 188811 [details]
tests/testsuite.log

After trying out the sequence listed in comment number 8 (although i failed to create a /tmp/testroot dir), i now have 1 additional test fail.

And what i didn't report previously are scanelf errors which appear only on the console, but not in the log file; although those errors don't seem to correspond to the failing tests:

## ----------------------- ##
## sandbox 1.6 test suite. ##
## ----------------------- ##
  1: access/1                                        ok
  2: chmod/1                                         ok
  3: chown/1                                         ok
  4: fchmodat/1                                      FAILED (fchmodat.at:1)
  5: fchownat/1                                      ok
  6: fchownat/2                                      FAILED (fchownat.at:2)
  7: lchown/1                                        FAILED (lchown.at:1)
  8: libsigsegv                                      ok
  9: mkdir/1                                         FAILED (mkdir.at:1)
 10: mkdir/2                                         ok
 11: mkdir/3                                         FAILED (mkdir.at:3)
 12: open/1                                          FAILED (open.at:1)
 13: sb_printf                                       ok
 14: script/1                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 ok
 15: script/2                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 ok
 16: script/3                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 ok
 17: script/4                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 FAILED (script.at:4)
 18: script/5                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 ok
 19: script/6                                       scanelf: Invalid format specifier 'M' (byte 2)
scanelf: Invalid format specifier 'M' (byte 2)
 ok

## ------------- ##
## Test results. ##
## ------------- ##

ERROR: All 19 tests were run,
7 failed unexpectedly.
## -------------------------- ##
## testsuite.log was created. ##
## -------------------------- ##

Please send `tests/testsuite.log' and all information you think might help:

   To: <sandbox@gentoo.org>
   Subject: [sandbox 1.6] testsuite: 4 6 7 9 11 12 17 failed
Comment 21 SpanKY gentoo-dev 2009-04-18 17:05:36 UTC
your system has a horribly out of date pax-utils and you arent using stable.  but i'll force a newer version since i imagine other people are being lazy as well.

Raúl: that ia64 failure has been fixed in newer versions and technically, it's not a regression.  older sandboxes would fail the same way under ia64 (there just wasnt a test for it).  i.e. ignore it and stabilize anyways ;).
Comment 22 Jerome Potts 2009-04-18 17:51:59 UTC
(In reply to comment #21)
> your system has a horribly out of date pax-utils and you arent using stable. 
> but i'll force a newer version since i imagine other people are being lazy as
> well.

I'm trying to upgrade Portage, which will pull a newer Pax-utils in after the upgrade of Sandbox (Yes, although i use Paludis, /usr/sbin/python-updater which i currently need to run is requiring of me a newer Portage). Actually it now looks like i can go ahead with installing Pax-utils and Portage, it seems happy with the version of sandbox that i have (wish me luck).

As for the laziness, it took me /years/ to get this Gentoo system running somewhat properly, and i've finally been /using/ it instead of /working on/ it. Lately an application which i hardly ever use failed on me, i can't figure out why, so i thought i'd upgrade to a newer version, which of course it wouldn't do graciously, and this has pulled me back into the upgrade hell. Good exercise, i admit, overdue too, but remember that i am building my computer in order to use it (for noble tasks, i might add. I even had the vision of doing that for friends and people in need, but after years of fighting i've had to give that up, and be happy that i've managed to deliver only /one/ computer and kept one for myself. Very frustrating.)

You might ask: why Gentoo, then? I was having a difficult time with binaries in other distros: packages in the Unix world come with so many options (small, medium, or large; with cream, or lowfat milk, or regular; vanilla or chocolate? white or whole wheat or rye bread? mayonnaise and mustard? etc.), that i couldn't find one that worked like i was hoping (unlike most americans, i do like anchovies and not so much the pickles). Every time i checked with a developper's web site, the instructions are to build from source. So i looked around and found Gentoo.

Thanks for your work, though. For the rest of us dummies.
Comment 23 SpanKY gentoo-dev 2009-04-18 21:18:13 UTC
*** Bug 266625 has been marked as a duplicate of this bug. ***
Comment 24 Raúl Porcel (RETIRED) gentoo-dev 2009-04-20 15:59:29 UTC
(In reply to comment #21)
> Raúl: that ia64 failure has been fixed in newer versions and technically, it's
> not a regression.  older sandboxes would fail the same way under ia64 (there
> just wasnt a test for it).  i.e. ignore it and stabilize anyways ;).
> 

Yeah, i saw there wasn't a test on the stable version.

ia64 stable then, thanks :)

Comment 25 Brent Baude (RETIRED) gentoo-dev 2009-04-26 19:32:02 UTC
ppc stable, closing