Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 265256 - xfce-base/{xfce4-panel,xfdesktop}-4.6.0 crash when dealing with strange unicode characters in file name
Summary: xfce-base/{xfce4-panel,xfdesktop}-4.6.0 crash when dealing with strange unico...
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: XFCE Team
URL: http://blog.oup.com/2009/03/science-f...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-07 07:18 UTC by Alexander Brüning
Modified: 2009-08-23 03:02 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Window decoration with line breaks (decoration.png,5.38 KB, image/png)
2009-04-07 07:20 UTC, Alexander Brüning
Details
strace of xfce4-panel crashing (strace.txt,506.49 KB, text/plain)
2009-04-07 07:22 UTC, Alexander Brüning
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Brüning 2009-04-07 07:18:25 UTC
Hi,

I just wanted to read the story linked above and the XFCE panel crashed. Turns out there are two unicode line seperator characters (<U+2028><U+2028>) in the pages title tag. I then saved the page to my desktop for further investigation and the desktop crashed too. XFWM seems unaffected and actually seems to display the line breaks (see attached screenshot). I ran xfce4-panel with strace and this is what it displayed multiple times before segfaulting:

read(3, "\1\1%\10\0\0\0\0\375\257\200\0\0\0\0\0\0\0\0\0\0\0\0\0\20\365\34\n\0\0\0\0"..., 4096) = 32
read(3, 0x8ce47ec, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{"+\0\1\0"..., 4}], 1)       = 4
select(4, [3], [], NULL, NULL)          = 1 (in [3])
read(3, "\1\2&\10\0\0\0\0B\0\340\1\0\0\0\0\1\0\0\0\0\0\0\0\20\365\34\n\0\0\0\0"..., 4096) = 32
read(3, 0x8ce47ec, 4096)                = -1 EAGAIN (Resource temporarily unavailable)
select(4, [3], [3], NULL, NULL)         = 1 (out [3])
writev(3, [{"(\0\4\0\33\0\340\0;\1\0\0\0\0\0\0"..., 16}], 1) = 16
select(4, [3], [], NULL, NULL)          = 1 (in [3])
read(3, "\1\1'\10\0\0\0\0\375\257\200\0\0\0\0\0\0\0\0\0\0\0\0\0\20\365\34\n\0\0\0\0"..., 4096) = 32
read(3, 0x8ce47ec, 4096)                = -1 EAGAIN (Resource temporarily unavailabl

Reproducible: Always

Steps to Reproduce:
Comment 1 Alexander Brüning 2009-04-07 07:20:53 UTC
Created attachment 187530 [details]
Window decoration with line breaks
Comment 2 Alexander Brüning 2009-04-07 07:22:50 UTC
Created attachment 187532 [details]
strace of xfce4-panel crashing
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-07 20:32:05 UTC
Please post your "emerge --info".
Comment 4 Alexander Brüning 2009-04-08 07:49:32 UTC
Portage 2.1.6.11 (default/linux/x86/2008.0/desktop, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.29 i686)
=================================================================
System uname: Linux-2.6.29-i686-Intel-R-_Core-TM-2_Duo_CPU_T7300_@_2.00GHz-with-glibc2.0
Timestamp of tree: Tue, 07 Apr 2009 15:00:01 +0000
app-shells/bash:     4.0_p10-r1
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.3-r4, 2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.7
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sunrise /usr/local/portage/layman/gentoo-de /usr/local/portage/layman/mozilla /usr/local/portage/layman/gnome /usr/local/portage/layman/wschlich-testing /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa ao autoipd avahi berkdb blender-game bluetooth bonjour branding bzip2 cairo cdda cddb cdio cdparanoia cdr cdrkit chardet cleartype cli cracklib crypt cups curl dbus dhcp dia dillo djbfft djvu dri dssi dv dvb dvd dvdr dvdread dvi emboss emf encode equalizer evo exif fam ffmpeg fftw firefox flac fltk fortran gdbm gdl ggi gif glib glibc-compat20 glitz gnome gpm gsf gstreamer gtk gtkhtml hal hbci howl-compat iconv id3tag ieee1394 imagemagick imap imlib inkjar ipod iptc ipv6 isdnlog ithreads java jpeg jpeg2k kdeenablefinal kdehiddenvisibility ladcca lame laptop lcms ldap libburn libcaca libnotify libsamplerate libsexy libssh2 live log4j lzma lzo mad matroska midi mikmod mjpeg mmx mmxext mng modplug moznopango mp2 mp3 mpeg mplayer mudflap musepack ncurses network nls nptl nptlonly ogg openal openexr opengl openmp pam pcmcia pcre pdf perl plotutils plugins png postscript ppds pppd python qt3 qt3support qt4 quicktime rar raw readline reflection rtsp rubberband samba scanner sdl session shout sid slp smp sndfile speex spell spl sqlite sse sse2 sse3 ssl ssse3 startup-notification stream svg sysfs t1lib tcpd tetex theora threads tiff timidity tk truetype unicode usb utempter v4l v4l2 vcd verse vidix vorbis vorbis-psy wavpack win32codecs wma wmf wxwindows x264 x86 xattr xcb xcomposite xine xinerama xml xorg xosd xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" DVB_CARDS="dibusb-usb1" ELIBC="glibc" INPUT_DEVICES="joystick keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" LIRC_DEVICES="*" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 5 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-21 04:53:01 UTC
wow, that is a fun one.

Please upgrade to 4.6.1 and if the problem still persists, it *really* needs to be taken upstream at http://bugzilla.xfce.org

thx.
Comment 6 Alexander Brüning 2009-04-21 18:54:08 UTC
4.6.1 didn't fix it for me.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-04-22 14:18:33 UTC
http://bugzilla.xfce.org/show_bug.cgi?id=5277
Comment 8 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-08-23 03:02:14 UTC
filed bug, please follow it there. Closing this bug report because there is nothing that I can do. http://bugzilla.xfce.org/show_bug.cgi?id=5277