Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264987 - >=dev-games/ggz-client-libs-0.0.14 stabilization request
Summary: >=dev-games/ggz-client-libs-0.0.14 stabilization request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High minor with 1 vote (vote)
Assignee: Gentoo Games
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 260063
  Show dependency tree
 
Reported: 2009-04-05 17:17 UTC by Riccardo Brasca
Modified: 2009-04-06 01:13 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Brasca 2009-04-05 17:17:26 UTC
After emerge --synch dev-games/ggz-client-libs is masked, no version available, but gnome-base/gnome-2.24.1 depends on it.

Reproducible: Always

Steps to Reproduce:
1. emerge --synch
2. emerge -ep gnome
3.

Actual Results:  
!!! All ebuilds that could satisfy ">=dev-games/ggz-client-libs-0.0.14" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-games/ggz-client-libs-0.0.14.1 (masked by: ~amd64 keyword)
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-04-05 20:17:53 UTC
I just ran cvs up and couldn't find anything about this in package.mask.
Comment 2 Riccardo Brasca 2009-04-05 20:30:56 UTC
(In reply to comment #1)
> I just ran cvs up and couldn't find anything about this in package.mask.
> 

I don't understand the answer. The package is not hard masked, so it is not in package.mask. It is enough to un unmask it in package.keywords, but without this workaround it prevents gnome to be installed.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-04-05 21:11:03 UTC
erm I misunderstood your problem it seems.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-04-05 21:11:28 UTC
reassigning to games.
Comment 5 Riccardo Brasca 2009-04-05 21:15:26 UTC
Also my fault, it is gnome-extra/gnome-games that depends directly on it, not gnome-base/gnome.
Comment 6 Mr. Bones. (RETIRED) gentoo-dev 2009-04-05 23:05:42 UTC
there's no bug here that I can see.
Comment 7 Gilles Dartiguelongue gentoo-dev 2009-04-05 23:11:27 UTC
Simple put, gnome-games depends on ggz-clients-libs. gnome-games is stable, ggz-client-libs is not, hence stablereq.
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-04-05 23:12:04 UTC
ah forgot to say that since ggz-client-libs is under games metadata, I thought you would like to say yay or nay for stabilization.
Comment 9 Mr. Bones. (RETIRED) gentoo-dev 2009-04-05 23:18:16 UTC
It is stable.
Comment 10 Mart Raudsepp gentoo-dev 2009-04-06 01:13:32 UTC
Problem was that armin76 accidentally made all arches ~arch while marking it ~arm.
loki_val fixed it by now