1. simplejson should not be installed if >=dev-lang/python-2.6 is installed. Currently it installes <dev-lang/python-2.6 but (judging on the ebuild) it will be build against default python (2.6 included). >=dev-lang/python-2.6 should be blocked
2. dev-python/pylons and dev-python/webhelpers should accept dev-lang/python-2.6 as alternative to dev-pyton/simplejson (possibly preferable).
While simplejson might be included in python-2.6 it has a different name then. Some software relies on being able to import simplejson, even if under python 2.6 it could just import json, so I think that no such restriction should be put in place. Some elog message might make sense but if we blocked python-2.6 users from having simplejson we'd get a lot of software not working.
Please file separate bugs for packages, whose the newest version unconditionally depends on dev-python/simplejson, but also supports using 'json' module. Please precisely check these packages.
Maybe this'll still be considered as cantfix, but here's some updates on this bug (since I'd be happy to rid my system of simplejson) :
* all rabbitmq-server versions in the portage tree (2.4 and 2.5) can work with either the external simplejson module or the internal json module from python >= 2.6. You can check in amqp_codegen.py that they did the necessary import-one-or-the-other dance.
* gentoo systems without python >= 2.6 installed should be exeedingly rare nowadays, making the installation of simplejson a waste of resources for most users.
* I believe the DEPEND could be fixed by depending on (python>=2.6 || simplejson), and seting the active python version to >= 2.6 during compilation if available.
I'm sure we wouldn't get any user complain if we removed the simplejson case altogether, but I assume you'll want to take the safe route here. I'm also assuming you can easily choose your python version during the compile process, but that's beyond my current ebuild skills, so I may be wrong ?