Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264847 - dev-python/simplejson should not be pulled if >=dev-lang/python-2.6 is installed
Summary: dev-python/simplejson should not be pulled if >=dev-lang/python-2.6 is installed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Python Gentoo Team
Depends on:
Reported: 2009-04-04 09:25 UTC by Maciej Piechotka
Modified: 2011-07-26 11:17 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2009-04-04 09:25:31 UTC
1. simplejson should not be installed if >=dev-lang/python-2.6 is installed. Currently it installes <dev-lang/python-2.6 but (judging on the ebuild) it will be build against default python (2.6 included). >=dev-lang/python-2.6 should be blocked
2. dev-python/pylons and dev-python/webhelpers should accept dev-lang/python-2.6 as alternative to dev-pyton/simplejson (possibly preferable).

Reproducible: Always
Comment 1 Jürgen Geuter 2009-04-21 11:28:22 UTC
While simplejson might be included in python-2.6 it has a different name then. Some software relies on being able to import simplejson, even if under python 2.6 it could just import json, so I think that no such restriction should be put in place. Some elog message might make sense but if we blocked python-2.6 users from having simplejson we'd get a lot of software not working.
Comment 2 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-09-10 03:09:39 UTC
Please file separate bugs for packages, whose the newest version unconditionally depends on dev-python/simplejson, but also supports using 'json' module. Please precisely check these packages.
Comment 3 Vincent de Phily 2011-07-26 11:17:08 UTC
Maybe this'll still be considered as cantfix, but here's some updates on this bug (since I'd be happy to rid my system of simplejson) :

* all rabbitmq-server versions in the portage tree (2.4 and 2.5) can work with either the external simplejson module or the internal json module from python >= 2.6. You can check in that they did the necessary import-one-or-the-other dance.
* gentoo systems without python >= 2.6 installed should be exeedingly rare nowadays, making the installation of simplejson a waste of resources for most users.
* I believe the DEPEND could be fixed by depending on (python>=2.6 || simplejson), and seting the active python version to >= 2.6 during compilation if available.

I'm sure we wouldn't get any user complain if we removed the simplejson case altogether, but I assume you'll want to take the safe route here. I'm also assuming you can easily choose your python version during the compile process, but that's beyond my current ebuild skills, so I may be wrong ?