Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264757 - sci-mathematics/octave-3.2.0 version bump request
Summary: sci-mathematics/octave-3.2.0 version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo Science Mathematics related packages
URL:
Whiteboard:
Keywords:
: 275108 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-03 12:12 UTC by Tiziano Müller
Modified: 2009-07-08 01:52 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
octave-3.0.3-to-3.0.5.diff (octave-3.0.3-to-3.0.5.diff,1.54 KB, patch)
2009-04-24 05:00 UTC, Tim Harder
Details | Diff
Ebuild updates from 3.0.3 to 3.2.0 (octave-3.0.3-to-3.2.0.diff,2.66 KB, patch)
2009-06-27 09:17 UTC, Tim Harder
Details | Diff
octave-3.2.0-no_helvetica.patch (octave-3.2.0-no_helvetica.patch,563 bytes, patch)
2009-06-27 09:21 UTC, Tim Harder
Details | Diff
octave-3.2.0-test-fix.patch (octave-3.2.0-test-fix.patch,2.06 KB, patch)
2009-06-27 09:21 UTC, Tim Harder
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tiziano Müller gentoo-dev 2009-04-03 12:12:50 UTC
Just stumbled over it...

April 2, 2009
    Version 3.0.4 has been released and is now available for ftp. Octave 3.0.4 is a bug-fixing release. Most bugs reported since the release of version 3.0.3 have been fixed. Please note that Octave 3.0 is significantly different from Octave 2.1.x, particularly with regard to graphics, path handling, and built-in variables. Please read the NEWS file.
Comment 1 Francisco J. Vazquez 2009-04-04 05:24:17 UTC
Renaming octave-3.0.3.ebuild and octave-3.0.3-test-fix.patch to 3.0.4 works ok for me. This version solves the bug with gcc-4.4, too.
Comment 2 Peter Gantner (a.k.a. nephros) 2009-04-09 14:17:58 UTC
(In reply to comment #1)
> This version solves the bug with gcc-4.4, too.
 
 Are you referring the compile error from Gentoo Bug #262892 ?
Comment 3 Peter Gantner (a.k.a. nephros) 2009-04-09 15:50:49 UTC
compiled & tested on x86.

Compilation went without errors, bugfix from Bug #262892 was NOT needed.

The resuling binary ran my existing octave programs without problems. (Which aren't very complex though.)
Comment 4 juantxorena@gmail.com 2009-04-09 20:11:38 UTC
octave-3.0.5 is out, it fixes a serious bug found in 3.0.4
Comment 5 Tim Harder gentoo-dev 2009-04-24 05:00:00 UTC
Created attachment 189286 [details, diff]
octave-3.0.3-to-3.0.5.diff

Ebuild updates from version 3.0.3 currently in the tree to version 3.0.5:
  * Use EAPI 2 phases
  * Remove unused flag-o-matic eclass
  * Minor reordering
  * Fix patch name
Comment 6 hirakendu 2009-05-29 08:09:15 UTC
bump please version :).
Comment 7 Michael Duelli 2009-06-12 12:34:45 UTC
Octave 3.2.0 has been released on 2009-06-06 and brings several major improvements. A corresponding octave-forge release has been done, too.
Comment 8 Sébastien Fabbro (RETIRED) gentoo-dev 2009-06-25 03:21:33 UTC
*** Bug 275108 has been marked as a duplicate of this bug. ***
Comment 9 Tim Harder gentoo-dev 2009-06-27 09:17:08 UTC
Created attachment 195863 [details, diff]
Ebuild updates from 3.0.3 to 3.2.0

Ebuild updates from octave-3.0.3 to octave-3.2.0
    * Use EAPI 2 phases -- src_prepare and src_configure
    * Remove unused flag-o-matic eclass
    * Minor reordering of LICENSE, KEYWORDS, and IUSE to standard places
    * Update patches -- plotyy patch not needed anymore
    * Reorder deps to be a bit more alphabetic
    * Add arpack dep to the sparse functionality
    * Add fltk dep and use flag for the new experimental plotting system
    * Remove ls-R sed stuff -- doesn't seem to be necessary anymore
Comment 10 Tim Harder gentoo-dev 2009-06-27 09:21:08 UTC
Created attachment 195864 [details, diff]
octave-3.2.0-no_helvetica.patch

Updated patch for octave-3.2.0
Comment 11 Tim Harder gentoo-dev 2009-06-27 09:21:43 UTC
Created attachment 195865 [details, diff]
octave-3.2.0-test-fix.patch

Another updated patch for octave-3.2.0
Comment 12 Tim Harder gentoo-dev 2009-07-03 07:44:12 UTC
I forgot to note that octave-3.2.0 now depends on the GraphicsMagick library for the new functions, imwrite and imread, for reading and writing images. However, it appears that there are no ebuilds for graphicsmagick currently in the official repo. An ebuild for the current stable release does exist in the sunrise repo so whenever a dev commits this it would be good to pull graphicsmagick into the main tree and make it a dependency for octave-3.2.0.
Comment 13 Markus Dittrich (RETIRED) gentoo-dev 2009-07-08 01:52:15 UTC
Hi dev-zero,

Thanks much for the great work. I've just committed an octave-3.2.0
ebuild.

A few things are still missing but it should be good enough for the
time being. The ebuild currently lacks:

- support for graphicsmagick (will look into getting it into the tree)
- support for arpack until the package is keyworded on all relevant
  arches
- need to look into fltk. Currently, the build system does not seem 
  to allow to disable fltk; it will be detected when present no matter
  what. I'll have a look at this as well.

Thanks,
Markus