Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264536 - update-modules: lm_sensors needs /etc/modprobe.d/lm_sensors
Summary: update-modules: lm_sensors needs /etc/modprobe.d/lm_sensors
Status: RESOLVED DUPLICATE of bug 214273
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-01 19:52 UTC by pat
Modified: 2009-04-01 23:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pat 2009-04-01 19:52:17 UTC
Please file a bug about /etc/modules.d/lm_sensors: it needs an /etc/modprobe.d/lm_sensors

Reproducible: Always

Steps to Reproduce:
1. update kernel or remove /etc/modules.conf /etc/modprobe.conf
2. run update-modules


Actual Results:  
 * Updating modules.conf ...                                              [ ok ]
 * Updating modules.dep ...                                               [ ok ]
 * Please file a bug about /etc/modules.d/lm_sensors: it needs an /etc/modprobe.d/lm_sensors
 * Updating modprobe.conf by hand ...                                     [ ok ]


Expected Results:  
Don't print an error message, and make lm_sensors work

#### emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-tuxonice-r8 x86_64)
=================================================================
System uname: Linux-2.6.28-tuxonice-r8-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_5200+-with-glibc2.2.5
Timestamp of tree: Sun, 29 Mar 2009 09:15:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.imj.fr/pub/gentoo/ ftp://mirror.netcologne.de/gentoo/ http://mirror.ovh.net/gentoo-distfiles/ http://mirror.jamit.de/gentoo/ http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 apache2 bash-completion berkdb bzip2 cli cracklib crypt cups dbus dri fortran gdbm glitz gpm gtk hal iconv ipv6 isdnlog jpeg lm_sensors midi mmx mmxext mudflap multilib ncurses nls nptl nptlonly opengl openmp pam pcre php png pppd python readline reflection sdl session sharedmem smp spl sse sse2 ssl svg sysfs tcpd threads truetype unicode xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS



#### package.keywords
=sys-kernel/tuxonice-sources-2.6.28-r8
=sys-apps/tuxonice-userui-0.7.3
=sys-power/hibernate-script-1.99-r1
=sys-fs/e2fsprogs-1.41.4
=sys-libs/e2fsprogs-libs-1.41.4


#### other
installed: sys-apps/lm_sensors-2.10.7 (-sensord)
previous kernel was 2.6.25-r7, everything worked fine there
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-04-01 23:25:06 UTC
lm_sensors package no longer installs anything into /etc/modules.d

*** This bug has been marked as a duplicate of bug 214273 ***