Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 264199 - =gnome-base/gnome-settings-daemon-2.24.1-r1 crashes at start up (xorg root cause)
Summary: =gnome-base/gnome-settings-daemon-2.24.1-r1 crashes at start up (xorg root ca...
Status: RESOLVED DUPLICATE of bug 256016
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
: 264207 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-29 17:14 UTC by Alexander Goomenyuk
Modified: 2009-03-31 19:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info output (emerge.info,3.75 KB, text/plain)
2009-03-29 17:15 UTC, Alexander Goomenyuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Goomenyuk 2009-03-29 17:14:18 UTC
g-s-d fails while initializing keyboard.

Reproducible: Always

Steps to Reproduce:
1. start gnome-settings-daemon
$ /usr/libexec/gnome-settings-daemon --debug --no-daemon

2. Daemon failed with backtrace indicating keyboard init problem.
$ gnome-settings-daemon: xcb_xlib.c:73: xcb_xlib_lock: Assertion
`!c->xlib.lock' failed.

3. xcb lock workaround doesn't really helps
$ LIBXCB_ALLOW_SLOPPY_LOCK=1 /usr/libexec/gnome-settings-daemon --debug
--no-daemon
gives high CPU load. But daemon started fine and settings restored correctly.

Actual Results:  
g-s-d not started.

The problem solved by updating xorg from 1.3.0.0-r6 to 1.5.3-r5;
Here is the list of ports emerged as dependencies:
gnome-base:gvfs-1.0.3-r1:20090329-133622.log
gnome-base:gvfs-1.0.3-r1:20090329-133631.log
media-gfx:imagemagick-6.4.8.3:20090329-133444.log
media-libs:freetype-2.3.9:20090329-130405.log
media-libs:libgphoto2-2.4.3:20090329-132809.log
media-libs:mesa-7.4_rc1:20090329-131008.log
net-p2p:amule-2.2.3:20090329-141513.log
sys-apps:hal-0.5.12_rc1:20090329-131134.log
sys-devel:binutils-2.19.1-r1:20090329-125621.log
sys-devel:libtool-2.2.6a:20090329-125717.log
x11-apps:xinit-1.0.8-r4:20090329-131153.log
x11-base:xorg-server-1.5.3-r5:20090329-131838.log
x11-drivers:xf86-input-evdev-2.2.0-r1:20090329-131857.log
x11-drivers:xf86-input-keyboard-1.3.2:20090329-131915.log
x11-drivers:xf86-input-mouse-1.4.0:20090329-131319.log
x11-drivers:xf86-video-ati-6.12.1:20090329-131259.log
x11-drivers:xf86-video-v4l-0.1.1:20090329-141615.log
x11-drivers:xf86-video-vesa-2.2.0:20090329-141912.log
x11-libs:libX11-1.1.5:20090329-130302.log
x11-libs:libXau-1.0.4:20090329-125955.log
x11-libs:libXaw-1.0.5:20090329-130754.log
x11-libs:libXext-1.0.4:20090329-130327.log
x11-libs:libXfont-1.3.4:20090329-130636.log
x11-libs:libXi-1.2.1:20090329-130542.log
x11-libs:libXmu-1.0.4:20090329-130516.log
x11-libs:libXrender-0.9.4:20090329-130426.log
x11-libs:libXxf86vm-1.0.2:20090329-130653.log
x11-libs:libdrm-2.4.5:20090329-125831.log
x11-libs:libpciaccess-0.10.5:20090329-131336.log
x11-libs:libxkbfile-1.0.5:20090329-130448.log
x11-libs:pixman-0.14.0-r1:20090329-125927.log

I suppose most essential package is xf86-input-keyboard. I guess the should be dependency of g-s-d from driver. It should be noted that it works fine with libxklavier-3.8;




Stack trace:
** (gnome-settings-daemon:27359): DEBUG: GsdKeyboardPlugin initializing
** (gnome-settings-daemon:27359): DEBUG: Activating keyboard plugin
** (gnome-settings-daemon:27359): DEBUG: Starting keyboard manager

Gdk-ERROR **: The program 'gnome-settings-daemon' received an X Window System
error.
This probably reflects a bug in the program.
The error was 'BadClass, invalid event class'.
  (Details: serial 169 error_code 184 request_code 148 minor_code 6)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
aborting...
Locking assertion failure.  Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb75ab857]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_lock+0x2e) [0xb75ab90e]
#2 /usr/lib/libX11.so.6 [0xb75ef9f6]
#3 /usr/lib/libX11.so.6(XUngrabPointer+0x25) [0xb75e64a5]
#4 /usr/lib/libgdk-x11-2.0.so.0(gdk_display_pointer_ungrab+0x84) [0xb7ac2384]
#5 /usr/lib/libgdk-x11-2.0.so.0(gdk_pointer_ungrab+0x1a) [0xb7a9d9ca]
#6 /usr/lib/gtk-2.0/modules/libgnomebreakpad.so [0xb7ee470f]
#7 [0xb7ef0400]
#8 /usr/lib/libglib-2.0.so.0(g_log+0x29) [0xb6e4def9]
#9 /usr/lib/libgdk-x11-2.0.so.0 [0xb7adcd24]
#10 /usr/lib/libxklavier.so.12(xkl_process_error+0xe4) [0xb5f76124]
#11 /usr/lib/libX11.so.6(_XError+0xd2) [0xb75e8dd2]
#12 /usr/lib/libX11.so.6 [0xb75f0346]
#13 /usr/lib/libX11.so.6(_XReply+0x15c) [0xb75f06ec]
#14 /usr/lib/libX11.so.6(_XGetWindowAttributes+0xc8) [0xb75cff98]
#15 /usr/lib/libX11.so.6(XGetWindowAttributes+0x42) [0xb75d00e2]
#16 /usr/lib/libxklavier.so.12(xkl_engine_select_input_merging+0x51)
[0xb5f74f51]
#17 /usr/lib/libxklavier.so.12(xkl_engine_resume_listen+0x81) [0xb5f75001]
#18 /usr/lib/libxklavier.so.12(xkl_engine_start_listen+0x36) [0xb5f756c6]
#19
/usr/lib/gnome-settings-daemon-2.0/libkeyboard.so(gsd_keyboard_xkb_init+0x2f6)
[0xb5facf06]
gnome-settings-daemon: xcb_xlib.c:73: xcb_xlib_lock: Assertion `!c->xlib.lock'
failed.
[1238279995,000,xklavier.c:xkl_engine_start_listen/]    The backend does not
require manual layout management - but it is provided by the
applicationMultiple segmentation faults occurred; can't display error dialog
Comment 1 Alexander Goomenyuk 2009-03-29 17:15:44 UTC
Created attachment 186663 [details]
emerge --info output
Comment 2 David Abbott gentoo-dev 2009-03-29 19:19:24 UTC
dup 256016
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-29 19:55:10 UTC
*** Bug 264207 has been marked as a duplicate of this bug. ***
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-03-29 19:55:37 UTC
please check you are not hitting bug #256016
Comment 5 Alexander Goomenyuk 2009-03-30 19:38:57 UTC
Downgrade libxklavier from 3.8 to 3.6 fixed the problem as expected. But for me it looks as incompatibility issue of xorg with libklavier, which may be fixed by adding dependency to ebuild.
Comment 6 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-31 19:41:27 UTC

*** This bug has been marked as a duplicate of bug 256016 ***