Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263864 - dev-util/monodevelop-1.9.3 should have the dev-dotnet/mono-addins dependencies reversed
Summary: dev-util/monodevelop-1.9.3 should have the dev-dotnet/mono-addins dependencie...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-26 14:08 UTC by Maciej Piechotka
Modified: 2009-03-26 22:52 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Piechotka 2009-03-26 14:08:24 UTC
dev-util/monodevelop-1.9.3 should have the dev-dotnet/mono-addins dependencies reversed. Currently it is:
        ||      (
                ~dev-dotnet/mono-addins-0.3.1
                >=dev-dotnet/mono-addins-0.4[gtk]
        )

and some packet managers (paludis) choose the dev-dotnet/mono-addins-0.3.1.

Reproducible: Always
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-26 22:52:19 UTC
+  26 Mar 2009; Peter Alfredsen <loki_val@gentoo.org>
+  monodevelop-1.9.1.ebuild, monodevelop-1.9.2.ebuild,
+  monodevelop-1.9.3.ebuild:
+  Fix order of mono-addins in || ( a b ) expression to prefer the newest
+  version. Bug 263864. Thanks to uzytkownik <uzytkownik2@gmail.com> for
+  reporting.
+