Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263564 - media-tv/mythtv-0.21_p19961-r1 will not jump ahead on mythtv recorded ATSC AC3 Video
Summary: media-tv/mythtv-0.21_p19961-r1 will not jump ahead on mythtv recorded ATSC AC...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Television related Applications in Gentoo's Portage
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-24 06:23 UTC by John Klug
Modified: 2009-11-16 05:35 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Klug 2009-03-24 06:23:01 UTC
I updated my system, and now mythtv will not jump ahead or backwards properly.

The same recording plays fine in XINE, and I can jump ahead without freezing in XINE.

The current time display goes to the end time when I jump ahead in mythtv, but the actual position in the recording does to the beginning the first time.  If I try to go backwards, it jumps out of the recording and goes back to the menu.

I have:
media-tv/mythtv-0.21_p19961-r1

Here is some output while trying to jump ahead:
400 New DB connection, total: 3
2009-03-24 00:36:27.401 Using realtime priority.
2009-03-24 00:36:27.401 Connected to database 'mythconverg' at host: localhost
2009-03-24 00:36:27.509 OpenGLVideoSync()
2009-03-24 00:36:27.537 Video timing method: SGI OpenGL
2009-03-24 00:36:35.119 [mpeg2video @ 0x7f30e2f9dcf0]current_picture not initialized
2009-03-24 00:36:35.119 AFD Error: Unknown decoding error
2009-03-24 00:36:35.120 [mpeg2video @ 0x7f30e2f9dcf0]warning: first frame is no keyframe
2009-03-24 00:36:42.506 [mpeg2video @ 0x7f30e2f9dcf0]releasing zombie picture
2009-03-24 00:36:50.077 TV: Attempting to change from WatchingPreRecorded to None
2009-03-24 00:36:50.122 ~OpenGLVideoSync() -- begin
2009-03-24 00:36:50.122 ~OpenGLVideoSync() -- middle
2009-03-24 00:36:50.123 ~OpenGLVideoSync() -- end
2009-03-24 00:36:50.687 TV: Changing from WatchingPreRecorded to None
2009-03-24 00:36:50.870 DPMS Reactivated.
2009-03-24 00:36:51.996 AFD: Opened codec 0x9ff200, id(MPEG2VIDEO) type(Video)
2009-03-24 00:36:51.996 AFD: codec AC3 has 6 channels
2009-03-24 00:36:51.997 AFD: Opened codec 0x158d910, id(AC3) type

Here are ffmpeg levels:
[I--] [  ] media-plugins/gst-plugins-ffmpeg-0.10.5 (0.10)
[I--] [ ~] media-video/ffmpeg-0.4.9_p20090201-r1 (0)


Reproducible: Always

Steps to Reproduce:
1.Record ATSC-MPEG/AC3 TV
2.Try to jump ahead while playing back a recording
3.

Actual Results:  
Position in recording moves to start of movie.  Current time is set to end time of movie.  Subsequent jumps ahead do nothing.  Jumps backwards terminates playback.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 21:42:32 UTC
Please post your "emerge --info".
Comment 2 John Klug 2009-03-25 02:01:54 UTC
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_6000+-with-glibc2.2.5
Timestamp of tree: Sat, 21 Mar 2009 02:00:03 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /home/mythtv/ /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://prometheus.cs.wmich.edu/gentoo ftp://mirror.mcs.anl.gov/pub/gentoo/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/ "
LANG="en_US"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/armagetron"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac acl acpi alsa amd64 audiofile automount autostart avahi bash-completion berkdb bidi bzip2 cairo caps cdda cdio cdr cli cracklib crciprec crypt cups dbus devinput divx dri dts dvb dvd dvdnav dvdr dvdread encode expat ffmpeg fftw firefox flac fluidsynth fortran ftp gdbm gif gnome gnome-print gnutls gpm gstreamer gtk guile hal httpd iconv ipv6 isc isdnlog java jpeg kde lame lcd libsamplerate lirc live mad matroska mdnsresponder-compat midi mjpeg mmx moviepack moviesounds mp3 mpeg mplayer mudflap multilib mysql na_dd na_icons ncurses networking nls nptl nptlonly nsplugin ogg opengl openmp pam pango pcre pdf perl png postscript pppd pulseaudio python qmail-spp qt3 qt4 readline realmedia reflection regex samba sdl session sound soundex sounds soundtouch spell spl sse ssl stream svg sysfs tcpd theora threads tiff transcode truetype tv_check tv_combiner tv_pick_cgi twolame unicode vcd videos vim-syntax vlm vnc vorbis vorbis-psy wav wavpack winbind wma wmp wxwindows xcb xcomposite xinerama xiph xml xorg xsettings xulrunner xv xvid xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="imon" LIRC_DEVICES="imon_pad2keys" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================
media-tv/mythtv-0.21_p19961-r1 was built with the following:
CFLAGS=""
CXXFLAGS=""

>>> Attempting to run pkg_info() for 'media-tv/mythtv-0.21_p19961-r1'
Please include all output in bug reports.
MythTV Version   : 19961
MythTV Branch    : branches/release-0-21-fixes
Library API      : 0.21.20080304-1
Network Protocol : 40
Options compiled in:
 linux profile using_oss using_alsa using_backend using_dbox2 using_dvb using_frontend using_hdhomerun using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_opengl_vsync using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmcw using_glx_proc_addr_arb using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads using_live
Comment 3 John Klug 2009-05-06 06:03:46 UTC
The problem appears to be ffmpeg.


This ffmpeg worked for me:
media-video/ffmpeg-0.4.9_p20090201

This ffmpeg does not:
media-video/ffmpeg-0.5-r1
Comment 4 Doug Goldstein (RETIRED) gentoo-dev 2009-11-15 00:36:12 UTC
Please test with a newer MythTV version. There have been updates in this code path.
Comment 5 John Klug 2009-11-16 05:35:12 UTC
I can play MPEG2 just fine now.  I still can't skip ahead in an Xvid-MPEG4 ogm file (but it will play as long as I don't try to skip).

xine can skip just fine with the following file that fails in mythtv (mythfrontend):

$ mplayer -vo null -ao null -frames 0 -identify soldworld.ogm
MPlayer SVN-r29463-4.3.4 (C) 2000-2009 MPlayer Team
mplayer: could not open config files /root/.lircrc and /etc/lirc/lircrc
mplayer: No such file or directory
Failed to read LIRC config file ~/.lircrc.

Playing soldworld.ogm.
ID_VIDEO_ID=0
[Ogg] stream 0: video (FOURCC XVID), -vid 0
ID_AUDIO_ID=0
[Ogg] stream 1: audio (format 0x2000), -aid 0
Ogg file format detected.
VIDEO:  [XVID]  1280x720  24bpp  59.940 fps    0.0 kbps ( 0.0 kbyte/s)
ID_FILENAME=soldworld.ogm
ID_DEMUXER=ogg
ID_VIDEO_FORMAT=XVID
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=59.940
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=8192
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=6
ID_LENGTH=2548.76
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
==========================================================================
ID_VIDEO_CODEC=ffodivx
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
ID_AUDIO_BITRATE=384000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [null] 48000Hz 2ch s16le (2 bytes per sample)
ID_AUDIO_CODEC=a52
Starting playback...


Exiting... (End of file)
ID_EXIT=EOF