Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263552 - kde-base/kdeplasma-addons-4.2.1-r1 fails to compile with < dev-util/cmake-2.6.3
Summary: kde-base/kdeplasma-addons-4.2.1-r1 fails to compile with < dev-util/cmake-2.6.3
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-23 22:11 UTC by Christoph Lange
Modified: 2009-07-05 16:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Lange 2009-03-23 22:11:09 UTC
cmake-2.6.2-r1 was installed; I wanted to install kdeplasma-addons-4.2.1-r1 (which did not require a newer cmake)

Extract from paludis output:

...
>>> Starting src_configure
>>> Working in BUILD_DIR: "/var/tmp/paludis/kde-base-kdeplasma-addons-4.2.1-r1/work/kdeplasma-addons_build"
loading initial cache file /var/tmp/paludis/kde-base-kdeplasma-addons-4.2.1-r1/temp//gentoo_common_config.cmake
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Phonon Version: 4.3.0
-- Found Phonon: /usr/lib64/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/4.2/include
-- Found KDE 4.2 library dir: /usr/kde/4.2/lib64
-- Found the KDE4 kconfig_compiler preprocessor: /usr/kde/4.2/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
  Could NOT find KDE4Workspace (missing: KDE4Workspace_CONFIG)
Call Stack (most recent call first):
  /usr/kde/4.2/share/apps/cmake/modules/FindKDE4Workspace.cmake:70 (find_package_handle_standard_args)
  CMakeLists.txt:9 (find_package)


-- Configuring incomplete, errors occurred!

!!! ERROR in kde-base/kdeplasma-addons-4.2.1-r1:
!!! In cmake-utils_src_configure at line 1222
!!! cmake failed

!!! Call stack:
!!!    * cmake-utils_src_configure (/var/tmp/paludis/kde-base-kdeplasma-addons-4.2.1-r1/temp/loadsaveenv:1222)
!!!    * kde4-base_src_configure (/var/tmp/paludis/kde-base-kdeplasma-addons-4.2.1-r1/temp/loadsaveenv:3491)
!!!    * src_configure (/var/tmp/paludis/kde-base-kdeplasma-addons-4.2.1-r1/temp/loadsaveenv:4446)
!!!    * ebuild_f_configure (/usr/libexec/paludis/2/src_configure.bash:52)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:482)
!!!    * main (/usr/libexec/paludis/ebuild.bash:498)

diefunc: making ebuild PID 24105 exit with error

Solved the problem by installing cmake-2.6.3 (cf. http://www.mail-archive.com/kde-buildsystem@kde.org/msg03986.html)

Reproducible: Always

Steps to Reproduce:
1. have cmake-2.6.2 installed
2. try to compile kdeplasma-addons-4.2.1-r1

Actual Results:  
failure to compile

Expected Results:  
should have compiled (or kdeplasma-addons should have had a dependency on >= cmake-2.6.3).
Comment 1 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2009-05-20 14:38:14 UTC
can't reproduce with 4.2.3 and cmake-2.6.2-r1 please double check
Comment 2 Maciej Mrozowski gentoo-dev 2009-05-20 14:39:28 UTC
This error is most certainly caused by the fact, that KDE workspace libs and kdeplasma-addons have been built with *different* cmake versions - workspace libs presumably with >=2.6.3 (placing exports in <libdir>/cmake/<export>) and kdeplasma-addons with 2.6.2 (placing exports and looking for them in <libdir>/<export>/cmake/).
Comment 3 Maciej Mrozowski gentoo-dev 2009-07-05 16:41:03 UTC
so as a 'solution' - reemerge libkworkspace and kdeplasma-addons using the same cmake