Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263525 - x11-libs/gtk+-2.14.7-r2 causes firefox and thunderbird to crash
Summary: x11-libs/gtk+-2.14.7-r2 causes firefox and thunderbird to crash
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Mozilla Gentoo Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-23 18:20 UTC by Bernd Schmidt
Modified: 2010-03-22 01:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Schmidt 2009-03-23 18:20:00 UTC
After I installed gtk+-2.14.7-r2, thunderbird and firefox always crash when they try to open a file selector (e.g. attaching something to a mail, or using "Save as" on an image on a web page.

I've now downgraded to gtk+-2.12, and the crash is gone in thunderbird (haven't restarted firefox yet).


Reproducible: Always

Steps to Reproduce:
1. Open a web page with an image file
2. Right click, choose "Save Image as..."
3. Crash.




I'm running an xfce4 desktop with the xfce-winter theme selected.

beaker ~ # emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.25.19-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.25.19-gentoo-r6-i686-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-glibc2.0
Timestamp of tree: Mon, 23 Mar 2009 12:25:01 +0000
distcc 3.0 i686-pc-linux-gnu [disabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.2-r1
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.17-r1, 2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -fomit-frame-pointer -mfpmath=sse -pipe -mtune=core2 -march=prescott"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/4.2/env /usr/kde/4.2/share/config /usr/kde/4.2/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -fomit-frame-pointer -mfpmath=sse -pipe -mtune=core2 -march=prescott"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/Spring /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acpi alsa asf audacious bash-completion berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus de_tvtoday doc dri dts dvd dvdr dvdread eds emboss encode evo exif fam ffmpeg firefox flac gcj gdbm gif gpm gtk hal iconv ipv6 isdnlog ivtv joystick jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kdeprefix kpathsea kqemu lcms libnotify lm_sensors loop-aes mad midi mikmod mmx mozilla mp3 mpeg mudflap mysql ncurses nptl nptlonly nsplugin nvidia ogg openexr opengl openmp pcre pdf perl png povray ppds pppd python qt qt3 qt3support qt4 quicktime readline reflection sdl session sid spl sse ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb v4l2 vorbis win32codecs x86 xine xml xorg xscreensaver xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci hda-intel intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev glint i810 intel mach64 mga neomagic nv r128 radeon savage sis tdfx trident vesa vga via vmware voodoo nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Some packages that may be relevant.  This is after masking gtk-2.14 in package.mask.

beaker ~ # emerge -pv mozilla-firefox gtk+ glib  gtk-engines gtk-engines-xfce gtk-theme-switch 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/glib-2.18.4-r1  USE="doc fam -debug -hardened (-selinux) -xattr" 0 kB
[ebuild   R   ] x11-libs/gtk+-2.12.11  USE="X cups doc jpeg tiff -debug -vim-syntax -xinerama" 0 kB
[ebuild   R   ] www-client/mozilla-firefox-3.0.7  USE="dbus java startup-notification xulrunner -bindist -custom-optimization -gnome -iceweasel -mozdevelop -restrict-javascript" LINGUAS="-af -ar -be -bg -bn -bn_IN -ca -cs -cy -da -de -el -en -en_GB -en_US -eo -es -es_AR -es_ES -et -eu -fi -fr -fy -fy_NL -ga -ga_IE -gl -gu -gu_IN -he -hi -hi_IN -hu -id -is -it -ja -ka -kn -ko -ku -lt -lv -mk -mn -mr -nb -nb_NO -nl -nn -nn_NO -oc -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -si -sk -sl -sq -sr -sv -sv_SE -te -th -tr -uk -zh -zh_CN -zh_TW" 19 kB
[ebuild   R   ] x11-themes/gtk-engines-2.16.1  USE="-accessibility -debug" 0 kB
[ebuild   R   ] x11-themes/gtk-engines-xfce-2.4.3  0 kB
[ebuild   R   ] x11-themes/gtk-theme-switch-2.0.0_rc2-r2  0 kB
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-23 22:07:50 UTC
Have you tried to solve this by recompiling firefox/thunderbird after the gtk+ upgrade?
Comment 2 Bernd Schmidt 2009-03-23 22:38:39 UTC
I'm pretty sure thunderbird at least was recompiled since the gtk upgrade.  If you insist I can try again.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-23 23:21:40 UTC
sounds like bug #239992. Could you confirm ?
Comment 4 Bernd Schmidt 2009-03-23 23:39:04 UTC
I have librsvg-2.22.3, but as far as I can tell the crashes do not appear to be related to it.  The downgrade of gtk+, without changing librsvg, fixed the issue for me.
Comment 5 Bernd Schmidt 2009-03-26 12:36:28 UTC
I've now downgraded librsvg and a number of other gnome packages, and updated gtk+ to 2.14 again.  With this configuration, I'm also unable to reproduce the crashes.  Here's a current list of packages (good configuration, no crashes):

beaker ~ # emerge -pv gtk+ librsvg libgnomeui gail libgsf

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/gtk+-2.14.7-r2  USE="X cups doc jpeg jpeg2k tiff -debug -vim-syntax -xinerama" 0 kB
[ebuild   R   ] gnome-extra/libgsf-1.14.10  USE="bzip2 doc python -debug -gnome" 0 kB
[ebuild   R   ] gnome-base/librsvg-2.22.2  USE="doc zlib -debug" 0 kB
[ebuild   R   ] gnome-base/libgnomeui-2.22.1  USE="doc jpeg -debug" 0 kB
[ebuild   R   ] gnome-base/gail-1000  0 kB

Total: 5 packages (5 reinstalls), Size of downloads: 0 kB
Comment 6 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-02 03:35:10 UTC
Is this still relevant?
Comment 7 Jory A. Pratt gentoo-dev 2010-03-22 01:23:25 UTC
No response in almost a year closing.