Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263496 - sys-fs/lvm2-2.02.36: init-script fails to run complaining about wrong baselayout version
Summary: sys-fs/lvm2-2.02.36: init-script fails to run complaining about wrong baselay...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-23 14:34 UTC by Vladimir
Modified: 2009-05-10 21:51 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir 2009-03-23 14:34:30 UTC
Afer world update on reboot i've got this error:

 * The lvm init-script is written for baselayout-2!
 * ERROR: lvm failed to start

LVM volumes were not mounted. Error occures due to the check for /etc/init.d/sysfs file, which is not present. I'm running baselayout-2.0.0 and openrc (see emerge --info). Just commenting the check makes it work fine. Luckily, i did not boot from LVM.


Reproducible: Always

Steps to Reproduce:
1.run /etc/init.d/lvm
2.
3.

Actual Results:  
 * The lvm init-script is written for baselayout-2!
 * ERROR: lvm failed to start

Expected Results:  
do required stuff for lvm

 emerge --info
Portage 2.1.6.7 (default/linux/x86/2008.0/developer, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-Intel-R-_Pentium-R-_4_CPU_3.20GHz-with-glibc2.0
Timestamp of tree: Mon, 23 Mar 2009 13:15:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.6.3
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect cvs digest distlocks fixpackages multilib-strict parallel-fetch protect-owned sandbox sfperms sign splitdebug strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="ru_RU.UTF-8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="ru"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aalib acl acpi alsa apache2 bash-completion berkdb bzip2 cairo cdr chroot cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fontconfig fortran gdbm gif gnome gstreamer gtk gtk2 hal iconv isdnlog jpeg kde kdeenablefinal kerberos ldap libnotify lirc mad mailwrapper midi mikmod mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg openal opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba scanner sdl session slang snmp spell spl ssl startup-notification svg sysfs tcpd tetex tiff truetype unicode usb userlocales vorbis win32codecs x86 xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru" USERLAND="GNU" VIDEO_CARDS="vesa nv nvidia vga vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-23 14:55:13 UTC
What is your version of lvm2?
Comment 2 Vladimir 2009-03-23 18:50:11 UTC
(In reply to comment #1)
> What is your version of lvm2?
> 

[ebuild   R   ] sys-fs/lvm2-2.02.36  USE="lvm1 readline static -clvm -cman (-selinux)" 0 kB
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-23 21:26:29 UTC
The scripts in /etc/init.d/ are not intended to be used with baselayout-1.
baselayout-1 uses the scripts from /lib/rcscripts/addons/

*** This bug has been marked as a duplicate of bug 260276 ***
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-23 21:56:09 UTC
Sorry, my mistake. I really should take a nap. Vladimir, please upgrade sys-apps/openrc to version 0.4.x or else the init-script fails.
Comment 5 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-24 23:13:05 UTC
Please test if the init-script works with sys-apps/openrc-0.4.3-r1 and reopen this bug if it still fails.
Comment 6 Vladimir 2009-04-06 17:58:02 UTC
(In reply to comment #5)
> Please test if the init-script works with sys-apps/openrc-0.4.3-r1 and reopen
> this bug if it still fails.
> 

openrc-0.4.3-r1 is installed, everything works fine. Thanks!
Comment 7 Luke-Jr 2009-05-10 21:47:27 UTC
I just had this same problem. Is OpenRC 0.2 no longer supported?
Comment 8 Luke-Jr 2009-05-10 21:47:44 UTC
Either way, please add a version dep to lvm
Comment 9 Luke-Jr 2009-05-10 21:51:24 UTC
Ew, OpenRC 0.4 requires keywording ~arch sysvinit, udev, and cryptsetup. :<