Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263352 - virtual/init-0 Digest verification failed
Summary: virtual/init-0 Digest verification failed
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: PPC Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-22 08:00 UTC by Boney McCracker
Modified: 2009-03-22 21:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Boney McCracker 2009-03-22 08:00:37 UTC
Interesting digest verification error.  Note the similarity between the two strings (RMD160 verification):
!!! Got: f616e26e08d873923240dea512cf02e1ae2f1dd1
!!! Expected: f61>e26e08d873923240dea512cf02e1ae2f1dd1

System has been stable for two years.

Reproducible: Always

Steps to Reproduce:
1. Was trying to emerge -e world

Actual Results:  
~ # emerge -1 init
Calculating dependencies... done!

>>> Verifying ebuild manifests

!!! Digest verification failed:
!!! /usr/portage/virtual/init/init-0.ebuild
!!! Reason: Failed on RMD160 verification
!!! Got: f616e26e08d873923240dea512cf02e1ae2f1dd1
!!! Expected: f61>e26e08d873923240dea512cf02e1ae2f1dd1

Expected Results:  
No digest verification failure.

~ # emerge --info
Portage 2.1.6.7 (default/linux/powerpc/ppc32/2008.0, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 ppc)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-ppc-7400,_altivec_supported-with-glibc2.0
Timestamp of tree: Sat, 21 Mar 2009 07:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.6.3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="ppc"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-O2 -mtune=7400 -mcpu=7400 -maltivec -mabi=altivec -pipe"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -mtune=7400 -mcpu=7400 -maltivec -mabi=altivec -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.osuosl.org/               ftp://ftp.gtlib.gatech.edu/pub/gentoo                http://open-systems.ufl.edu/mirrors/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1,--hash-style=gnu"
LINGUAS="en_US en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X alsa altivec berkdb bzip2 cairo caps cli consolekit cracklib crypt dbus dri ffmpeg fortran gdbm gif gpm gtk hal iconv java jpeg midi mp3 mudflap ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcre perl png ppc python readline reflection reiserfs samba session spl ssl sysfs theora threads tiff truetype unicode userlocales vorbis xattr xcb xorg xulrunner zlib" ALSA_CARDS="powermac" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="r128"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-22 15:53:42 UTC
RMD160 f616e26e08d873923240dea512cf02e1ae2f1dd1

This is the correct RMD160 checksum for this package. Look at the checksum portage expects from you. The difference is just one character (">" instead of "6").
Please resync your protage tree and try to emerge this package again. 
In case you still encounter this error, please do a thorough check of your hard drive and if your hard drive turns out to be okay, reopen this bug and tell us from which mirror your synced your portage-tree.
Comment 2 Boney McCracker 2009-03-22 21:49:17 UTC
It was a file corruption problem.

Thank you Lars.