Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 263175 - x11-libs/libxklavier-3.8 causes GNOME login failure due to multiple crashes
Summary: x11-libs/libxklavier-3.8 causes GNOME login failure due to multiple crashes
Status: RESOLVED DUPLICATE of bug 256016
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-20 21:45 UTC by Rumi Szabolcs
Modified: 2009-03-21 00:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rumi Szabolcs 2009-03-20 21:45:50 UTC
I've upgraded several GNOME packages at once and in the end I was not
able to log in due to crashes in gnome-session and gnome-settings-daemon.

----------- .xsession-errors ---------------------
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/seahorse-agent --execute gnome-session
SESSION_MANAGER=local/raketa:/tmp/.ICE-unix/5961
1237279209.771199 Session manager: disconnected...
1237279211.392308 Session manager: disconnected...
1237279211.833197 Session manager: disconnected...
Window manager warning: Failed to read saved session file /home/rumi/.config/metacity/sessions/default0.ms: Failed to open file '/home/rumi/.config/metacity/sessions/default0.ms': No such file or dir
e
1237279213.182303 Session manager: disconnected...
**
ERROR:dbus-gproxy.c:661:unassociate_proxies: assertion failed: (priv->associated)
Multiple segmentation faults occurred; can't display error dialog
** (gnome-panel:6083): WARNING **: Unable to obtain AppletShell interface from control
** (gnome-panel:6083): WARNING **: panel-applet-frame.c:1413: failed to load applet OAFIID:GNOME_KeyboardApplet (cannot get applet shell)
--------------------------------------------------


Reproducible: Always




I've tracked this down to libxklavier and made the observation that
echo ">=x11-libs/libxklavier-3.8" >> /etc/portage/package.mask
and remerging libxklavier fixes it.
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-03-21 00:36:56 UTC

*** This bug has been marked as a duplicate of bug 256016 ***