Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262734 - Gnome 2.24 appears to be broken
Summary: Gnome 2.24 appears to be broken
Status: RESOLVED DUPLICATE of bug 256016
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-16 21:49 UTC by fernercc
Modified: 2009-03-20 15:42 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fernercc 2009-03-16 21:49:38 UTC
Upon logging into a newly emerged gnome ebuild (2.24.1), I get the following error as a popup, clicking OK logs me out:


/etc/X11/gdm/Xsession: Beginning session setup...
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- /usr/bin/seahorse-agent --execute gnome-session
SESSION_MANAGER=local/mobiliare:/tmp/.ICE-unix/26848
** Message: another SSH agent is running at: /tmp/ssh-ADDCI26848/agent.26848
1237221729.801311 Session manager: disconnected...
Window manager warning: Failed to read saved session file /home/bully/.config/metacity/sessions/default0.ms: Failed to open file '/home/bully/.config/metacity/sessions/default0.ms': No such file or directory
1237221730.539864 Session manager: disconnected...
**
ERROR:dbus-gproxy.c:661:unassociate_proxies: assertion failed: (priv->associated)

(nautilus:26913): GnomeUI-WARNING **: While connecting to session manager:
IO error occured doing Protocol Setup on connection.

(gnome-power-manager:26927): GnomeUI-WARNING **: While connecting to session manager:
IO error occured doing Protocol Setup on connection.


Reproducible: Always

Steps to Reproduce:
1. Just login.
Comment 1 Jean-Claude Repetto 2009-03-17 08:29:09 UTC
I have a similar problem, just after upgrading to gnome 2.24.
This is the content of the .xsession-errors file :

/etc/X11/gdm/Xsession: Beginning session setup...
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
SESSION_MANAGER=local/jean-claude:/tmp/.ICE-unix/4931
** Message: another SSH agent is running at: /tmp/ssh-tWENIS4931/agent.4931
1237277412.989167 Session manager: disconnected...
**
ERROR:dbus-gproxy.c:661:unassociate_proxies: assertion failed: (priv->associated)
Comment 2 luca 2009-03-17 10:37:14 UTC
same here problems here ...

.xsession-errors file:

/etc/X11/gdm/Xsession: Beginning session setup...
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
SESSION_MANAGER=local/bet4:/tmp/.ICE-unix/4071
** Message: another SSH agent is running at: /tmp/ssh-QWwrFX4071/agent.4071
1237286050.366383 Session manager: disconnected...
1237286051.572129 Session manager: disconnected...
**
ERROR:dbus-gproxy.c:661:unassociate_proxies: assertion failed: (priv->associated)
Comment 3 luca 2009-03-17 11:38:11 UTC
It seems an downgrade to x11-libs/libxklavier-3.6 (3.8 was installed), fix the problem.
http://forums.gentoo.org/viewtopic-t-709049-postdays-0-postorder-asc-highlight-gnome-start-150.html

Comment 4 fernercc 2009-03-17 16:00:33 UTC
(In reply to comment #3)
> It seems an downgrade to x11-libs/libxklavier-3.6 (3.8 was installed), fix the
> problem.
> http://forums.gentoo.org/viewtopic-t-709049-postdays-0-postorder-asc-highlight-gnome-start-150.html
> 


I can confirm that downgrading from x11-libs/libxklavier-3.8 to x11-libs/libxklavier-3.6 worked by doing:  echo "=x11-libs/libxklavier-3.8*" >> /etc/portage/package.mask then doing a deep update worl emerge.
Comment 5 Gilles Dartiguelongue gentoo-dev 2009-03-17 16:21:44 UTC

*** This bug has been marked as a duplicate of bug 256016 ***