Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262628 - dev-php5/eAccelerator should contain dependancy on php
Summary: dev-php5/eAccelerator should contain dependancy on php
Status: RESOLVED DUPLICATE of bug 192319
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-16 08:02 UTC by Manuel Schmitt
Modified: 2009-03-17 18:41 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Schmitt 2009-03-16 08:02:54 UTC
Upgrading PHP breaks eAccelerator build (because PHP version is hard-encoded in eAccelerator shared object file).

The eBuild for eAccelerator should take this into consideration and contain some dependecies.

Reproducible: Always

Steps to Reproduce:
1. Upgrade php (while having eAccerlator not rebuilt)
2. Restart your webserver (e.g. Apache)


Actual Results:  
eAccelerator start fails and complains about "wrong" php version.

Expected Results:  
eAccelerator eBuild should depend on php version and hard-rebuild should be taken into consideration.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-17 18:41:33 UTC
Portage cannot forcibly re-emerge any package due to another package being upgraded. This might be on the TODO list for future portage-versions but currently this is not implemented.

*** This bug has been marked as a duplicate of bug 192319 ***