Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262389 - app-emulation/vmware-server-1.0.8 - Unable to connect to the MKS: The operation has timed out.
Summary: app-emulation/vmware-server-1.0.8 - Unable to connect to the MKS: The operati...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-13 21:14 UTC by Chris Frederick
Modified: 2011-03-17 13:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
/tmp/vmware-cdf123/ui-9475.log showing segfault (ui-9475.log,7.73 KB, text/plain)
2009-03-13 21:19 UTC, Chris Frederick
Details
client /tmp/vmware-root/ui-9177.log file (ui-9177.log,8.51 KB, text/plain)
2009-03-23 19:24 UTC, Chris Frederick
Details
server /var/log/vmware/vmware-serverd.log file (vmware-serverd.log,21.56 KB, text/plain)
2009-03-23 19:29 UTC, Chris Frederick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Frederick 2009-03-13 21:14:40 UTC
Connecting to a remote vmware-server-1.0.8.126538 installation using vmware-server-console-1.0.8.126538 works.  But if I try to start a guest machine, or connect while a guest machine is running the console will freeze for a while and eventually popup an error: "Unable to connect to the MKS: The operation has timed out."
Further investigation shows a segfault being caught in the /tmp/vmware-[user]/ui-*.log.

I've tried this with multiple user accounts (including root) and they have the same segfault in the ui-*.log file.
Comment 1 Chris Frederick 2009-03-13 21:17:40 UTC
emerge --info
Portage 2.1.6.7 (!../usr/portage/profiles/default/linux/x86/2008.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r9 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r9-i686-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-glibc2.0
Timestamp of tree: Thu, 26 Feb 2009 20:45:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r9, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://gentoo.mirrors.tds.net/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/overlay"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa asf avi berkdb browserplugin bzip2 cdr cli cracklib crypt cups dri dvd dvdr dvdread encode foomaticdb fortran ftp gdbm gif gimp iconv imap isdnlog jpeg kde ldap midi mmx mp3 mpeg mudflap ncurses nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png pppd python readline reflection session spl sse sse2 ssl svg sysfs tcpd threads tiff truetype unicode usb vorbis win32codecs x86 xine xml xorg xprint xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="i810 vga vesa intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 2 Chris Frederick 2009-03-13 21:19:10 UTC
Created attachment 184919 [details]
/tmp/vmware-cdf123/ui-9475.log showing segfault
Comment 3 Mike Auty gentoo-dev 2009-03-17 23:08:33 UTC
Ok, this looks like a segfault on the server side.  Could you please tell me what happens when you start up /opt/vmware/server/bin/vmware, and connect not using an IP address, but the radio button that says "connect to local machine" or something like that?

My guess is the whole lot will still crash, but it's quite difficult to diagnose given that the server doesn't provide any further descriptive information.  Please also ensure that revdep-rebuild doesn't say anything's broken...

Lastly, could you please check if you have any none ui logs, so just /var/log/vmware/vmware-serverd.log or anything like that.  It might have more useful information about what's going wrong...
Comment 4 Chris Frederick 2009-03-23 19:22:46 UTC
I did a revdep-rebuild on both server and client, the server was fine.  The client had problems with xpdf and nessus, and I fixed the xpdf but I'm saving the nessus for another day and that shouldn't interfere with vmware-server-console at all anyway.

I rebooted the server and shut down all the vmware guests.  I started vmware-server-console with the root user and I connected to the server and tried to start one of the guests.  This gave the same error as before (I'll attach the log files for /tmp/vmware-root/ui-9177.log on the client and /var/log/vmware/vmware-serverd.log on the server).  I also connected from a windows box with the vmware-server-console installed, and I can see that machine that I started was up and running.  I was also able to run vmware on the server itself without any problems.

This looks like it's the vmware-server-console client that is segfaulting.  Any ideas?
Comment 5 Chris Frederick 2009-03-23 19:24:38 UTC
Created attachment 186029 [details]
client /tmp/vmware-root/ui-9177.log file
Comment 6 Chris Frederick 2009-03-23 19:29:34 UTC
Created attachment 186030 [details]
server /var/log/vmware/vmware-serverd.log file
Comment 7 Mike Auty gentoo-dev 2009-03-23 20:51:24 UTC
Hiya Chris, first off a quick question.  Does this happen with a brand new virtual machine made on vmware-server?  Be careful of the "console crashes when making new machine" issue by double checking you've got gtkmm, libsexy, libsexymm and libview recompiled (in that order) after setting USE="accessibility" for gtkmm.  There seem to be messages about unknown hardware devices, which suggests that possibly it's a vmware machine that's been taken from elsewhere and may have virtual hardware differences.

Thanks for the extra logs, they offer a little more to search on.

http://communities.vmware.com/thread/64548 suggests permission problems, but that appears to be the server killing off the machines, whereas you said the windows client could connect to them fine and they were still running.

Nothing else seems to come close.  There's several mentions of checking the permissions of the all the files in the vmware directory (some of the files have to be executable for vmware to start them ok), but again since vmware starts, I'm not sure what's wrong.

The only issue I've ever seen with the console hanging is due to xinetd issues where localhost isn't correctly parsed, but that would block the windows console too.

You didn't mention whether you tried using local access, or always tested the xinetd/remote method of connecting.  Could you please test that?  There are instructions in comment 3 for starting that up, although it won't work if you don't have X running on your server box.

Otherwise I'm stumped, and you might do better to try asking on the VMTN network, since I don't really have any further advice and can't help you debug the problem further...
Comment 8 Chris Frederick 2009-03-25 20:22:47 UTC
Well, I tried the emerge steps that you listed, just in case, and that didn't fix it.  I did test the local connection (I installed tightvnc and ratpoison) and it did work.

Thanks for your help, I guess I'll see what I can do from the VMTN.  Do you mind leaving the bug open until I hear from them?  Hopefully I can get a fix and post it back here.
Comment 9 Mike Auty gentoo-dev 2009-03-25 21:44:09 UTC
No that's fine, I'm happy to leave it open.

It's odd that the local connection works, but the network connection fails.  From the local running console (running vmware on the server itself), rather than selecting local, what happens if you try to connect to 127.0.0.1?

Also, since we're going over the basics in case they help, do double check the xinetd.conf and xinetd.d/vmware files, and make sure the only_from line is set appropriately (it's usually set to localhost only, and depending on the hosts file setup, can sometimes cause problems).  
Comment 10 Chris Frederick 2009-06-10 13:28:09 UTC
Hey Mike, got an update for you.  I updated the server to vmware-server-2.0 and everything seems to be working fine now.  I had to uninstall all the vmware products on my desktop and use the web interface to access the virtual machines on the server.  If you want to close the bug, go right ahead.
Comment 11 Vadim Kuznetsov (RETIRED) gentoo-dev 2011-03-17 13:11:21 UTC
vmware-server 1.0.x is not in the portage anymore.
Bug 354383.