Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262313 - x11-drivers/xf86-input-evdev-2.2.0-r1: keyboard not working after a VT switch
Summary: x11-drivers/xf86-input-evdev-2.2.0-r1: keyboard not working after a VT switch
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-12 22:08 UTC by Andrey Vihrov
Modified: 2009-03-14 08:50 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Log file (Xorg.0.log,23.59 KB, text/plain)
2009-03-12 22:09 UTC, Andrey Vihrov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Vihrov 2009-03-12 22:08:28 UTC
Switching from X to the console and back renders the whole keyboard useless. Not 100% sure this is not an X server bug, but it appears the behavour occured first shortly after updating evdev to the latest version.

Running stable amd64 (but with ~amd64 packs listed in bug #251832) and x11-base/xorg-server-1.5.3-r4. Video driver, just in case, is x11-drivers/xf86-video-intel-2.6.3 on an Intel GMA X3100.

Also attaching sample log acquired after reproducing the bug, but doesn't seem like there's anything special.

Reproducible: Always

Steps to Reproduce:
1. Start the X server
2. Switch to the text console
3. Switch back

Actual Results:  
Keyboard unusable

Expected Results:  
Keyboard works

Portage 2.1.6.7 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r1, 2.6.28-gentoo-r3 x86_64)
=================================================================
System uname: Linux-2.6.28-gentoo-r3-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T8100_@_2.10GHz-with-glibc2.2.5
Timestamp of tree: Thu, 12 Mar 2009 20:00:02 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CPPFLAGS="-DNDEBUG"
CXXFLAGS="-march=nocona -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://gentoo.tups.lv/source/"
LANG="ru_RU.UTF-8"
LC_ALL="ru_RU.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en lv"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aac acpi alsa amd64 avahi bash-completion berkdb bluetooth bonjour branding bzip2 cairo cdr cli cracklib crypt cups dbus djvu dri dvd dvdr dvdread eds emboss encode evo exif fam ffmpeg firefox flac fortran gdbm gif gnome gnome-keyring gpm gstreamer gtk hal hddtemp iconv id3tag ieee1394 ipod isdnlog jpeg libnotify lm_sensors mad midi mikmod mmx mmxext mp3 mpeg mudflap multilib nautilus ncurses networkmanager nls nptl nptlonly nsplugin ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support quicktime readline reflection rtc samba sdl session smp spell spl sqlite sse sse2 sse3 sse4_1 ssl ssse3 startup-notification svg symlink sysfs tcpd theora threads tiff totem truetype unicode upnp usb v4l2 vim-syntax vorbis x264 xml xorg xulrunner xv xvid xvmc zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en lv" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Andrey Vihrov 2009-03-12 22:09:01 UTC
Created attachment 184844 [details]
Log file
Comment 2 Rémi Cardona gentoo-dev 2009-03-14 06:54:11 UTC
I have no idea what is causing this issue.

Please file a bug in FreeDesktop's bugzilla. Please paste the url here so we can track the issue.

Thanks
Comment 3 Andrey Vihrov 2009-03-14 08:40:46 UTC
Sorry, it seems I didn't realize what was happening there to the end. After a little more experimenting, it was discovered that

* X would hang after a software suspend-resume (probably because a VT switching also takes place there)
* It's not only the keyboard: in reality, all apps seem to be frozen when the bug is triggered, and the only one alive thing is the mouse pointer (sometimes freezes too)
* Disabling the console framebuffer makes the bug disappear

So, it seems it's rather a video driver issue.

Now, about the framebuffer: the kernel is 2.6.28-gentoo-r3, framebuffer module is vesafb and is started with kernel command line parameters "video=vesafb:mtrr:3,ywrap vga=0x363".
Comment 4 Rémi Cardona gentoo-dev 2009-03-14 08:50:45 UTC
Ahha, well thanks for the follow up, I appreciate it.

Unfortunately, I don't think this is fixable and since newer kernels will have KMS with a built-in kernel framebuffer driver, you won't be able to use vesafb anyway.

I strongly urge you disable vesafb, it's not the first time I see bugs related to it.

Thanks again for digging :)