Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262283 - net-misc/openssh-5.1_p1-r2 segfaults regularly on IRIX
Summary: net-misc/openssh-5.1_p1-r2 segfaults regularly on IRIX
Status: RESOLVED DUPLICATE of bug 261904
Alias: None
Product: Gentoo/Alt
Classification: Unclassified
Component: Prefix Support (show other bugs)
Hardware: All IRIX
: Highest critical (vote)
Assignee: Gentoo Prefix
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-12 16:33 UTC by Stuart Shelton
Modified: 2009-03-12 17:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Shelton 2009-03-12 16:33:59 UTC
... the ChangeLog for this ebuild includes:

  09 Mar 2009; Robin H. Johnson <robbat2@gentoo.org>
  +openssh-5.2_p1-r2.ebuild:
  Added my own unofficial port of the HPN patch, because performance sucks
  without it.

... which I'm not suggesting is the cause of the problem, but it caught my interest ;)

OpenSSH has always been completely stable on IRIX, except after upgrading yesterday I've had at least 8 segfaults so far today.

Are any other exotic/prefix arches experiencing instability with the latest build?
Comment 1 Stuart Shelton 2009-03-12 16:35:51 UTC
(My USE flags for this build are "X hpn".  I've not tried it without "hpn" yet.  Let me give that a try and I'll report back)
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-12 16:38:38 UTC
This version already got p.masked because of problems with the HPN patch:

# Robin H. Johnson <robbat2@gentoo.org> (11 Mar 2009)
# HPN patch contains some breakages with port forwarding.
=net-misc/openssh-5.2_p1-r2

Please downgrade to openssh-5.2_p1-r1

*** This bug has been marked as a duplicate of bug 261904 ***
Comment 3 Fabian Groffen gentoo-dev 2009-03-12 17:54:10 UTC
mask synced, should flow through in 30 minutes or so