Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262193 - gnome-extra/gnome-media-2.24.0.1-r1: Function `g_content_type_guess' implicitly converted to pointer at gnome-recorder.c:99
Summary: gnome-extra/gnome-media-2.24.0.1-r1: Function `g_content_type_guess' implicit...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High major (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 20:14 UTC by Alexander Bezrukov
Modified: 2009-05-25 23:28 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Bezrukov 2009-03-11 20:14:50 UTC
When emerging =gnome-extra/gnome-media-2.24.0.1-r1, I have got the following message:

 * QA Notice: Package has poor programming practices which may compile
 *            but will almost certainly crash on 64bit architectures.
 *
 * Function `g_content_type_guess' implicitly converted to pointer at gnome-recorder.c:99
 *
 *  Please file a bug about this at http://bugs.gentoo.org/
 *  with the maintaining herd of the package.

I didn't attempt to look any further.

Reproducible: Always

Steps to Reproduce:
1. emerge --oneshot =gnome-extra/gnome-media-2.24.0.1-r1

Actual Results:  
 * Function `g_content_type_guess' implicitly converted to pointer at gnome-recorder.c:99



emerge --info
Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.8_p20080602-r1, 2.6.28.7-alb x86_64)
=================================================================
System uname: Linux-2.6.28.7-alb-x86_64-Dual_Core_AMD_Opteron-tm-_Processor_285-with-glibc2.2.5
Timestamp of tree: Wed, 11 Mar 2009 18:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-combine -march=opteron -momit-leaf-frame-pointer -Os -pipe -fomit-frame-pointer -finline-functions-called-once -ftree-vectorize"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-combine -march=opteron -momit-leaf-frame-pointer -Os -pipe -fomit-frame-pointer -finline-functions-called-once -ftree-vectorize"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ http://trumpetti.atm.tut.fi/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ ftp://mirror.yandex.ru/gentoo-distfiles/"
LANG="en_US.utf8"
LC_ALL=""
LDFLAGS="-Wl,-O1"
LINGUAS="en ru"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X acl acpi alsa amd64 bash-completion berkdb bidi bzip2 caps cdr cjk cli cracklib crypt cscope cups dbus djvu dri dvd dvdr dvdread fortran gdbm gif gnome gpm gtk hal hardened iconv ieee1394 isdnlog jpeg jpeg2k kerberos lcms ldap ldapsam lm_sensors loop-aes midi mmap mmx mudflap multilib ncurses nls nptl nptlonly nsplugin opengl openmp pam pcre perl png pppd python readline reflection samba session spl sse sse2 ssl sysfs tcpd threads tiff truetype unicode usb winbind xorg xulrunner zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse joystick vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en ru" USERLAND="GNU" VIDEO_CARDS="nvidia fbdev vesa vga"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Philippe Chaintreuil 2009-03-12 12:06:33 UTC
I get this as well.
Comment 2 SpanKY gentoo-dev 2009-03-12 22:57:27 UTC
there was a bug in some versions of portage which allowed this to be installed.  that has been fixed which means this is now a build failure.
Comment 3 Gilles Dartiguelongue gentoo-dev 2009-03-14 22:02:11 UTC
oh nice, yet another time wasting QA warning. Please report this upstream and paster the url here, thanks.
Comment 4 Gilles Dartiguelongue gentoo-dev 2009-03-14 22:42:06 UTC
On second thought, 
FEATURES="test stricter" emerge -1 gnome-media

doesn't fail here:

# emerge --info
Portage 2.2_rc25 (default/linux/amd64/2008.0, gcc-4.3.3, glibc-2.9_p20081201-r2, 2.6.24-gentoo-r8-mactel x86_64)
=================================================================
System uname: Linux-2.6.24-gentoo-r8-mactel-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T7500_@_2.20GHz-with-gentoo-2.0.0
Timestamp of tree: Sat, 14 Mar 2009 20:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     4.0_p10-r1
dev-lang/python:     2.6.1
dev-util/ccache:     2.4-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.4.3-r1
sys-apps/sandbox:    1.6
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -g"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -g"
DISTDIR="/var/tmp/distfiles"
FEATURES="ccache distcc distlocks fixpackages multilib-strict parallel-fetch preserve-libs protect-owned sandbox sfperms sign splitdebug strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://mirror.ovh.net/gentoo-distfiles/ ftp://mirror.ovh.net/gentoo-distfiles/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en fr ja zh zh_CN"
MAKEOPTS="-j4"
PKGDIR="/var/tmp/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/voip /home/eva/devel/overlays/gentoo-misc /home/eva/devel/overlays/gnome"
SYNC="rsync://rsync.be.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 applet asyncns avahi avi bash-completion bluetooth bzip2 cairo cdr cjk cli consolekit cracklib crypt cups dbus dri dvd dvdr dvdread eds epiphany evo fam ffmpeg flac galago gedit glitz gnome gnome-keyring gnutls gpm gstreamer hal iconv ipv6 isdnlog jpeg laptop ldap libnotify mad matroska midi mmx mp3 mpeg mudflap multilib nautilus ncurses networkmanager nfs nls nntp nptl nptlonly nsplugin ntpl ogg openct opengl openmp pam pcre pdf perl png pppd python readline reflection session smp spell spl sse sse2 ssl ssse3 startup-notification svg sysfs tcpd theora threads unicode v4l v4l2 vim-syntax vorbis x264 xattr xcb xinerama xml xmp xorg xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="dav dav_fs authn_file auth_digest authz_groupfile authz_host dir mime" APACHE2_MPMS="event" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics evdev" KERNEL="linux" LINGUAS="en fr ja zh zh_CN" USERLAND="GNU" VIDEO_CARDS="i810 intel vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

There's no reason a stable version of portage would introduce a feature that hasn't been in a development version for a while, is it ? @zmedico, could you confirm or inform vapier's comment ?
Comment 5 Zac Medico gentoo-dev 2009-03-16 01:19:21 UTC
(In reply to comment #4)
> There's no reason a stable version of portage would introduce a feature that
> hasn't been in a development version for a while, is it ? @zmedico, could you
> confirm or inform vapier's comment ?

This is the change got released in portage-2.1.6.8 and 2.2_rc24:

http://sources.gentoo.org/viewcvs.py/portage?view=rev&rev=12793

Since we don't have time machines there's no way that change got into any earlier releases.
Comment 6 Alexander Bezrukov 2009-03-16 02:07:52 UTC
This happened in Portage 2.1.6.7 but I cannot reproduce this right now.

What I see from the code, this means that somehow happened that $gentoo_bug = yes. What I see also is this construct (/usr/lib64/portage/bin/misc-functions.sh:387):

# just warn on 32bit hosts but bail on 64bit hosts
case ${CHOST} in
  alpha*|ia64*|powerpc64*|mips64*|sparc64*|x86_64*) gentoo_bug=yes ;;
esac

this is just my case.

I must be unaware of many details but at least this code is present in 2.1.6.7 and the problem doesn't show up simply because the compiler doesn't complain anymore:

emerge --oneshot gnome-extra/gnome-media 2>&1 | grep g_content_type_guess
<empty>
Comment 7 Alexander Bezrukov 2009-03-16 02:15:49 UTC
And the ebuild hasn't died with the "poor code kills airplanes" message, just the request to file a bug has shown up.
Comment 8 Gilles Dartiguelongue gentoo-dev 2009-05-25 23:28:18 UTC
closing CANTFIX per comment #4, #6 and #7. Please do reopen if you can reproduce this. Thanks.