Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262170 - Not stable dependency for app-misc/beagle with USE="eds"
Summary: Not stable dependency for app-misc/beagle with USE="eds"
Status: RESOLVED DUPLICATE of bug 234305
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 18:17 UTC by Claas Altschaffel
Modified: 2009-03-22 17:57 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claas Altschaffel 2009-03-11 18:17:43 UTC
'emerge -avuND world' fails on amd64 with installed app-misc/beagle and use flag 'eds' due to dependency on on dev-dotnet/evolution-sharp.

Current stable on amd64 is dev-dotnet/evolution-sharp-0.17.4. That version is for evolution-data-server-2.22*. The version for evolution-data-server-2.24 is >=evolution-sharp-0.18.1. But this versions are masked as testing and depends on mono-2.

Solutions?:
1. Mask keyword 'eds' for app-misc/beagle for amd64. (works)
2. Stabilize dev-dotnet/evolution-sharp-0.18.1 and mono-2 dependencies?

emerge -avuND world runs fine with USE="-eds" or in package.use for app-misc/beagle

Best regards,
Claas

Reproducible: Always

Steps to Reproduce:
1. USE="eds"
2. emerge gnome-2.24 and beagle
3. failed dependency, emerge stops

Actual Results:  
beagle does not work work for evolution-2.24

Expected Results:  
beagle can index evolution information
Comment 1 Gilles Dartiguelongue gentoo-dev 2009-03-22 15:26:48 UTC
dotnet would probably be more interested in this.
Comment 2 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-22 17:57:15 UTC

*** This bug has been marked as a duplicate of bug 234305 ***