Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262147 - net-misc/nxserver-freenx always pulls net-misc/vnc. tightvnc is needed to connect to Mac OS X + missing x11-misc/x11vnc dependency
Summary: net-misc/nxserver-freenx always pulls net-misc/vnc. tightvnc is needed to con...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High minor (vote)
Assignee: NX Server Herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 15:26 UTC by Chris Paras
Modified: 2009-09-17 09:23 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Paras 2009-03-11 15:26:20 UTC
I'd like to use NX to connect to my macbook pro running a vnc server. Unfortunately, when the NX Client shows "established the display connection", NX client bails out immediately without any error messages. I tried to use the vncviewer program from the net-misc/vnc package (which is a dependency of net-misc/nx) to connect to the mac, with the same results as using NX. Afterwards i tried using the vncviewer program included in the net-misc/tightvnc package and it worked just fine. 

Reproducible: Always

Steps to Reproduce:
1. emerge nxserver-freenx on server
2. try to connect to a mac running it's internal vnc server (via net-misc/vnc's vncviewer program)
3. try 2. but instead use net-misc/tightvnc's vncviewer program (you may emerge tightvnc first)





One should be able to choose which vnc client to install to satisfy net-misc/nx
Comment 1 Alexander Bezrukov 2009-03-12 02:12:03 UTC
By the way, nxserver-freenx needs x11-misc/x11vnc. So despite the ebuild pulls net-misc/vnc, nxserver-freenx tries to launch x11vnc (because it needs to snoop the real X11 display). To the best of my knowledge, neither tightvnc nor net-misc/vnc are of any help on the server side.
Comment 2 Chris Paras 2009-03-12 23:15:05 UTC
(In reply to comment #1)
> By the way, nxserver-freenx needs x11-misc/x11vnc. So despite the ebuild pulls
> net-misc/vnc, nxserver-freenx tries to launch x11vnc (because it needs to snoop
> the real X11 display). To the best of my knowledge, neither tightvnc nor
> net-misc/vnc are of any help on the server side.
> 

I think you're wrong, because when i try to emerge nxserver-freenx-0.7.3-r2, it doesn't want to pull net-misc/x11vnc. Also the ebuild file doesn't mention any dependencies on net-misc/x11vnc. 
Comment 3 Alexander Bezrukov 2009-03-12 23:28:05 UTC
(in reply to comment #2)

This is what makes it a bug. To reproduce it, emerge net-misc/nx with vnc USE flag, start an instance of a local X server on a local console, start the nxserver and then try to attach remotely (through an nx client) to your local X session. Then you will observe the behaviour described in this bug. What happens is that nxserver tries to launch x11vnc and fails (unless it is indeed installed and path to it set correctly in the COMMAND_X11VNC variable (either internally in the defaults or in the node.conf bash script)). This behaviour is documented in the nxserver-freenx documentation.
Comment 4 Bernard Cafarelli gentoo-dev 2009-03-19 16:18:08 UTC
OK let's try to clear this one up:
* net-misc/nx accepts either vnc or tightvnc as dependency (vnc by default)
* and vncviewer from vnc does not work when connecting to a VNC server on Mac OS X
That would rather be a bug report for net-misc/vnc itself (can you try if it is reproductible on a local X session).

Now freenx also requires x11vnc for shadowing (in addition to vncviewer, which does the real job). VNC server USE flag was needed before for vncpasswd tool (worked around in current freenx with nxpasswd tool).

I wanted to move vnc/rdesktop depends in nxserver-freenx too, with updated depend for USE=vnc on x11vnc and either tightvnc (default) or vnc.

Yell at me if I forgot something in this bug ;) (I'll try to do these changes soon)
Comment 5 Bernard Cafarelli gentoo-dev 2009-03-20 16:40:44 UTC
(In reply to comment #4)
I'll try to do these changes soon

Done, net-misc/nx-3.3.0-r3 no longer has rdesktop and vnc USE flags, and net-misc/nxserver-freenx-0.7.3_p102.ebuild got them, with vnc dependencies updated to:
        vnc? ( x11-misc/x11vnc
                   || ( net-misc/tightvnc net-misc/vnc ) )

Thanks for the report and suggestions
Comment 6 Chris Paras 2009-09-11 14:21:04 UTC
(In reply to comment #5)
> (In reply to comment #4)
> I'll try to do these changes soon
> 
> Done, net-misc/nx-3.3.0-r3 no longer has rdesktop and vnc USE flags, and
> net-misc/nxserver-freenx-0.7.3_p102.ebuild got them, with vnc dependencies
> updated to:
>         vnc? ( x11-misc/x11vnc
>                    || ( net-misc/tightvnc net-misc/vnc ) )
> 
> Thanks for the report and suggestions
> 

(In reply to comment #5)
> (In reply to comment #4)
> I'll try to do these changes soon
> 
> Done, net-misc/nx-3.3.0-r3 no longer has rdesktop and vnc USE flags, and
> net-misc/nxserver-freenx-0.7.3_p102.ebuild got them, with vnc dependencies
> updated to:
>         vnc? ( x11-misc/x11vnc
>                    || ( net-misc/tightvnc net-misc/vnc ) )
> 
> Thanks for the report and suggestions
> 

When does this become stable in portage ?

Btw, shouldn't the same be done to net-misc/nxserver-freeedition ?

Comment 7 Bernard Cafarelli gentoo-dev 2009-09-17 09:23:17 UTC
(In reply to comment #6)
My current plan is to ask stable on all NX servers (including neatx which was a bit delayed), and latest NX libs, so this should happen in a few weeks

And indeed freeedition needed a few cleanups too (missing the last checks added in freenx), this is updated now and will go in the same round of stabling