Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 262139 - x11-plugins/pidgin-msn-pecan crashes... predictably
Summary: x11-plugins/pidgin-msn-pecan crashes... predictably
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Bernard Cafarelli
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-11 14:26 UTC by Giuseppe Marco Randazzo <zeld>
Modified: 2009-06-21 22:33 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
backtrace 1/3 (backtrace1.log,1.17 KB, text/plain)
2009-03-11 14:27 UTC, Giuseppe Marco Randazzo <zeld>
Details
backtrace 2/3 (backtrace2.log,4.92 KB, text/plain)
2009-03-11 14:27 UTC, Giuseppe Marco Randazzo <zeld>
Details
backtrace 3/3 (backtrace3.log,1.07 KB, text/plain)
2009-03-11 14:28 UTC, Giuseppe Marco Randazzo <zeld>
Details
emerge --info and emerge -qpv results (pidgin_bug.txt,3.58 KB, text/plain)
2009-03-15 14:52 UTC, gogoprog
Details
pidgin output and emrge --info (myoutput.txt,4.38 KB, text/plain)
2009-03-16 00:05 UTC, Giuseppe Marco Randazzo <zeld>
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Giuseppe Marco Randazzo <zeld> 2009-03-11 14:26:25 UTC
net-im/pidgin-2.5.5 with x11-plugins/pidgin-msn-pecan-0.0.18 going on iexplicably crash. I use gentoo linux with gcc-4.3.2-r3 and glibc sys-libs/glibc-2.9_p20081201-r1. Attached the backtrace.

Reproducible: Always
Comment 1 Giuseppe Marco Randazzo <zeld> 2009-03-11 14:27:36 UTC
Created attachment 184697 [details]
backtrace 1/3

backtrace 1/3
Comment 2 Giuseppe Marco Randazzo <zeld> 2009-03-11 14:27:54 UTC
Created attachment 184698 [details]
backtrace 2/3
Comment 3 Giuseppe Marco Randazzo <zeld> 2009-03-11 14:28:07 UTC
Created attachment 184700 [details]
backtrace 3/3
Comment 4 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-12 16:05:28 UTC
Please post your "emerge--info" and the output of
  emerge -qpv pidgin pidgin-msn-pecan

Re-open this bug when you provide the requested information. 
Comment 5 gogoprog 2009-03-15 14:52:06 UTC
Created attachment 185089 [details]
emerge --info and emerge -qpv results

I've got the same bug, so here is soem additionnal information
Comment 6 Giuseppe Marco Randazzo <zeld> 2009-03-16 00:05:16 UTC
Created attachment 185123 [details]
pidgin output and  emrge --info
Comment 7 Giuseppe Marco Randazzo <zeld> 2009-03-16 00:05:57 UTC
reopened the bug :-)
Comment 8 Olivier Crete (RETIRED) gentoo-dev 2009-03-16 15:08:35 UTC
Those are not in pidgin, but in msn-pecan.

My advice is to use the built-in msn plugin, not pecan.
Comment 9 Bernard Cafarelli gentoo-dev 2009-03-16 16:52:22 UTC
Thanks for the report, can you recompile pidgin-msn-pecan (and maybe pidgin too) with debug informations enabled?

http://www.gentoo.org/proj/en/qa/backtraces.xml

Also upstream suggests to run pidgin as:
# pidgin --debug > debug_log.txt

This will help them track the problem. At first glance, I've not seen any recent commit that could fix your crash, and it works fine here so I cannot reproduce
Comment 10 Bernard Cafarelli gentoo-dev 2009-06-21 22:33:26 UTC
pidgin-msn-pecan-0.0.19 is in tree and fixes a few crashes, please test it. The announcement (and list of fixed items) is here:
http://felipec.wordpress.com/2009/06/16/msn-pecan-0-0-19-released-more-stability-and-now-playing-support/

Please reopen if it is not fixed in this release