Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261869 - dev-lang/mono-2.2-r3 merging hangs
Summary: dev-lang/mono-2.2-r3 merging hangs
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: dotnet
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-09 15:04 UTC by alexey stalker
Modified: 2009-04-17 01:29 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge.log file (emerge.log,272.42 KB, text/plain)
2009-03-10 10:38 UTC, alexey stalker
Details
build.log for mono (build.log,261.97 KB, text/plain)
2009-03-10 12:17 UTC, alexey stalker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alexey stalker 2009-03-09 15:04:47 UTC
whtn emerging mono-2.2-r3, (using ACCEPT_KEYWORDS="~x86") it hangs on this:
cd ../mcs && make NO_DIR_CHECK=1 PROFILES='net_1_1 net_2_0 net_3_5' CC='i686-pc-linux-gnu-gcc' all-profiles
make[3]: Entering directory `/var/tmp/portage/dev-lang/mono-2.2-r3/work/mono-2.2/mcs'
make profile-do--net_1_1--all profile-do--net_2_0--all profile-do--net_3_5--all
make[4]: Entering directory `/var/tmp/portage/dev-lang/mono-2.2-r3/work/mono-2.2/mcs'
make PROFILE=basic all
make[5]: Entering directory `/var/tmp/portage/dev-lang/mono-2.2-r3/work/mono-2.2/mcs'
make[6]: mcs: Command not found
make[6]: *** [build/deps/basic-profile-check.exe] Error 127
make[6]: Entering directory `/var/tmp/portage/dev-lang/mono-2.2-r3/work/mono-2.2/mcs'
*** The compiler 'mcs' doesn't appear to be usable.
*** Trying the 'monolite' directory.
make[7]: Entering directory `/var/tmp/portage/dev-lang/mono-2.2-r3/work/mono-2.2/mcs'


Reproducible: Always

Steps to Reproduce:
1.set ACCEPT_KEYWORDS="~x86"
2.emerge mono

Actual Results:  
merging fails (hangs for two hours minimum)
Comment 1 Rafał Mużyło 2009-03-09 15:47:27 UTC
Please attach full emerge.log.
Also, do you have any previous versions of mono already emerged ?
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-09 16:00:10 UTC
And don't forget to post your "emerge --info".
Comment 3 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-09 21:39:58 UTC
Please re-open when you add the requested information.
Comment 4 alexey stalker 2009-03-10 10:36:07 UTC
System uname: Linux-2.6.27-gentoo-r8-i686-Intel-R-_Core-TM-2_CPU_T5500_@_1.66GHz-with-glibc2.0
Timestamp of tree: Mon, 09 Mar 2009 07:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.6.3
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.4
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=prescott -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O3 -march=prescott -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ http://gentoo.kiev.ua/ftp/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://gentoo.virginmedia.com/ "
LANG="C"
LDFLAGS="-Wl,-O1"
LINGUAS="ru en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="Qt4 X acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kde ldap libnotify mad midi mikmod mono mp3 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis webkit win32codecs x86 xml xorg xulrunner xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse vmmouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="ru en" USERLAND="GNU" VIDEO_CARDS="vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Comment 5 alexey stalker 2009-03-10 10:38:18 UTC
Created attachment 184546 [details]
emerge.log file
Comment 6 Peter Alfredsen (RETIRED) gentoo-dev 2009-03-10 11:31:41 UTC
Please attach build.log
Also, if you already have another version of mono installed could you try uninstalling that and retrying?
Comment 7 alexey stalker 2009-03-10 12:17:33 UTC
Created attachment 184558 [details]
build.log for mono
Comment 8 alexey stalker 2009-03-10 12:19:59 UTC
no versions of mono were installed on the system before.
Comment 9 Sergey Zolotorev 2009-04-14 11:46:44 UTC
I found the same problem with compiling mono-2.0.1-r1.

I have discovered that is compiling hangs on semget() call (in shared.c) when SysV IPC (CONFIG_SYSVIPC) is disabled in kernel.

When I had enabled CONFIG_SYSVIPC compiling was successfully.

Perhaps it should be fixed in Mono sources (to check if semget is 'not implemented'). For workaround CONFIG_SYSVIPC checking can be added into mono ebuild.
Comment 10 Peter Alfredsen (RETIRED) gentoo-dev 2009-04-17 01:29:55 UTC
+  17 Apr 2009; Peter Alfredsen <loki_val@gentoo.org> mono-2.0.1-r1.ebuild,
+  mono-2.2-r5.ebuild, mono-2.4.ebuild:
+  Check for CONFIG_SYSVIPC, see bug 261869. Thanks to Sergey Zolotorev
+  <sergey.zolotorev@gmail.com> for finding the cause.
+

Thanks for finding the cause of this elusive bug.