Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261846 - Decorations and windows display errors at KDE 4.2.1 and QT 4.5.0
Summary: Decorations and windows display errors at KDE 4.2.1 and QT 4.5.0
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-09 12:00 UTC by Migo
Modified: 2010-04-09 09:11 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments
distorded widnow (shot1.jpeg,180.75 KB, image/jpeg)
2009-03-09 12:07 UTC, Migo
Details
distorded widnow (shot2.jpeg,225.56 KB, image/jpeg)
2009-03-09 12:08 UTC, Migo
Details
distorded widnow (shot3.jpeg,246.84 KB, image/jpeg)
2009-03-09 12:08 UTC, Migo
Details
distorded widnow (shot4.jpeg,335.55 KB, image/jpeg)
2009-03-09 12:21 UTC, Migo
Details
My xorg.conf file (xorg.conf.txt,4.64 KB, text/plain)
2009-03-10 08:27 UTC, Migo
Details
My emerge --info output (emerge-info.txt,5.73 KB, text/plain)
2009-03-10 08:27 UTC, Migo
Details
My Xorg.0.log file (xorglog.txt,56.28 KB, text/plain)
2009-03-10 11:05 UTC, Migo
Details
drawing error in status bar (shot1.png,69.10 KB, image/png)
2009-06-05 19:54 UTC, Christopher Schwan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Migo 2009-03-09 12:00:08 UTC
Hello,

After upgrade QT to 4.5.0 KDE 4.2.0 randomly show distorted windows, Next day I upgraded to KDE 4.2.1 without effect. I attach few screen shots.

Reproducible: Sometimes

Steps to Reproduce:
I don't know how to reproduce it, after few hours of running several programs (PSI, QT Creator, Kmail, Firefox 3.0.5, pgAdminIII 1.8.4)
Comment 1 Migo 2009-03-09 12:07:55 UTC
Created attachment 184445 [details]
distorded widnow
Comment 2 Migo 2009-03-09 12:08:17 UTC
Created attachment 184446 [details]
distorded widnow
Comment 3 Migo 2009-03-09 12:08:38 UTC
Created attachment 184447 [details]
distorded widnow
Comment 4 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-09 12:09:36 UTC
raster useflag enabled on qt?
Comment 5 Migo 2009-03-09 12:21:09 UTC
Created attachment 184450 [details]
distorded widnow
Comment 6 Migo 2009-03-09 12:24:11 UTC
(In reply to comment #4)
> raster useflag enabled on qt?
> 

It's my USE flags, I don't want raster because I want to use in future compis of kde effects.

x11-libs/qt-gui-4.5.0  USE="accessibility cups dbus glib gtkstyle mng pch qt3support tiff -custom-cxxflags -debug -nas -nis -raster -xinerama"
x11-libs/qt-4.5.0  USE="dbus opengl qt3support"
Comment 7 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-09 18:38:29 UTC
Ok am i right that this is xf86-video-ati driver?
Comment 8 Migo 2009-03-09 18:44:05 UTC
(In reply to comment #7)
> Ok am i right that this is xf86-video-ati driver?
> 

Its xf86-video-intel driver (I tried latest from portage)
Comment 9 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-09 18:47:26 UTC
This really looks more like driver rendering issue.
I will cc x11 team to tell me if i am correct (even driver developers make mistakes ;])
Comment 10 Migo 2009-03-09 18:52:02 UTC
(In reply to comment #9)
> This really looks more like driver rendering issue.
> I will cc x11 team to tell me if i am correct (even driver developers make
> mistakes ;])
> 

I don't have that problems at home (nvidia closed drivers) so I agree with your theory
Comment 11 Robert Piasek (RETIRED) gentoo-dev 2009-03-09 21:10:04 UTC
(In reply to comment #10)
> (In reply to comment #9)
> > This really looks more like driver rendering issue.
> > I will cc x11 team to tell me if i am correct (even driver developers make
> > mistakes ;])

Looks like a driver problem to me as well.
Could you also attach your emerge --info and xorg.conf please?

Thanks,
Rob
Comment 12 Migo 2009-03-10 08:27:07 UTC
Created attachment 184537 [details]
My xorg.conf file
Comment 13 Migo 2009-03-10 08:27:55 UTC
Created attachment 184539 [details]
My emerge --info output
Comment 14 Rémi Cardona gentoo-dev 2009-03-10 09:40:00 UTC
Your Xorg.0.log would be more helpful.

Thanks
Comment 15 Migo 2009-03-10 11:05:27 UTC
Created attachment 184549 [details]
My Xorg.0.log file
Comment 16 Christopher Schwan 2009-06-05 19:51:51 UTC
Can confirm this bug (with xf86-video-intel-2.6.3-r1 & KDE 4.2.4), but upgrading to xf86-video-intel-2.7.1 seems to _partially_ solve the issue. One remaining problem is that Konqueror's status bar gets not repainted.
Comment 17 Christopher Schwan 2009-06-05 19:54:24 UTC
Created attachment 193653 [details]
drawing error in status bar
Comment 18 Christopher Schwan 2009-07-15 12:45:05 UTC
I'm very sure that this a graphics driver bug. I my case it works perfectly well with KMS enabled (xf86-video-intel-2.7.1, gentoo-sources-2.6.30-r2, xorg-server-1.6.2-r1) and raster-useflag disabled.
Comment 19 Maciej Mrozowski gentoo-dev 2009-08-05 17:07:29 UTC
Removing block on bug 277868 then.
Comment 20 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 02:22:32 UTC
what about newer packages? (kernel, drivers, kde/qt)
Comment 21 Christopher Schwan 2010-04-09 08:04:05 UTC
After upgrading as described in #18 this problem never appeared again - at least on my system. I still think its the intel-driver which is to blame because upgrading and using KMS did it (maybe the problem was caused by older - and now deprecated - graphics acceleration architectures like EXA / XAA ?).
Comment 22 Andreas K. Hüttel gentoo-dev 2010-04-09 09:11:14 UTC
OK, closing since the affected package x11-drivers/xf86-video-intel-2.6... is long gone from the tree.