Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261531 - >=x11-drivers/xf86-video-intel-2.6.2: Xv use crashes X
Summary: >=x11-drivers/xf86-video-intel-2.6.2: Xv use crashes X
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo X packagers
URL: https://bugs.freedesktop.org/show_bug...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-07 08:17 UTC by Bob Raitz
Modified: 2009-07-14 22:41 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
xf86-video-intel-9999.ebuild (xf86-video-intel-9999.ebuild,852 bytes, text/plain)
2009-03-10 06:57 UTC, Rémi Cardona
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Raitz 2009-03-07 08:17:21 UTC
After installation of xf86-video-intel-2.6.3, I can no longer play a DVD via kaffeine. The program will have one of three observed behaviors:
1) As soon as the DVD starts to play, the screen blanks, and I am returned to CLI.
2) The audio will play, but there is a green screen in the viewing area
3) When I exit KDE, the screen goes black, and Skinny Elephants are useless. I have to hold down the power button.

Reproducible: Always

Steps to Reproduce:
1. Install xf86-video-intel-2.6.3
2. Attempt to play DVD
3. Kaffeine halts.
4. X bails out to CLI.
5. If X is restarted, when exited, it locks the machine.

Actual Results:  
Kaffeine and X fail with xf86-video-intel-2.6.3 while trying to view DVD.

Expected Results:  
I expected kaffeine to play DVD's properly without killing my computer.

pappy-lap ~ # emerge --info
Portage 2.2_rc23 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.9_p20081201-r2, 2.6.27-gentoo-r8 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-i686-Intel-R-_Celeron-R-_M_CPU_440_@_1.86GHz-with-glibc2.0
Timestamp of tree: Fri, 06 Mar 2009 06:35:01 +0000
distcc 3.1 i486-pc-linux-gnu [enabled]
app-shells/bash:     3.2_p48-r1
dev-lang/python:     2.5.4-r2
dev-python/pycrypto: 2.0.1-r8
dev-util/cmake:      2.6.2
sys-apps/baselayout: 1.12.12
sys-apps/sandbox:    1.3.9
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.19.1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.28-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i486-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe"
CHOST="i486-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distcc distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://192.168.0.130/gentoo-portage"
USE="X a52 aac acl acpi alsa ao audiofile avi bash-completion berkdb bitmap-fonts bzip2 cairo cdr cli cracklib crypt css cups dbus dlloader dri dts dv dvd dvdr dvdread eds encode fam fbcon ffmpeg fftw flac foomaticdb fortran gdbm gif gimp glib gpm gsl gtk hal iconv ipv6 isdnlog jack jpeg kde ladspa lame ldap libsamplerate mad midi mikmod mmx mp3 mpeg mudflap nas ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl php png ppds pppd python qt3 quicktime readline reflection samba sdl session slang slp sndfile spell spl sse sse2 ssl swat sysfs tcpd theora tiff truetype udev unicode usb v4l v4l2 vidix vorbis wifi win32codecs wxwindows x264 x86 xine xml xorg xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="intel v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Bob Raitz 2009-03-07 08:19:57 UTC
Downgrading to xf86-video-intel-2.6.1 solved the issue temporarily. Things operate normally with that driver version.
Comment 2 Lars Wendler (Polynomial-C) gentoo-dev 2009-03-07 09:15:03 UTC
Reassigning to x11 herd.
Comment 3 Rémi Cardona gentoo-dev 2009-03-07 10:37:03 UTC
Thanks for doing the grunt work of downgrading to check which bits caused the bug.

Please file a bug over in FreeDesktop's bugzilla so that Intel devs can solve this bug. This document [1] will explain what these guys need.

If you do, please paste the url here so we can keep track of the issue.

Thanks again
Comment 4 Bob Raitz 2009-03-07 20:13:15 UTC
(In reply to comment #3)
> Thanks for doing the grunt work of downgrading to check which bits caused the
> bug.
> 
> Please file a bug over in FreeDesktop's bugzilla so that Intel devs can solve
> this bug. This document [1] will explain what these guys need.
> 
> If you do, please paste the url here so we can keep track of the issue.
> 
> Thanks again
> 

DONE: https://bugs.freedesktop.org/show_bug.cgi?id=20525


Comment 5 Rémi Cardona gentoo-dev 2009-03-08 14:13:08 UTC
Alright, thanks for doing this.

Now upstream would like you to bisect the driver. That means using git's "bisect" command which will help cut down the number of commits to test to find the broken one.

Here's how you can do that without messing up your system :

- in a local dir, run : "git clone git://anongit.freedesktop.org/xorg/driver/xf86-video-intel"
- cd xf86-video-intel
- git bisect start
- git bisect good xf86-video-intel-2.6.1
- git bisect bad 2.6.3

Git bisect will now give you a commit number, copy it.

- grab the xf86-video-intel-9999 ebuild from the x11 overlay [1] and copy it to a local overlay
- edit the ebuild to have the following *before* the "inherit" line :
EGIT_TREE="<commit number>"
- run : ebuild xf86-video-intel-9999 digest

and emerge that ebuild, do your testing.

For every test that you do, run either "git bisect good" or "git bisect bad" if the driver works properly or not. After each bisect command, git will give you another commit number to try. Edit the ebuild, re-digest it and re-emerge the driver. Lather, rinse, repeat.

Phew, that was long :)

Hope you're able to get through that, if you have any questions, don't hesitate to ask here or come talk to us on #gentoo-desktop on FreeNode.

Thanks
Comment 6 Bob Raitz 2009-03-09 00:17:42 UTC
(In reply to comment #5)
> Alright, thanks for doing this.
> 
> Now upstream would like you to bisect the driver. That means using git's
> "bisect" command which will help cut down the number of commits to test to find
> the broken one.
> 
> Here's how you can do that without messing up your system :
> 
> - in a local dir, run : "git clone
> git://anongit.freedesktop.org/xorg/driver/xf86-video-intel"
> - cd xf86-video-intel
> - git bisect start
> - git bisect good xf86-video-intel-2.6.1
> - git bisect bad 2.6.3
> 
> Git bisect will now give you a commit number, copy it.
> 
> - grab the xf86-video-intel-9999 ebuild from the x11 overlay [1] and copy it to
> a local overlay
> - edit the ebuild to have the following *before* the "inherit" line :
> EGIT_TREE="<commit number>"
> - run : ebuild xf86-video-intel-9999 digest
> 
> and emerge that ebuild, do your testing.
> 
> For every test that you do, run either "git bisect good" or "git bisect bad" if
> the driver works properly or not. After each bisect command, git will give you
> another commit number to try. Edit the ebuild, re-digest it and re-emerge the
> driver. Lather, rinse, repeat.
> 
> Phew, that was long :)
> 
> Hope you're able to get through that, if you have any questions, don't hesitate
> to ask here or come talk to us on #gentoo-desktop on FreeNode.
> 
> Thanks
> 
You're telling me! I'll see what happens. Hopefully, the commit is early on, not the last house on the block.

Comment 7 Bob Raitz 2009-03-09 00:45:47 UTC
the xf86-video-intel-9999 I have isn't doing anything but failing, badly. Here's what I get: 

pappy-lap ~ # emerge -av =xf86-video-intel-9999
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] x11-drivers/xf86-video-intel-9999 [2.6.1] USE="dri -debug" 0 kB [0=>1]

Total: 1 package (1 upgrade), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage

Would you like to merge these packages? [Yes/No] 

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) x11-drivers/xf86-video-intel-9999 from Local Portage Overlay
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
 * 
 * ERROR: x11-drivers/xf86-video-intel-9999 failed.
 * Call stack:
 *                      ebuild.sh, line   49:  Called pkg_setup
 *   xf86-video-intel-9999.ebuild, line   37:  Called built_with_use 'x11-base/xorg-server' 'dri'
 *                  eutils.eclass, line 1763:  Called die
 * The specific snippet of code:
 *   					die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   x11-base/xorg-server-1.5.3-r3 does not actually support the dri USE flag!
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/die.env'.
 * This ebuild is from an overlay named 'Local Portage Overlay': '/usr/local/portage/'
 * 

>>> Failed to emerge x11-drivers/xf86-video-intel-9999, Log file:

>>>  '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/build.log'

I have no idea why this is happening. I don't see git sources winding up anywhere. All I have is a failing ebuild.
Comment 8 Rémi Cardona gentoo-dev 2009-03-09 07:49:07 UTC
Hum, that's weird, it works fine here. Please make sure your portage tree is up to date as I did some changes to the x-modular eclass a couple days ago.

Please also make sure you have the latest version of xorg-server (1.5.3-r3) installed.

Thanks
Comment 9 Bob Raitz 2009-03-09 22:59:35 UTC
(In reply to comment #8)
> Hum, that's weird, it works fine here. Please make sure your portage tree is up
> to date as I did some changes to the x-modular eclass a couple days ago.
> 
> Please also make sure you have the latest version of xorg-server (1.5.3-r3)
> installed.
> 
> Thanks
> 

I sync daily. Please send me your ebuild, and I'll give it a try. You can do so privately so as not to make this thread longer than necessary. I'm not sure my ebuild is up to date. Thanks.
Comment 10 Rémi Cardona gentoo-dev 2009-03-10 06:57:37 UTC
Created attachment 184532 [details]
xf86-video-intel-9999.ebuild

This one should work.

Thanks
Comment 11 Bob Raitz 2009-03-10 08:04:29 UTC
(In reply to comment #10)
> Created an attachment (id=184532) [edit]
> xf86-video-intel-9999.ebuild
> 
> This one should work.
> 
> Thanks
> 
Unfortunately, it doesn't. It downloads whatever, and makes it into a .pack file. The pack file doesn't get decompressed into it's working directory, and it comes up with the following error:

>>> Emerging (1 of 1) x11-drivers/xf86-video-intel-9999 from Local Portage Overlay
 * checking ebuild checksums ;-) ...                                     [ ok ]
 * checking auxfile checksums ;-) ...                                    [ ok ]
 * checking miscfile checksums ;-) ...                                   [ ok ]
>>> Unpacking source...
 * git update start -->
 *    repository: git://anongit.freedesktop.org/git/xorg/driver/xf86-video-intel
 *    local clone: /usr/portage/distfiles/git-src/xf86-video-intel
 *    committish: f1ed73c1ef3e3daa9f695194dcc813167cbcb53d
fatal: not a tree object
tar: This does not look like a tar archive
tar: Exiting with failure status due to previous errors
>>> Unpacked to /var/tmp/portage/x11-drivers/xf86-video-intel-9999/work/xf86-video-intel-9999
>>> Source unpacked in /var/tmp/portage/x11-drivers/xf86-video-intel-9999/work
>>> Compiling source in /var/tmp/portage/x11-drivers/xf86-video-intel-9999/work/xf86-video-intel-9999 ...
make -j4 
make: *** No targets specified and no makefile found.  Stop.
 * 
 * ERROR: x11-drivers/xf86-video-intel-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3117:  Called x-modular_src_compile
 *             environment, line 3897:  Called x-modular_src_make
 *             environment, line 3936:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed
 * 
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/environment'.
 * This ebuild is from an overlay named 'Local Portage Overlay': '/usr/local/portage/'
 * 

>>> Failed to emerge x11-drivers/xf86-video-intel-9999, Log file:

>>>  '/var/tmp/portage/x11-drivers/xf86-video-intel-9999/temp/build.log'


Comment 12 Rémi Cardona gentoo-dev 2009-03-10 10:46:11 UTC
Wow, this is _really_ weird, I have no idea what's going on here...

Does the -9999 ebuild work if you don't modify it (ie, the one directly from the x11 overlay)?

Thanks
Comment 13 Bob Raitz 2009-03-10 19:28:04 UTC
(In reply to comment #12)
> Wow, this is _really_ weird, I have no idea what's going on here...
> 
> Does the -9999 ebuild work if you don't modify it (ie, the one directly from
> the x11 overlay)?
> 
> Thanks
> 
No, it doesn't. It looks to me as if there is no decompression being done to the .pack file, or whatever is supposed to make this work. If I'm supposed to work to find which commit screwed me, I need to get a workable ebuild. There is no way I want to mess with my systems without being able to return to "stable".
Comment 14 Rémi Cardona gentoo-dev 2009-03-11 10:02:53 UTC
I think your git install might be broken. The -9999 ebuilds have been working correctly for months (if not years).

Please try to remerge git, or something else, I don't know.

Thanks
Comment 15 Rémi Cardona gentoo-dev 2009-03-14 08:52:46 UTC
FTR, it's not limited to DVDs, nor to KDE, nor to 945 :)

I think I'll push commits that revert the changes. I'll just wait for upstream to comment a bit first.

Thanks
Comment 16 Bob Raitz 2009-03-14 20:24:56 UTC
(In reply to comment #15)
> FTR, it's not limited to DVDs, nor to KDE, nor to 945 :)
> 
> I think I'll push commits that revert the changes. I'll just wait for upstream
> to comment a bit first.
> 
> Thanks
> 
Yes, it also happens with gen-tosh, my old Toshiba laptop, and it has an I830 chipset. I haven't noticed it do it outside of kaffeine, but considering what I saw while bisecting, yes, it could affect other things.
Comment 17 Rémi Cardona gentoo-dev 2009-03-21 08:24:45 UTC
reopening
Comment 18 Rémi Cardona gentoo-dev 2009-03-21 08:26:29 UTC
I've committed 2.6.3-r1 which contains a backport of the upstream fix.

This patch fixed the bug on my laptop.

Closing fixed. Please don't hesitate to reopen this bug if the issue is still there.

Thanks
Comment 19 Bob Raitz 2009-03-21 17:14:13 UTC
(In reply to comment #18)
> I've committed 2.6.3-r1 which contains a backport of the upstream fix.
> 
> This patch fixed the bug on my laptop.
> 
> Closing fixed. Please don't hesitate to reopen this bug if the issue is still
> there.
> 
> Thanks
> 

I'm going to give it a test here in a few. Thanks for the heads-up and I will definitely let you know if I find a problem.
Comment 20 Anthoine Bourgeois 2009-04-13 18:35:16 UTC
I've still the same bug with x11-base/xorg-server-1.5.3-r5 and x11-drivers/xf86-video-intel-2.6.3-r1.

My emerge --info below :

Portage 2.1.6.7 (default/linux/amd64/2008.0, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.27-gentoo-r8 x86_64)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-x86_64-Intel-R-_Core-TM-2_Duo_CPU_L7500_@_1.60GHz-with-glibc2.2.5
Timestamp of tree: Mon, 13 Apr 2009 15:45:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.5.2-r7
dev-util/cmake:      2.4.8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/
revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.free.fr/mirrors/ftp.gentoo.org http://distfiles.gentoo.org http://www.ibiblio.org/pub/L
inux/distributions/gentoo"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --s
tats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 audiofile berkdb bzip2 cdda cddb cdio cli cracklib crypt cscope cups dbus dri 
dvd dvdr dvdread fbcondecor ffmpeg firefox flac fortran gdbm gnome gpm gstreamer gtk hal iconv id3 ipv6 isdnlog j
ava jpeg midi mmx mp3 mpeg mudflap multilib musepack ncurses nls nptl nptlonly nsplugin ogg opengl openmp pam pcr
e pdf perl png pppd python readline reflection rtsp samba sdl session spl sse sse2 sse2sse3 ssl ssse3 svg sysfs t
cpd theora tiff unicode vorbis x264 xorg xulrunner xvmc zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt8
7x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="intel"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

I had some problems after the xorg upgrade and I fixed it by removing my xorg.cfg. Is there another package to rebuild besides xf86-video-intel ?
Comment 21 Bob Raitz 2009-04-14 06:02:16 UTC
(In reply to comment #19)
> (In reply to comment #18)
> > I've committed 2.6.3-r1 which contains a backport of the upstream fix.
> > 
> > This patch fixed the bug on my laptop.
> > 
> > Closing fixed. Please don't hesitate to reopen this bug if the issue is still
> > there.
> > 
> > Thanks

This issue remains. Is there any movement in this at all?
> > 
> 
> I'm going to give it a test here in a few. Thanks for the heads-up and I will
> definitely let you know if I find a problem.
> 

Comment 22 Alexander Tsoy 2009-04-14 21:32:26 UTC
I have the same issue. Xorg crashes when using Xv extension.
xf86-video-intel-2.6.3-r1
x11-base/xorg-server-1.5.3-r5
Comment 23 Anthoine Bourgeois 2009-04-15 21:13:16 UTC
# git bisect start
# git bisect good xf86-video-intel-2.6.1
# git bisect bad 2.6.3

I find this commit :
8ef4eb50193a849cb9fd0d7a85c6814e1d473101 is first bad commit
commit 8ef4eb50193a849cb9fd0d7a85c6814e1d473101
Author: Eric Anholt <eric@anholt.net>
Date:   Mon Jan 19 14:43:20 2009 -0800

    Do check_aperture_space and batch_start_atomic for i965 video.

How can I help more ?
Comment 24 Rémi Cardona gentoo-dev 2009-04-19 13:21:07 UTC
I've commented on the upstream bug: you should open a new bug in FreeDesktop's bugzilla as the bug seems to be different enough.

Don't forget to add "remi@gentoo.org" as a CC on the new bug so I can keep track of it.

Thanks
Comment 25 Bob Raitz 2009-04-19 18:01:00 UTC
(In reply to comment #24)
> I've commented on the upstream bug: you should open a new bug in FreeDesktop's
> bugzilla as the bug seems to be different enough.
> 
> Don't forget to add "remi@gentoo.org" as a CC on the new bug so I can keep
> track of it.
> 
> Thanks
> 
I'll take care of that later on today. Thanks for the heads-up.

BB!
P
Comment 26 David Raison 2009-07-14 00:01:21 UTC
Problem still persists. Or doesn't it? If it's fixed, please indicate where or the link to the second upstream bug report. Thanks!

xf86-video-intel-2.6.3-r1
gentoo-sources-2.6.28-r5
xorg-server-1.5.3-r6

Comment 27 Bob Raitz 2009-07-14 07:24:54 UTC
(In reply to comment #26)
> Problem still persists. Or doesn't it? If it's fixed, please indicate where or
> the link to the second upstream bug report. Thanks!
> 
> xf86-video-intel-2.6.3-r1
> gentoo-sources-2.6.28-r5
> xorg-server-1.5.3-r6
> 

With that driver version, yes, it still persists. However, I am currently using x11-drivers/xf86-video-intel-2.7.1, 2.6.29-zen2, and x11-base/xorg-server-1.6.2-r1, and apart from the occasional nifty color patterns when X exits, it works.
Comment 28 David Raison 2009-07-14 10:29:39 UTC
> With that driver version, yes, it still persists. However, I am currently using
> x11-drivers/xf86-video-intel-2.7.1, 2.6.29-zen2, and
> x11-base/xorg-server-1.6.2-r1, and apart from the occasional nifty color
> patterns when X exits, it works.


Well, then the issue ain't fixed in my eyes. Sorry for the bickering, but I can't see how a bug is resolved when you have to install another unstable version of software that may bring other problems (Your combination, for instance, gives me nothing but a black screen) 
"Stable" is supposed to work isn't it? I can see that yes, upstream may have fixed the bug in a more recent version of their driver but this "it's fixed in ~arch" leads to new problems instead of having a stable release that actually allows everyone to get his work done.
Comment 29 Bob Raitz 2009-07-14 18:07:52 UTC
(In reply to comment #28)
> > With that driver version, yes, it still persists. However, I am currently using
> > x11-drivers/xf86-video-intel-2.7.1, 2.6.29-zen2, and
> > x11-base/xorg-server-1.6.2-r1, and apart from the occasional nifty color
> > patterns when X exits, it works.
> 
> 
> Well, then the issue ain't fixed in my eyes. Sorry for the bickering, but I
> can't see how a bug is resolved when you have to install another unstable
> version of software that may bring other problems (Your combination, for
> instance, gives me nothing but a black screen) 
> "Stable" is supposed to work isn't it? I can see that yes, upstream may have
> fixed the bug in a more recent version of their driver but this "it's fixed in
> ~arch" leads to new problems instead of having a stable release that actually
> allows everyone to get his work done.
> 
I'm with you on that one...but fixing a bug via attrition is valid. I'm doubly with you because I had to stick with 2.6.1 until 2.7.1 came out. However, it's not like either one of us is going to change the course of the river that is open source software. Therefore, I accept that things aren't always going to go my way.

It was nearly a year before I could watch a DVD on this machine without wanting to chuck it out my third story window. I stuck with it, and things got better.

If you want a better chance of things working right, switch to a .27 kernel. They are the last kernel versions untouched by GEM and other Intel killers.
Comment 30 Rémi Cardona gentoo-dev 2009-07-14 22:41:27 UTC
I know that this is a frustrating situation but _please_ understand that I don't have the knowledge nor the resources to fix those kinds of bugs.

I just make sure that things build correctly in our packages and I forward bug reports to upstream.

It's all I do because it's all I _can_ do.

Thank you all for your patience.