Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 26149 - Ebuilds that ignore distcc
Summary: Ebuilds that ignore distcc
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Lisa Seelye (RETIRED)
URL:
Whiteboard:
Keywords:
: 25677 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-08-07 12:36 UTC by Lisa Seelye (RETIRED)
Modified: 2004-03-08 11:41 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lisa Seelye (RETIRED) gentoo-dev 2003-08-07 12:36:25 UTC
This is going to be a meta bug that lists all of the ebuilds that ignore distcc 
(for whatever reason).
Comment 1 Lisa Seelye (RETIRED) gentoo-dev 2003-08-07 12:37:26 UTC
*** Bug 25677 has been marked as a duplicate of this bug. ***
Comment 2 Lisa Seelye (RETIRED) gentoo-dev 2003-08-07 12:38:16 UTC
So far, from bug 25677
app-text/openjade-1.3.2-r1
media-libs/gle-3.0.1-r2
x11-misc/xscreensaver-4.11
gnome-base/ORBit-0.5.17
app-arch/zip-2.3-r2
Comment 3 Lisa Seelye (RETIRED) gentoo-dev 2003-08-07 13:54:18 UTC
openjade, zip and gle were fixed.  They just needed a s/make/emake in src_compile().

ORBit has a note in the ebuild about "-j4 not working" so I won't touch that one.
Comment 4 Svein Erik Brostigen 2003-08-07 15:49:28 UTC
kdemultimedia-3.1.3 is also not using distcc 
 
Comment 5 Svein Erik Brostigen 2003-08-07 18:15:22 UTC
kdepim-3.1.3 is another one. 
 
Comment 6 Jeroen 2003-08-22 07:04:09 UTC
x11-base/xfree-4.3.0-r2 (maybe other versions as well)
As far as I understand this is due to the stripping of unsafe flags by the ebuild: lines 16-36 of xfree-4.3.0-r2.ebuild
Comment 7 klavs klavsen 2003-08-22 10:20:13 UTC
ARGHHH!! compiling XFree and KDE on a PII-233mhz machine.. I'm really bugged that I have to select an older version of XFree to compile it within a day (using distcc) - it's reaaaaaaaly slow going on localhost only :(

How are you doing with fixing this xfree ebuild? and what are the flags that make gcc use distcc? I'd like to know - then I could try and fix the ebuild my self (forcing those flags to not be cleared) and see if it still works..
Comment 8 Lisa Seelye (RETIRED) gentoo-dev 2003-08-22 10:24:39 UTC
There are comments inside the xfree .ebuild that explain why it fails with parallel builds.  Its an upstream Makefile problem, essentially.
Comment 9 Brad Grzesiak 2003-08-23 19:42:53 UTC
ffmpeg 0.4.7_pre20030624

As far as I could tell (by observing progress through top), this ebuild does not use distcc.
Comment 10 Brad Grzesiak 2003-08-23 20:15:59 UTC
transcode 0.6.6

Same problem as ffmpeg

Is it safe to assume that if an ebuild uses 'make' instead of 'emake', then it won't utilize distcc?  Is it also safe to assume (in general with some exceptions) that making the change s/make/emake will fix this?
Comment 11 Lisa Seelye (RETIRED) gentoo-dev 2003-08-23 20:32:16 UTC
Yeah. If an ebuild doesn't use emake it won't follow MAKEOPTS.  Usually its safe to just s/make/make/, but check bugzilla first for parallel build problems, and test it first.
Comment 12 Luke Maurer (Jyrinx) 2003-09-01 18:23:51 UTC
Samba also appears to ignore distcc. The ebuild does indeed use make instead of emake, and I couldn't find any bugs about parallel-building samba ... in a bit, I'll get a chance to try the ol' s/make/emake.
Comment 13 Luke Maurer (Jyrinx) 2003-09-03 20:19:16 UTC
Yep ... I just changed all the makes to emakes (5 in total) in the .ebuild, and it compiled happily.
Comment 14 Rob Davies 2003-09-24 07:19:47 UTC
Where ebuilds have an issue with parallel builds, it would be better handled  
by removing the -j option in MAKEOPTS (or setting -j1), rather than disabling 
distcc entirely avoiding emake.  distcc can be useful for passing compiles off 
to a faster host from an old machine, used say as a firewall.  The alternative, 
building binary packages elsewhere is much less convenient (temporary USE & 
CFLAG changes on build machine). 
Comment 15 Svein Erik Brostigen 2003-10-01 15:22:40 UTC
unixODBC also ignores distcc
Comment 16 Svein Erik Brostigen 2003-10-30 17:40:47 UTC
openldap alos ignores distcc.
Comment 17 Svein Erik Brostigen 2003-10-30 17:48:16 UTC
glib also ignores distcc
Comment 18 Danny 2003-12-11 13:47:01 UTC
perl-tk seems to ignore distcc, it inherits from perl-module which uses make not emake.  Will fixing /usr/portage/eclass/perl-module.eclass break other perl things?
Comment 19 Danny 2003-12-11 13:55:52 UTC
media-tv/mythtv and media-tv/mythfrontend also ignore distcc
Comment 20 Rick Jenkins 2004-01-06 13:05:27 UTC
openssl seems to ignore distcc
Comment 21 Jonathan Adamczewski 2004-02-11 17:41:45 UTC
x11-libs/gtk+-2.2.4 seems to work with s/make/emake and MAKEOPTS="-j7"
Comment 22 Lisa Seelye (RETIRED) gentoo-dev 2004-03-04 19:14:36 UTC
I think this can be closed.  Some of these KDE things I have no chance to install since I don't have unlimited disk space to install KDE.

Refile any existing problems and assign them to the proper folk, cc me.
Comment 23 Lisa Seelye (RETIRED) gentoo-dev 2004-03-04 19:15:00 UTC
see comment 22
Comment 24 Johnny Cadavid 2004-03-08 11:41:12 UTC
Open Office actually ignores distcc when building from source. It took me 8 hours to compile. I looked at the activity on my distcc helper and there was no activity from distcc at all.