Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261260 - plasma starts with crash handler disabled
Summary: plasma starts with crash handler disabled
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High minor (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 313999
  Show dependency tree
 
Reported: 2009-03-05 08:18 UTC by renato gallo
Modified: 2010-05-16 12:33 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description renato gallo 2009-03-05 08:18:15 UTC
ps ax|grep plasma
 8384 pts/15   D+     0:00 grep --colour=auto plasma
26167 ?        Sl    11:21 plasma --nocrashhandler
30008 ?        S      0:00 kdeinit4: kio_file [kdeinit] file local:/tmp/ksocket-root/klauncherMT8027.slave-socket local:/tmp/ksocket-root/plasmaX26167.slave-socket

Reproducible: Always

Steps to Reproduce:
1.after a plasma crash open a terminal
2.ps ax|grep plasma


Actual Results:  
ps ax|grep plasma
 8384 pts/15   D+     0:00 grep --colour=auto plasma
26167 ?        Sl    11:21 plasma --nocrashhandler
30008 ?        S      0:00 kdeinit4: kio_file [kdeinit] file local:/tmp/ksocket-root/klauncherMT8027.slave-socket local:/tmp/ksocket-root/plasmaX26167.slave-socket

Expected Results:  
ps ax|grep plasma
 8384 pts/15   D+     0:00 grep --colour=auto plasma
26167 ?        Sl    11:21 plasma
30008 ?        S      0:00 kdeinit4: kio_file [kdeinit] file local:/tmp/ksocket-root/klauncherMT8027.slave-socket local:/tmp/ksocket-root/plasmaX26167.slave-socket

since plasma is still crashing and untill the brave devs will, as I am positively certain of, fix and improve everything to the best quality possible on planet earth, I would really need for now the crash handling function to be enabled.. thanks
Comment 1 Tomáš Chvátal (RETIRED) gentoo-dev 2009-03-05 15:34:55 UTC
Hm then tell us what needs to be changed where :]
Comment 2 renato gallo 2009-03-05 15:41:25 UTC
If I knew I would attach a patch I just would like plasma to start without the   nocrashhandler option.
(In reply to comment #1)
> Hm then tell us what needs to be changed where :]
> 

Comment 3 renato gallo 2009-04-20 08:53:32 UTC
news ?
Comment 4 Andreas K. Hüttel gentoo-dev 2010-02-21 20:59:14 UTC
Possibly fixed in 4.4.0 ???

huettel@pinacolada ~ $ ps ax|grep plasma
18854 ?        S      5:19 kdeinit4: plasma-desktop [kdeinit]
19543 pts/1    S+     0:00 grep --colour=auto plasma
huettel@pinacolada ~ $

Comment 5 Theo Chatzimichos (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2010-04-09 01:45:37 UTC
we'd like some feedback here, it seems fixed for 4.4.2, I couldn't crash my plasma but i tried to kill it.
Comment 6 Maciej Mrozowski gentoo-dev 2010-04-09 14:34:49 UTC
Plasma will most likely fallback to --nocrashhandler anyway when it detects that it has just crashed and automatically starts new 'failsafe' instance - this new instance will most likely have crash handler disabled.

Is this the case here? Or it's the first instance (the one run at startup) starts with crash handler disabled?
Comment 7 renato gallo 2010-04-09 18:06:22 UTC
at that time no instance had crash handler enabled and it could be nice to have it by default into the startup script

(In reply to comment #6)
> Plasma will most likely fallback to --nocrashhandler anyway when it detects
> that it has just crashed and automatically starts new 'failsafe' instance -
> this new instance will most likely have crash handler disabled.
> 
> Is this the case here? Or it's the first instance (the one run at startup)
> starts with crash handler disabled?
> 

Comment 8 Andreas K. Hüttel gentoo-dev 2010-05-16 12:33:09 UTC
No clue. Resolving it since it seems to work properly here. 

Feel free to reopen if you see the same behaviour on 4.4.2 or 4.4.3 ...