Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 261162 - kde-base/korganizer-4.2.0-r1: events multiply when a calendar resource is disabled and re-enabled
Summary: kde-base/korganizer-4.2.0-r1: events multiply when a calendar resource is dis...
Status: RESOLVED TEST-REQUEST
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo KDE team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-04 12:52 UTC by Marco Lui
Modified: 2010-04-07 21:12 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---
tampakrap: Bugday+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Lui 2009-03-04 12:52:18 UTC
After adding a calendar resource to korganizer, de-selecting and re-selecting it in the Show Resource View sidebar causes its entries to appear multiply.

Reproducible: Always

Steps to Reproduce:
1. Import an .ics calendar into KOrganizer
2. De-select the calendar in the Show Resource View sidebar
3. Select the calendar in the Show Resource View sidebar

Actual Results:  
Each deselect-reselect cycle duplicates all the entries in the calendar.

Expected Results:  
The entries in the calendar should not be duplicated.

emerge -pv korganizer                                                                                             (03-04 23:46)

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] kde-base/korganizer-4.2.0-r1  USE="kontact -debug -htmlhandbook -kdeprefix" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
emerge --info                                                                                                                    
Portage 2.2_rc23 (default/linux/amd64/2008.0/desktop, gcc-4.2.2, glibc-2.9_p20081201-r1, 2.6.26-rc5-zen1.0 x86_64)                                     
=================================================================                                                                                      
System uname: Linux-2.6.26-rc5-zen1.0-x86_64-Intel-R-_Core-TM-2_CPU_6420_@_2.13GHz-with-glibc2.2.5                                                     
Timestamp of tree: Tue, 03 Mar 2009 11:15:01 +0000                                                                                                     
app-shells/bash:     3.2_p48-r1                                                                                                                        
dev-java/java-config: 1.3.7-r1, 2.1.7                                                                                                                  
dev-lang/python:     2.4.4-r4, 2.5.4-r2                                                                                                                
dev-python/pycrypto: 2.0.1-r6                                                                                                                          
dev-util/cmake:      2.6.2                                                                                                                             
sys-apps/baselayout: 2.0.0                                                                                                                             
sys-apps/openrc:     0.4.3-r1                                                                                                                          
sys-apps/sandbox:    1.3.7                                                                                                                             
sys-devel/autoconf:  2.13, 2.63                                                                                                                        
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2                                                                                         
sys-devel/binutils:  2.19.51.0.1                                                                                                                       
sys-devel/gcc-config: 1.4.1                                                                                                                            
sys-devel/libtool:   2.2.6a                                                                                                                            
virtual/os-headers:  2.6.28-r1                                                                                                                         
ACCEPT_KEYWORDS="amd64 ~amd64"                                                                                                                         
CBUILD="x86_64-pc-linux-gnu"                                                                                                                           
CFLAGS="-O3 -march=nocona -fforce-addr -fomit-frame-pointer -ftracer -pipe"                                                                            
CHOST="x86_64-pc-linux-gnu"                                                                                                                            
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"                               
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"                                                                                            
CXXFLAGS="-O2 -pipe"                                                                                                                                    
DISTDIR="/usr/portage/distfiles"                                                                                                                        
FEATURES="distlocks fixpackages parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"       
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo/"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,--hash-style=gnu"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/zugaina /usr/local/portage/layman/sunrise /usr/local/portage/layman/zen-overlay /usr/portage/local/overlay"
SYNC="rsync://mirror.internode.on.net/gentoo-portage"
USE="X a52 acl acpi alsa amd64 arts avahi berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encodeesd evo fam firefox fortran gdbm gif glitz gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jack jpeg kde kdeenablefinal kdehiddenvisibility ldap libnotify mad mdnsresponder-compat midi mikmod mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl startup-notification svg sysfs tcpd theora tiff truetype unicode usb vorbis x264 xcomposite xinerama xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actionsalias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Sérgio Luís 2009-03-14 13:49:25 UTC
Can you attach your resource file?

~/.kde4/share/config/kresources/calendar/stdrc
Comment 2 Andreas K. Hüttel gentoo-dev 2010-02-25 23:01:30 UTC
Does this still happen in current KDE (4.3.5 or 4.4.0)?
Comment 3 Tomáš Chvátal (RETIRED) gentoo-dev 2010-04-07 21:12:01 UTC
Closing as test-request. Cant reproduce. Reopen if you still have the issue